Du bist nicht angemeldet.

#1 28.07.2006 20:38:06

nikaya
Gast

Keine Internetverbindung

Hallo Archies,
habe heute nach umfangreicher Lektüre AL 0.7.2 installiert.Ich komme von Gentoo und da hat mich vor allem interessiert ob das Buildsystem sowie das Paketmanagement da mithalten können.

Und nun:Kein Internet --> kein Pacman.Na toll <stunned>
Ich nutze einen DHCP-Router und habe in /etc/rc.conf schon alles mögliche probiert.Das ganze Netzwerk wird beim Systemstart nicht initialisiert.
"ifconfig" ergibt keine Ausgabe,ein Hostname wird nicht gesetzt (none).
Ich habe dann nochmal mit der Install-CD eine FTP-Installation versucht.Auch dies scheitert:"dhcpcd failed" oder so.Das Modul wird noch geladen,nur an dhcpcd scheitert es.
Unter anderen Betriebssystemen gibt es keinerlei Schrierigkeiten mit DHCP.

Weiß vielleicht jemand Rat,wäre schade wenn das mit AL schon so früh zu Ende geht.
Hier meine rc.conf damit keine Fragen entstehen:

# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/unimaps
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="de_DE.utf8"
HARDWARECLOCK="UTC"
TIMEZONE="Europe/Berlin"
KEYMAP="de-latin1-nodeadkeys"
CONSOLEFONT="lat9w-16
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by udev
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to blacklist it
#
MODULES=(8139too mii)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="archie"
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
#eth0="eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255"
eth0="dhcp"
INTERFACES=(lo eth0)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.241"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(main)

#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng !hotplug !pcmcia network netfs crond)


# End of file

#2 28.07.2006 21:39:45

bademeister
Mitglied

Re: Keine Internetverbindung

Hi,

nimm einfach das Ausrufezeichen vor "gateway" weg, dann funktioniert es
(sofern DHCP funktioniert, bzw. die Adressen stimmen).
Ansonsten mit festen Adressen testen.

Beispiel: ROUTES=(gateway)

Grüße

bademeister

Beitrag geändert von bademeister (28.07.2006 21:59:11)

Offline

#3 28.07.2006 22:28:15

nikaya
Gast

Re: Keine Internetverbindung

Funktioniert nicht.
Ich sagte es schon:Das ganze Netzwerk wird nicht gestartet.
"ifconfig" zeigt nichts an,nicht mal localhost "lo" :-0

#4 28.07.2006 23:39:17

bademeister
Mitglied

Re: Keine Internetverbindung

John Doe schrieb:

Funktioniert nicht.
Ich sagte es schon:Das ganze Netzwerk wird nicht gestartet.
"ifconfig" zeigt nichts an,nicht mal localhost "lo" :-0

Ok,

versuche heraus zu finden, ob der Treiber geladen wurde.

# lspci

sollte alle Geräte, darunter der LAN-Adapter (Ethernet controller) auflisten.
Schreibe mal, was lspci ergeben hat !

Entsprechend überprüfen, ob das Modul auch geladen wurde.
Zu finden mittels:

# lsmod | less

Beitrag geändert von bademeister (28.07.2006 23:39:40)

Offline

#5 29.07.2006 08:38:06

nikaya
Gast

Re: Keine Internetverbindung

Der Ethernet Controller wird gefunden.
lspci sagt:

00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400/A] Chipset Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:0d.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
00:0e.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

Das entsprechende Modul wäre 8139too,welches ich auch in rc.conf und nochmal in/etc/modprobe.conf eingetragen habe.Es wird beim Start jedoch auch nicht geladen.
Wenn ich es mit

modprobe 8139too

lade passiert allerdings auch nichts.

Beitrag geändert von nikaya (29.07.2006 08:42:10)

#6 29.07.2006 09:56:12

bademeister
Mitglied

Re: Keine Internetverbindung

Poste bitte was dmesg ergibt.

Offline

#7 29.07.2006 10:27:26

nikaya
Gast

Re: Keine Internetverbindung

OK,hat sich erledigt.
Ich habe eine Neuinstallation durchgeführt und es klappte sofort.
Ich habe zwar alles wie beim ersten Mal gemacht,aber nun funktionierte es "out of the box".
Keine Ahnung was da schief gelaufen ist.

Aber besten Dank für Deine Hilfe.

#8 29.07.2006 10:54:21

Pierre
Entwickler

Re: Keine Internetverbindung

Evtl. hattest Du einen veralteten Mirror erwischt...das ist manchmal ein ziemliches Problem.

Zu dem Gateway: Das braucht man bei DHCP gerade nicht manuell angeben.

Offline

#9 29.07.2006 11:18:27

nikaya
Gast

Re: Keine Internetverbindung

Nee,ist wohl irgendwas bei der Installation schief gelaufen.Wie gesagt,das ganze Netzwerk wurde nicht initialisiert.ping klappte nicht,sowohl mit Hostnamen,als auch über IP.Und wenn das Loopback schon nicht vorhanden ist,welches ja nur intern eine Verbindung aufbaut;kann es an den Mirrors nicht liegen.Es wurde ja nicht mal ein Hostname vergeben.
Ein

/etc/rc.d/network start

sagte irgendwas mit Syntaxfehler in Line ...

pierre schrieb:

Zu dem Gateway: Das braucht man bei DHCP gerade nicht manuell angeben.

Ja,ist schon klar.Aber man versucht in der Not ja alles.
Aber lange Rede,kurzer Sinn:Jetzt klappt es,bislang jedenfalls.Werde mich hier evtl. wieder melden,falls die Doku nicht weiter hilft.

Beitrag geändert von nikaya (29.07.2006 11:21:21)

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums