Du bist nicht angemeldet.

#1 18.07.2006 22:52:56

HiLL
Mitglied

W-Lan

Hallo zusammen,

ich habe ein Problem mit meinem W-Lan.
Folgendes, ich hab eine BenQ Joybook 5200G und will das W-Lan nutzen, ich hab allerdings ziemliche Probleme damit ... Ich habe es mal mit der Wiki versucht aber das hat mich nicht wirklich weiter gebracht. Die Ausgabe von hwd -s gibt mir aus das ich ein Intel-Chipsatz habe, was auch stimmt, es ist eine Pro2200. Es zeigt mir auch das dazugehörige Modul an, ist es dann auch schon geladen? Was mich verwundert ist das beim normalen Netzwerkanschluss, Realtek 8139,
eth0, eth1, eth2 steht, bei der Intel Karte steht allerdings gar nichts.

Ich hab auch recht viel gegoogelt zu dem Thema. Allerdings habe ich langsam das Gefühl das mein WLan gar nicht "aktiviert" ist.

Und könnte mir mal jemand erklären wie ich mein W-Lan mittels ifconfig, iwconfig konfiguriere.

Ich nutze bei meinem Router eine WPA-PSK Verschlüsselung, mit Windows hab ich null Probleme, habe bisher immer nur was von WEP Verschlüsselung bei Linux gelesen, kann Linux überhaupt WPA?

Wenn ich W-Lan unter Arch nutzen kann, ist Windows so gut wie tot bei mir:)

Freue mich über jede hilfreiche Antwort.
Gruß HiLL

Offline

#2 21.07.2006 15:04:18

dongiovanni
Mitglied

Re: W-Lan

hallo,

du kannst nachsehen ob das modul geladen ist, mit "lsmod" das zeigt alle geladenen module. mit "cat /proc/net/dev" siehst du, falls das modul das richtige ist und es richtig funktioniert, den device-namen (nicht eth0 etc. sondern z.B. wlan0, ra0).

Offline

#3 21.07.2006 20:23:13

HiLL
Mitglied

Re: W-Lan

hi,

also mit lsmod zeigt es mir an das ipw2200 geladen ist.
Wenn ich aber das cat /proc/net/dev eingebe zeigt es mir nur lo, eth0 und eth1 an und in der ganzen Tabelle steht überall ne 0.
Was muss ich jetzt machen???

HiLL

Offline

#4 22.07.2006 21:56:44

dongiovanni
Mitglied

Re: W-Lan

hallo,

hast du bereits die firmware installiert ( paket: ipw2200)? es is auch möglich das eth1 das device ist! das kannst du mit "iwlist scan" testen (wenn es keins ist, steht dahinter so was wie "Device doesn't support scanning". iwlist sucht nach drahtlosen netzwerken. davor muss man das device noch mit "ifconfig eth1 up" aktivieren.

Beitrag geändert von dongiovanni (22.07.2006 22:54:45)

Offline

#5 27.07.2006 20:36:20

HiLL
Mitglied

Re: W-Lan

Hallo zusammen,

also ich hab nun mal das ipw2200-fw Paket installiert. Und wolla, jetzt habe ich eth0 - 2. Allerdings spuckt mir eth2 IMMER folgende Mac-Adresse: 00-08-0D-03-9D-78-28-0F für was ist eht2 denn da, die mac ist doch viel zu lang, oder? Mein nächstes Problem, das eigentliche, eth0 und eth1 tauschen ständig die mac adresse und zwar nach jedem reboot.

Kennt jeamnd das Problem? Ich hoff doch...

Übrigens, die Mac-Adressen stimmen mit der Lan und W-Lan Karte überein.

Gruß HiLL

Offline

#6 27.07.2006 22:31:42

dongiovanni
Mitglied

Re: W-Lan

hallo,

der name mit dem zeitpunkt des ladens der module zusammen, da die namen dynamisch vergeben werden! das modul das zuerst geladen ist, bokommt eth0. mit "nameif" kann man die namen anhand der mac-adresse ändern. dies muss man aber machen, bevor das device aktiviert wird (mit ifconfig up). näheres in der man-page! man kann es auch irgendwie mit udev ändern.

Offline

Fußzeile des Forums