Du bist nicht angemeldet.

#1 13.07.2006 22:42:56

fallow
Mitglied

xmessage nicht vorhanden

hallo,

ich habe testweise arch aufgesetzt und bin im ersten eindruck ziemlich begeistert. leider habe ich noch zwie probleme. ich habe xorg mit fluxbox als wm laufen. leider lässt sich kein hintergrundbild setzen, da fbsetbg offenbar xmessage nutzt.

/usr/bin/fbsetbg: line 169: xmessage: command not found

afaik ist xmessage kein eigenes paket sondern teil von xterm. hat jemand einene idee, wie ich an xmessage komme?

zum anderen hab ich das problem, dass in vielen programmen (u.a. xmms, dillo) keine umlaute etc. dargestellt werden.

/etc/rc.conf:

LOCALE="de_DE.utf8"
HARDWARECLOCK="localtime"
TIMEZONE="Europe/Berlin"
KEYMAP="de-latin1-nodeadkeys"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

/etc/locale.gen

de_DE.UTF-8     UTF-8
de_DE   ISO-8859-1
de_DE@euro      ISO-8859-15

locale -a

locale -a
C
POSIX
de_DE
de_DE.iso88591
de_DE.iso885915@euro
de_DE.utf8
de_DE@euro
deutsch
german

gibt es dafür eine lösung oder muss ich damit lesen?

danke für eure mühe!

Offline

#2 14.07.2006 00:16:58

Pierre
Entwickler

Re: xmessage nicht vorhanden

Dann installiere doch mal xterm. wink

GTK kommt nicht wirklich mit utf klar. Du kannst entweder die schriftart auf z.B. Verdana ändern oder die Kodierung auf #ISO (für gtk-Programme) umstellen. Siehe auch: http://www.laber-land.de/?page=Postin... Falls ~/.gtkrc.mine nicht eingebudnen wird, kannst Du auch direkt ~/.gtkrc verwenden.

Offline

#3 14.07.2006 01:04:00

fallow
Mitglied

Re: xmessage nicht vorhanden

danke für deinen ratschlag, sieht zwar n bisschen komisch (schrift scheint zu groß geraten) aus, funktioniert aber gut.

Pierre schrieb:

Dann installiere doch mal xterm.

ich hätts vielleicht erwähnen sollen: xterm hab ich natürlich installiert...also woher gibts xmessage?

Offline

#4 14.07.2006 04:49:06

xxi
Mitglied

Re: xmessage nicht vorhanden

fallow schrieb:

ich hätts vielleicht erwähnen sollen: xterm hab ich natürlich installiert...also woher gibts xmessage?

xmessage liegt in dem xorg-clients Packet.

Beitrag geändert von xxi (14.07.2006 04:49:37)

Offline

#5 14.07.2006 18:06:22

fallow
Mitglied

Re: xmessage nicht vorhanden

super, jetzt läuft's. dank dir!

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums