#1 22.02.2006 15:39:35

matthias
Moderator

Tastaturbelegung Notebook

Hallo,

ich habe noch zwei Probleme bei den Einstellungen auf meinem Notebook, die ich hier besser mal getrennt behandele. Erstes Problem: Tastaturbelegung. Mir fehlen (einige) Deadkeys, u.a. für die Tilde (über AltGR), wo jedoch etwa das Pluszeichen funktioniert; die Taste mit Pipe-Zeichen läuft gar nicht. Allerdings kann ich mit Deadkeys Akzente auf Vokale setzen. Keyboard wurde korrekt als "pc105" erkannt. Ich habe bereits unterschiedliche Einstellungen durchprobiert, etwa in /etc/rc.conf unter locale=de_DE (oder de_DE@euro), unter KEYMAP= "de" oder "de-latin1". In /etc/X11/xorg.conf steht u.a
Option "XkbRules" "xfree86"
Option "XkbLayout" "de"
Option "XkbVariant" "latin1"
(müßte das vielleicht XkbLayout "de-latin1" heissen?)
Na, nur die beliebte Variante "de-latin1-nodeadkeys" habe ich bisher ausgelassen, da ich diese Tasten schon zum Arbeiten brauche ...
Bin für alle Ratschläge offen (und dankbar), S.

Offline

#2 22.02.2006 16:14:27

jakob
Mitglied

Re: Tastaturbelegung Notebook

Also:

/etc/rc.conf
die Einstellung

LOCALE=de_DE.utf-8

ist wohl die empfehlenswerte, hat aber keinerlei Einfluss auf das Tastaturlayout, sondern nur auf die Einstellung, in welchem Land sich dieser Rechner befindet und welche Enkodierung (hier utf-8, der quasi-Standard) er verwendet.

KEYMAP=de

bestimmt, dass in den virtuellen Konsolen (zu erreichen über Alt+F1-F6) in diesem Fall das deutsche Layout geladen wird, hat jedoch keinerlei Einfluss auf das Layout unter X, denn dafür ist die Einstellung in der

/etc/X11/xorg.conf

enfscheidend.

XkbLayout gibt dabei an, welche Tastutar du benutzt.

Jetzt müssen wir aber erst noch ne andere Sache klären: Deadkeys sind die Keys wie z.B. der ^ Circumflex neben der 1, der (normalerweise) erst beim 2. Anschlag erscheint, oder der Akut neben der Rücktaste ´. Diese Zeichen werden Deadkeys genannt, da beim 1. Anschlag nichts kommt. Sie werden benutzt, um z.B. Akzente zu setzen, oder Sachen wie ñ zu schreiben.

Nun schreibst du aber "Mir fehlen (einige) Deadkeys, u.a. für die Tilde (über AltGR), wo jedoch etwa das Pluszeichen funktioniert; die Taste mit Pipe-Zeichen läuft gar nicht. Allerdings kann ich mit Deadkeys Akzente auf Vokale setzen."

Dass du Akzente setzen kannst, heißt also, dass du Deadkeys hast smile. Ich nehme also an, du willst unter X gleich die Tilde haben und nicht erst nach dem 2. Tastendruck?

Dann sollten folgende Einstellung nötig sein:

/etc/X11/xorg.conf

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Ich hoffe, das funktioniert dann.

Theoretisch sollte noch folgende Option möglich sein:
Option "XkbVariant" "deadgraveacute"
Hiermit werden nur Akut ´ und Gravis ` dead gesetzt, Tilde ~ und Circumflex ^ bleiben alive.

Hoffe, dir halbwegs geholfen zu haben smile

Wie das mit ner Laptoptastatur genau ist (also, wo dann das Numpad auf der 3. Eben liegt und so) weiß ich leider nicht smile

MfG,

Jakob

Offline

#3 22.02.2006 16:42:15

matthias
Moderator

Re: Tastaturbelegung Notebook

hellwoofa schrieb:

Hoffe, dir halbwegs geholfen zu haben smile

Ja, allerdings - danke!
War natürlich mein Fehler, wenn ich die Bedeutung von "Deadkey" nicht richtig verstanden und zielsicher das ausgeschlossen habe, was ich eigentlich haben wollte *grins*
Ich habe die Einstellungen so angepasst, wie von Dir vorgeschlagen, und nun kann ich wenigstens die Tilde nutzen (brauche ich dringend für spanische Texte). Die Taste mit <,> und | funktioniert leider bisher nur, wenn ich X ausschalte - aber mit Hilfe Deiner Erklärung der Hintergründe kriege ich das hoffentlich selbst in den Griff, wenn ich noch ein paar Varianten ausprobiere.

Alles Gute, S.

Offline

#4 22.02.2006 17:21:40

jakob
Mitglied

Re: Tastaturbelegung Notebook

Hm, da bin ich jetzt etwas ratlos... was passiert denn, wenn du xev startest und "die Taste" mal drückst, also <?

Bei mir siehts so aus:

KeyPress event, serial 30, synthetic NO, window 0x1800001,
    root 0x11a, subw 0x0, time 2455316767, (163,-12), root:(321,171),
    state 0x10, keycode 94 (keysym 0x3c, less), same_screen YES,
    XLookupString gives 1 bytes: (3c) "<"
    XmbLookupString gives 1 bytes: (3c) "<"
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x1800001,
    root 0x11a, subw 0x0, time 2455316926, (163,-12), root:(321,171),
    state 0x10, keycode 94 (keysym 0x3c, less), same_screen YES,
    XLookupString gives 1 bytes: (3c) "<"

Wenn bei dir nichts, also gar nichts passiert, könnte das ein Hinweis darauf sein, dass die Taste evtl. klemmt , also gar kein Signal auslöst...++lol, bin ich doof, hast ja geschrieben, dass sie in der Konsole funktioniert, also scheint ein Brösel oder so wohl kaum das Problem zu sein *doh*++

MfG,

Jakob

Beitrag geändert von jakob (22.02.2006 17:23:27)

Offline

#5 23.02.2006 13:38:26

matthias
Moderator

Re: Tastaturbelegung Notebook

xev kannte ich noch nicht, ist ja ein nettes Spielzeug ... Die fragliche Taste brachte erst gar keine Ausgabe (NoSymbol, XLookupString gives 0 bytes usw.). Inzwischen habe ich die XkbRules auf "Xfree86" zurückgesetzt, und nun laufen alle Tasten wie gewünscht! (Ich habe halt das letzte Xorg-Upgrade noch nicht gemacht, weil das ja etwas problematisch ist.)

Also nochmals danke und aus, b.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums