Du bist nicht angemeldet.

#1 17.12.2005 15:15:12

Jürgen Vogt
Gast

Zwei Monitore und zwei Grafikkarten

Hallo Archgemeinde,

weihnachtliche Grüße an alle. Hier schneits gerade, 10 cm Schnee sind über nacht gefallen smile

So, nun meine Frage. Ich möchte unter Archlinux (derzeit 0.7.1) und KDE 3.5.0 und X.org 11R6.8.2-6 zwei 17"-Monitore an zwei Grafikkarten (beide AOpen FX-5200) betreiben. Die eine Grafikkarte hat einen AGP-Stecker, die andere einen PCI-Stecker.

Unter

http://www.linux-user.de/ausgabe/2001.../dual.html

habe ich auch viel lesenswertes gefunden. Der besagte Artikel ist von Hans-Georg Eßer und stammt aus dem Jahre 2001 (LinuxUser 12/2001: Dual Head)!

Zitat: "XFree86 erlaubt seit Version 4, mehrere Grafikkarten gleichzeitig zu verwenden; so kann zur AGP-Karte noch eine ältere PCI-Karte in den Rechner eingebaut werden, um einen zweiten Monitor zu betreiben. Eine Alternative sind Dual-Head-Karten mit zwei Monitor-Anschlüssen."

Woher bekomme ich XFree86 Version 4?

Mein pacman -Q xorg sagt:
xorg 11R6.8.2-6

Und das scheint nur XFree86 3.x zu enthalten. Das entnehme ich zumindest pacman:

[root@aikido ~]# pacman -Ql xorg | grep -i XFree86
xorg /etc/X11/xkb/compat/xfree86
xorg /etc/X11/xkb/keycodes/xfree86
xorg /etc/X11/xkb/keymap/xfree86
xorg /etc/X11/xkb/rules/xfree86
xorg /etc/X11/xkb/rules/xfree86-it.lst
xorg /etc/X11/xkb/rules/xfree86.lst
xorg /etc/X11/xkb/rules/xfree86.xml
xorg /usr/X11R6/lib/X11/config/xfree86.cf
xorg /usr/X11R6/man/man3/XFree86-DGA.3x

Wie kann ich rausfinden, welche XFree86-Version ich habe?
Enthält Xorg von Archlinux überhaupt XFree86 in der Version 4?

Auf Eure Antworten hoffend...

#2 17.12.2005 16:32:09

Pierre
Entwickler

Re: Zwei Monitore und zwei Grafikkarten

Hallo,

xorg ist ein Fork von XFree4.4. Dual-Head funktioniert also genauso auch mit xorg.

Offline

#3 17.12.2005 21:35:10

Jürgen Vogt
Gast

Re: Zwei Monitore und zwei Grafikkarten

Hallo Pierre,

nachdem ich jetzt zwei Tage lang an der xorg.conf rumgefummelt habe, habe ich in meiner Verzweifelung die Geforce FX5200 PCI-Karte aus dem Rechner rausgenommen und statt dessen eine alte PCI-Karte (ATI 3D RageIIC) eingebaut. Dann:

Xorg -configure

und

Xorg -config xorg.conf

Und es geht. Ich werde noch verrückt. Bisher dachte ich, ich bin zu blöd dafür bzw. der Fehler sitzt vorm Monitor, aber mit der alten PCI-Karte klappts jetzt. Das verstehe, wer will. Aber wieso gehts nicht mit der neuen PCI-Karte? Könntest Du mal einen Blick auf meine xorg.conf werfen?

AGP: FX5200 / PCI: ATI Mach64

Section "ServerLayout"
Identifier "X.org Configured and modified by Juergen Vogt AGP: FX 5200/PCI: ATI Mach64"
Screen 0 "Monitor_Rechts" 0 0
Screen 1 "Monitor_Links" LeftOf "Monitor_Rechts"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "extmod"
Load "record"
Load "glx"
Load "dbe"
Load "xtrap"
#Load "dri"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModell" "pc105"
Option "XkbLayout" "de"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "ZAxisMapping" "4 5"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
EndSection

Section "Monitor"
Identifier "Macom_S96D"
VendorName "Macom"
ModelName "S96D"
Option "DPMS"
HorizSync 30-96
VertRefresh 50-150
EndSection

Section "Monitor"
Identifier "Hansol_710A"
VendorName "Hansol"
ModelName "710A"
Option "DPMS"
HorizSync 30-75
VertRefresh 47-160
EndSection

Section "Device"
Identifier "Geforce_FX_5200_AGP"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV34 [GeForce FX 5200]"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "ATI_3D_Rage_IIC"
Driver "ati"
VendorName "ATI"
BoardName "3D Rage IIC 215IIC [Mach64 GT IIC]"
ChipSet "ati"
ChipId 0x4756
ChipRev 0x3a
BusID "PCI:0:9:0"
EndSection

Section "Screen"
Identifier "Monitor_Rechts"
Device "Geforce_FX_5200_AGP"
Monitor "Macom_S96D"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Monitor_Links"
Device "ATI_3D_Rage_IIC"
Monitor "Hansol_710A"
DefaultDepth 15
SubSection "Display"
Viewport 0 0
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

AGP: FX5200 / PCI: FX5200

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Monitor_Rechts" 0 0
Screen 1 "Monitor_Links" LeftOf "Monitor_Rechts"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "ddc" # ddc probing of monitor
Load "extmod"
Load "record"
Load "glx"
Load "dbe"
Load "xtrap"
# Load "dri" # Laut nVidia-ReadMe-Datei sollen die Module "dri" und "GLcore" deaktiviert werden
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbModell" "pc105"
Option "XkbLayout" "de"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "ZAxisMapping" "4 5"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
EndSection

Section "Monitor"
Identifier "Macom_S96D"
VendorName "Macom"
ModelName "S96D"
Option "DPMS"
HorizSync 30-96
VertRefresh 50-150
EndSection

Section "Monitor"
Identifier "Hansol_710A"
VendorName "Hansol"
ModelName "710A"
Option "DPMS"
HorizSync 30-75
VertRefresh 47-160
EndSection

Section "Device"
Identifier "Geforce_FX_5200_AGP"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV34 [GeForce FX 5200]"
BusID "PCI:1:0:0"
EndSection

Section "Device"
Identifier "Geforce_FX_5200_PCI"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV34 [GeForce FX 5200]"
BusID "PCI:0:9:0"
EndSection

Section "Screen"
Identifier "Monitor_Rechts"
Device "Geforce_FX_5200_AGP"
Monitor "Macom_S96D"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "Monitor_Links"
Device "Geforce_FX_5200_PCI"
Monitor "Hansol_710A"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

#4 23.12.2005 12:34:33

Jürgen Vogt
Gast

Re: Zwei Monitore und zwei Grafikkarten

So, ich habe eine Lösung gefunden. Wenn ich im BIOS (AMI und Award 4.51 PG) die Bootreihenfolge von AGP nach PCI umstelle, dann funktionierts mit den moderneren Grafikkarten auch.

Frohe Weihnachten, einen Guten Rutsch und ein frohes Neues Jahr...

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums