Du bist nicht angemeldet.

#1 20.04.2021 08:49:53

aik
Mitglied

Neuer Arbeitsrechner wird sporadisch unbenutzbar

Ahoihoi!

Ich habe eine neue Arbeitsstelle und darf dort endlich auf Applerechner verzichten und mir selbst das Betriebssystem installieren.
Ich habe arch nach Anleitung Moderne Installation mit UEFI und Verschlüsselung installiert, die benötigten Programme (und xf86-video-intel usw.) installiert und die wesentlichen dot-files von meinem Privat-PC rüberkopiert.
Soweit funktioniert auch alles - nur sporadisch frieren diverse Programme ein und "komische" sonstige Probleme treten auf
- kill (SIGTERM sowie SIGKILL) wird ignoriert bzw. es gibt nen timeout
- pcmanfm friert ein
- chrome verhält sich "komisch" - rocket.chat z.b. läd zwar und sendet mir auch notifications, ich sehe aber nur die ladespinner-punkte (auch nach chache leeren und reload etc.)
- gleiches bei electron programmen (auch rocket chat)
- xterm reagiert auf viele eingaben (history scrollen mit pfeilhoch z.b.) nicht mehr, teils lässt sich auch kein befehl mehr eingeben
- strg+alt+fx hat keinen effekt (ich kann nicht zu ner anderen tty-konsole wechseln) - das macht es besonders schwer, da zu investigieren, wenn alle x-programme "zicken"
- shutdown/reboot hängt und zeigt SIGKILL/-TERM timeouts usw.

Teilweise funktioniert alles gut, teils dann diese Merkwürdigkeiten. Top

Der PC ist ein dell precision 5550. Mein System recht minimalistisch - i3wm als Fenstermanager, kein Loginmanager o.ä. (startx von tty1 aus).

Was könnte das Problem sein?
Wie finde ich in so einer Situation heraus, was das Problem ist (also wenn xterm nicht funktioniert und ich nicht auf tty2 wechseln kann, kill ignoriert wird usw.)?
Welche Informationen sollte ich hier noch zur Fehleranalyse posten?

Ich hoffe, die Probleme lassen sich beseitigen - sonst werde ich nachher doch zu Ubuntu o.ä. verdonnert ^^ - lieber hätte ich es bei meinem Arbeits-PC so wie bei meinem privaten (der rollt seit gut 10Jahren ohne größere Modifikationen).

Offline

#2 20.04.2021 09:20:48

HansHiasl
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Hallo

Für mich sieht das nach einem Problem mit der Hardware aus.
Überhitzung z. B.
Der Rechner scheint ziemlich neu zu sein.
Evtl. arbeitet nicht der richtige Grafiktreiber in der Maschine.

Offline

#3 20.04.2021 09:41:25

aik
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

HansHiasl schrieb:

Hallo

Für mich sieht das nach einem Problem mit der Hardware aus.
Überhitzung z. B.
Der Rechner scheint ziemlich neu zu sein.
Evtl. arbeitet nicht der richtige Grafiktreiber in der Maschine.

Denke, das ist eher unwahrscheinlich - wenn die Probleme auftreten idR. direkt nach dem booten. Warm wird der Rechner nicht. xf86-video-intel dürfte der richtige GraKa-Treiber sein.

Offline

#4 20.04.2021 09:50:48

Icecube63
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

aik schrieb:

xf86-video-intel dürfte der richtige GraKa-Treiber sein.

"Dürfte sein" dürfte bei einer Beurteilung und Fehlersuche nicht wirklich hilfreich sein...

Was sagt denn

lspci | grep VGA

Offline

#5 20.04.2021 09:54:59

aik
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Icecube63 schrieb:

Was sagt denn

lspci | grep VGA
 00:02.0 VGA compatible controller: Intel Corporation UHD Graphics (rev 05) 

"sollte" - ich meinte "sollte" wink

Offline

#6 20.04.2021 10:27:24

hcjl
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Du könntest es auch mal ohne den xf86-video-intel Treiber versuchen. Siehe https://wiki.archlinux.org/index.php/Intel_graphics.

Offline

#7 20.04.2021 11:56:37

matthias
Moderator

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Bei mir steht da (bei sehr ähnlicher Konfiguration und halbwegs moderner Hardware):

00:02.0 VGA compatible compiler: Intel Corporation Device 5906 (rev 07)

Also besser mal den Treiber austauschen/updaten.

Offline

#8 20.04.2021 12:17:19

Icecube63
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Vielleicht hilft mehr Info weiter.

Was sagt

hwinfo --gfxcard

?

Wie aktuell ist denn dein BIOS/UEFI?

Offline

#9 20.04.2021 14:14:26

aik
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Icecube63 schrieb:

Vielleicht hilft mehr Info weiter.

Was sagt

hwinfo --gfxcard

?

Wie aktuell ist denn dein BIOS/UEFI?

 hwinfo --gfxcard
> pci.2: get sysfs pci data                                     
18: PCI 100.0: 0302 3D controller                               
  [Created at pci.386]
  Unique ID: VCu0.EKtxExbES07
  Parent ID: vSkL.Vib+ys5ONE2
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia TU117GLM [Quadro T2000 Mobile / Max-Q]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x1fb8 "TU117GLM [Quadro T2000 Mobile / Max-Q]"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x097e 
  Revision: 0xa1
  Driver: "nouveau"
  Driver Modules: "nouveau"
  Memory Range: 0xb3000000-0xb3ffffff (rw,non-prefetchable)
  Memory Range: 0x70000000-0x7fffffff (ro,non-prefetchable)
  Memory Range: 0x80000000-0x81ffffff (ro,non-prefetchable)
  I/O Ports: 0x3000-0x307f (rw)
  IRQ: 183 (1698 events)
  Module Alias: "pci:v000010DEd00001FB8sv00001028sd0000097Ebc03sc02i00"
  Driver Info #0:
    Driver Status: nouveau is active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #13 (PCI bridge)

35: PCI 02.0: 0300 VGA compatible controller (VGA)
  [Created at pci.386]
  Unique ID: _Znp.miCL_TFjZuB
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel UHD Graphics"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x9bc4 "UHD Graphics"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x097e 
  Revision: 0x05
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0x604a000000-0x604affffff (rw,non-prefetchable)
  Memory Range: 0x4000000000-0x400fffffff (ro,non-prefetchable)
  I/O Ports: 0x4000-0x403f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 184 (9617442 events)
  Module Alias: "pci:v00008086d00009BC4sv00001028sd0000097Ebc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #35

bios schaue ich später mal - gerade läuft es (will ich bis zum ende des arbeitstags nicht riskieren, wieder mit nem unbenutzbaren system dazustehen)

Offline

#10 20.04.2021 14:28:50

aik
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

matthias schrieb:

Bei mir steht da (bei sehr ähnlicher Konfiguration und halbwegs moderner Hardware):

00:02.0 VGA compatible compiler: Intel Corporation Device 5906 (rev 07)

Also besser mal den Treiber austauschen/updaten.

Gegen was denn austauschen? Aktuell ist alles…
Und die lspci-Ausgabe sollte doch unabhängig vom Treiber ausgeben, was die GraKa an Infos sendet (und Du hast eben ein anderes Modell)? Oder hab ich das falsch verstanden?

Beitrag geändert von aik (20.04.2021 14:35:27)

Offline

#11 20.04.2021 14:30:25

aik
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

hcjl schrieb:

Du könntest es auch mal ohne den xf86-video-intel Treiber versuchen. Siehe https://wiki.archlinux.org/index.php/Intel_graphics.

Meinst Du die Stelle "X freeze/crash with intel driver"? Hieße 3D-Beschleunigung deaktivieren nicht auch, dass die CPU dann mehr übernehmen muss?

Offline

#12 20.04.2021 14:44:11

Icecube63
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Hardware Class: graphics card
  Model: "nVidia TU117GLM [Quadro T2000 Mobile / Max-Q]"
 
  Device: pci 0x1fb8 "TU117GLM [Quadro T2000 Mobile / Max-Q]"
  
  Driver: "nouveau"

Eventuell ist der Treiber doch nicht der Richtige. Vielleicht findest du ja im BIOS eine Möglichkeit die Graphik auszuwählen.

Beitrag geändert von Icecube63 (20.04.2021 15:09:14)

Offline

#13 20.04.2021 15:35:21

aik
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Icecube63 schrieb:
Hardware Class: graphics card
  Model: "nVidia TU117GLM [Quadro T2000 Mobile / Max-Q]"
 
  Device: pci 0x1fb8 "TU117GLM [Quadro T2000 Mobile / Max-Q]"
  
  Driver: "nouveau"

Eventuell ist der Treiber doch nicht der Richtige. Vielleicht findest du ja im BIOS eine Möglichkeit die Graphik auszuwählen.


Bin auch etwas überrrascht gewesen - bin eigentlich davon ausgegangen, dass keine dedizierte nvidia GraKa drin ist - aber prüfe ich auf jeden Fall (wie gesagt erst nach Feierabend solange es gerade läuft ^^)

Offline

#14 20.04.2021 17:21:56

HansHiasl
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Offline

#15 20.04.2021 17:29:08

Icecube63
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

HansHiasl schrieb:

Da kann durchaus nVidia verbaut sein.

Das steht doch schon eindeutig direkt über deiner Antwort.

Offline

#16 20.04.2021 18:26:42

HansHiasl
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Ich wollte damit nur verdeutlichen, dass 5 Minuten Googlen die Innereien diese Geräts "ans Tageslicht" bringen kann, um dann die richtigen Treiber zu installieren.

Offline

#17 20.04.2021 18:31:47

Icecube63
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

HansHiasl schrieb:

Ich wollte damit nur verdeutlichen, dass 5 Minuten Googlen die Innereien diese Geräts "ans Tageslicht" bringen kann, um dann die richtigen Treiber zu installieren.

hwinfo hat 5 Sekunden gebraucht, und vor deinem Beitrag nicht nur ein kann, sondern ein eindeutiges und genaues Ergebnis mit Zusatzinfos incl des richtigen Treibers geliefert

Beitrag geändert von Icecube63 (20.04.2021 18:34:15)

Offline

#18 20.04.2021 18:46:41

HansHiasl
Mitglied

Re: Neuer Arbeitsrechner wird sporadisch unbenutzbar

Ich wollte damit nur verdeutlichen, dass man auch schon vor der Installation schauen kann, welche Innereien der Rechner hat und was man so alles braucht.
Ich mache das zumindest so.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums