Du bist nicht angemeldet.

#1 22.02.2021 19:10:57

ralf43
Mitglied

[ gelöst ] Firefox 85: Kein Ton bei Youtube und mp3 Datei

Hallo,

so langsam bin ich am verzweifeln. Youtube Videos kein Ton, ebenso bei mp3 aufgerufen über file:///home...usw.
Mit dem Chrome Browser funktioniert es problemlos.
Auf einem anderen Rechner mit ARCH Linux funktioniert es auch mit Firefox einwandfrei.

Habe versucht mit den Einstellungen im Firefox (andere Foren) und mit entsprechenden ADD Ons das Problem zu lösen.
Kein Erfolg.
Die Sound Einrichtung habe ich überprüft, funktioniert mit mplayer, vlc etc.

Kann mir jemand weiterhelfen ?

Vielen Dank im Voraus

Gruß Ralf

Beitrag geändert von ralf43 (26.02.2021 17:22:44)

Offline

#2 23.02.2021 00:58:57

tuxnix
Mitglied

Re: [ gelöst ] Firefox 85: Kein Ton bei Youtube und mp3 Datei

Nur, dass ich deine Frage richtig verstehe.

Du hast zwei Recher und beide laufen mit Arch Linux.
Auf einem geht der Ton nicht mit dem firefox browser.
Mit mplayer, vlc etc. geht der Ton.

Welches Destop hast du denn auf dem Rechner installiert?
Bei Plasma z.B. kann man Anwendungen auch einzeln an und aus stellen.

Offline

#3 23.02.2021 06:45:15

Dirk
Moderator

Re: [ gelöst ] Firefox 85: Kein Ton bei Youtube und mp3 Datei

Brauchte Firefox nicht dieses gstreamer-Zeugs für die Tonausgabe?

Offline

#4 25.02.2021 09:48:04

ralf43
Mitglied

Re: [ gelöst ] Firefox 85: Kein Ton bei Youtube und mp3 Datei

Hallo tuxnix, hallo Dirk,

Danke für eure Antworten.

Ich habe  2 Rechner auf beiden läuft Arch-Linux.
Beide Rechner sind auf dem neuesten Softwarestand.
Auf beiden Rechnern ist KDE Plasma als Desktop.
Das Problem habe ich nur auf dem Lenovo ideapad 320 Laptop -- auf dem älteren Midi-Tower habe ich keine Probleme.
Video läuft auf dem Problemrechner, nur ein Problem mit dem Ton.

gstreamer 18.3-1ist mit Zusatzprogrammen zum grössten Teil installiert, so wie es in den Dokus angegeben ist.

Grüße  Ralf

Offline

#5 25.02.2021 17:01:53

Henrikx
Mitglied

Re: [ gelöst ] Firefox 85: Kein Ton bei Youtube und mp3 Datei

Firefox nutzt ffmpeg und pulseaudio für die Wiedergabe von Audio- und Videoinhalten. Um zu Testen welche Medienformate unterstützt werden, kann man diese Seiten nutzen: Videotest und Audiotest.

https://wiki.archlinux.de/title/Firefox

libmp3lame ist auch installiert?

Offline

#6 25.02.2021 17:02:17

tuxnix
Mitglied

Re: [ gelöst ] Firefox 85: Kein Ton bei Youtube und mp3 Datei

Hallo Ralf,
Da hier alsa, pulseaudio , plasma-tools und das jeweilige Anwendungsprogramm zusammen werkeln schlage ich vor, das Problem mit Hilfe der schönen Klick-Tools anzugehen.
Plasma ist hier auch bestens gerüstet.
Im Grund geht es aber immer noch darum, wie bei einer, herkömmlichen Stereoanlage den Ausgang vom z.B. Plattenspieler mit dem Eingang vom Verstärker zu verbinden.

Schaue zunächst, dass, wenn du auf das Lautsprechersymbol auf der Task Leiste klickst, nicht nur das "Gerät" sondern auch der "Ausgang" hier die firefox-Anwendung einen eingeschalteten Lautstärkeregler aufweist. Lass dabei ein YouTube Video laufen! Firefox muss man unter Ausgang dann auch sehen können.

Edit: Sehe ich gerade. Viel besser ist natürlich die Firefox Test Seite.

Nun gehst du in den Systemeinstellungen auf audio und dort auf "Configure"
Hier probierst du die Profile aus und änderst die Einstellungen.
Good Luck

Was etwas tückisch ist. Ist dass es durchaus richtig sein kann wie sie zu Beginn stehen, aber erst dann greifen wenn man sie mal hin und hergeschaltet hat.
Jedenfalls hat das hier schon jemand mal berichtet. https://bbs.archlinux.de/viewtopic.php?id=33758

P.S.: Bei VlC gibt es einen Menupunkt für diese Einstellung. Vielleicht kannst du śie dir dort abschauen.

Beitrag geändert von tuxnix (25.02.2021 17:16:55)

Offline

#7 26.02.2021 17:21:05

ralf43
Mitglied

Re: [ gelöst ] Firefox 85: Kein Ton bei Youtube und mp3 Datei

Hallo,

Danke für eure Antworten, haben mir bei der Problemlösung sehr geholfen.

Jetzt funktioniert es.

ffmpeg-full aus dem AUR installiert, danach konnte ich im Lautstärkefenster unter Anwendungen die Lautstärke für Firefox einstellen.
ffmpeg aus extras war installiert, werde jetzt versuchen unnötige, nachinstallierte Dateien zu deinstallieren.

Gruß  Ralf

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums