Du bist nicht angemeldet.

#1 12.02.2021 14:46:40

HansHiasl
Mitglied

Fehlermeldungen beim Start von Installationsmedium

Hallo Gemeinde

Wenn ich mein Notebook mit einem aktuellen Arch-Installationsstick starte, dann gibt es zwei Dinge, die mich stören, wenn ich kein Netzwerk brauche (ist meistens der Fall).
Zum einen bleibt der Start etwa zwei Minuten hängen, weil das System auf ein Netzwerk wartet, das nicht vorhanden ist (keine physikalische Verbindung mittels Kabel)
Wenn der Start dann durch ist, dann erscheint am laufenden Band so eine Meldung:

Feb 12 12:22:13 archiso audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=reflector comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'

Diese Meldungen hören erst auf, wenn ich mittels iwctl eine Wirelessverbindung hergestellt habe.

Nun meine Fragen:
Kann ich z. B. per Bootparameter verhindern, dass das System auf ein Netzwerk wartet?
Würden dadurch auch diese Meldungen nach dem durchgelaufenen Start verschwinden?

Offline

#2 12.02.2021 15:16:25

drcux
Mitglied

Re: Fehlermeldungen beim Start von Installationsmedium

Du hast reflector.service(timer) aktiviert, der braucht natürlich Netzwerk...

Offline

#3 12.02.2021 15:31:57

HansHiasl
Mitglied

Re: Fehlermeldungen beim Start von Installationsmedium

Das ist ja im Bootmedium so eingestellt. Kann ich daran was verändern?
Also Reflektor deaktivieren?

Offline

#4 12.02.2021 18:05:44

HansHiasl
Mitglied

Re: Fehlermeldungen beim Start von Installationsmedium

Hallo

Nach langer Suche im Netz hab ich das hier gefunden: https://bbs.archlinux.org/viewtopic.php?id=257740

Der Bootparameter "audit=0" schafft wenigstens diese nervigen Fehlermeldungen ab, die ein Arbeiten ohne Netzwerkverbindung fast unmöglich machen.
Bleibt nur noch das zweiminütige Warten auf "a startjob...", wo auf ein Netzwerk gewartet wird, das definitiv nicht kommt.

Offline

#5 12.02.2021 21:01:20

chepaz
Mitglied

Re: Fehlermeldungen beim Start von Installationsmedium

Vielleicht hilft ein "systemd.mask=dhcpcd/dhclient/dhcpwhatever" als Kernel Parameter.

^ Ungeprüfte, undurchdachte Idee, zur weiteren Suche wink

Beitrag geändert von chepaz (12.02.2021 21:03:12)

Offline

#6 12.02.2021 22:08:54

Thoh7fie
Gast

Re: Fehlermeldungen beim Start von Installationsmedium

HansHiasl schrieb:

Der Bootparameter "audit=0" schafft wenigstens diese nervigen Fehlermeldungen ab, die ein Arbeiten ohne Netzwerkverbindung fast unmöglich machen.

Ein

systemctl stop reflector.service 

hätte es auch getan.

Bleibt nur noch das zweiminütige Warten auf "a startjob...", wo auf ein Netzwerk gewartet wird, das definitiv nicht kommt.

Das kann ich hier mit dem aktuellen Image auf einem T400 nicht nachvollziehen. Auch ohne eingestecktes Netzwerkkabel bootet das Image sofort bis zur Eingabeaufforderung.

Die Fehlermeldungen bekomme ich ebenfalls nicht zu sehen, sondern erscheinen nur im Journal in einem 10-Sekunden-Intervall. Das liegt daran, weil es für das Arch-ISO-Image ein Drop-In-File gibt, das die Standardeinstellungen übersteuert und alle 10 Sekunden wieder versucht, den Dienst zu starten. Wenn man das Drop-In-File entfernt und anschließend einen daemon-reload durchführt, dann werden auch keine weiteren Versuche unternommen, den Dienst zu starten.

#7 13.02.2021 14:00:00

HansHiasl
Mitglied

Re: Fehlermeldungen beim Start von Installationsmedium

chepaz schrieb:

Vielleicht hilft ein "systemd.mask=dhcpcd/dhclient/dhcpwhatever" als Kernel Parameter.

Nein, hilft leider nichts.

Thoh7fie schrieb:

...Wenn man das Drop-In-File entfernt und anschließend einen daemon-reload durchführt, dann werden auch keine weiteren Versuche unternommen, den Dienst zu starten..

Damit kann ich leider gar nichts anfangen.
Was ist ein Drop-In-File?
Muss/kann man das im laufenden Life-System machen?
Kann man diesen Zustand dann auch speichern?

Offline

#8 13.02.2021 14:41:15

Thoh7fie
Gast

Re: Fehlermeldungen beim Start von Installationsmedium

HansHiasl schrieb:

Damit kann ich leider gar nichts anfangen.
Was ist ein Drop-In-File?

Das liegt hier /etc/systemd/system/reflector.service.d/archiso.conf und

[Service]
Restart=on-failure
RestartSec=10

löst die Verbindungsversuche aus. Du kannst aber auch einfach den Dienst wie beschrieben beenden, wenn das einfacher ist.

Muss/kann man das im laufenden Life-System machen?

Ja

Kann man diesen Zustand dann auch speichern?

Nein, dazu müsste man das ISO neu mastern.

Mich würde aber eher die Frage beschäftigen, warum es überhaupt zu so einem Verhalten kommt. Ich konnte es nicht nachstellen, in sofern ist es nicht der Normalzustand. Und in wiefern der Aufwand der Analyse sich überhaupt lohnt, denn das Installationsmedium verwende ich in der Regel nur zur Installation und vielleicht im Bedarfsfall mal für die Systemrettung. Für die Installation brauche ich eh ein Netzwerk, insofern erscheint es mir reichlich praxisfremd, ein Installationsmedium ohne Netzwerk starten zu wollen. Wenn ich Reparaturen an einem gestörten System vornehmen will, dann wären mir die zwei Minuten Timeout beim Start auch egal, und dass ich den reflector.service danach noch stoppen und das Keyboard-Layout eh setzen muss, auch. Es ist ja kein Regelfall und auch kein Dauerzustand.

#9 13.02.2021 15:02:42

HansHiasl
Mitglied

Re: Fehlermeldungen beim Start von Installationsmedium

Hallo, Danke

Im Prinzip ist es richtig, dass man den Install-Stick nur selten braucht. Ich benutze ihn jedoch häufiger, um komplette Sicherungen meiner Festplatte zu machen.
Es gibt jedoch in dem Zusammenhang mit dem Install-Stick auch noch ein Problem beim Runterfahren. Siehe hierzu bitte den separaten Thread dazu.

Offline

#10 13.02.2021 19:37:53

chepaz
Mitglied

Re: Fehlermeldungen beim Start von Installationsmedium

Was auch immer du vorhast, es macht evtl. Sinn das du dich mit
https://wiki.archlinux.de/title/Archiso
beschäftigst. Ein eigenes ISO damit zu erstellen, mit persönlichen Anpassungen, ist damit sehr schnell möglich. Netter Nebeneffekt: Es macht dann auch exakt das was du willst ohne Verrenkungen.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums