Du bist nicht angemeldet.

#1 22.11.2020 14:54:17

Photor
Mitglied

Problem mit CUPS

Hallo Forum,

Hat sich vor kurzem irgendwas an CUPS geändert? Ich habe gestern bemerkt, dass CUPS die Druckaufträge nicht mehr druckt - was letzte Woche noch tadellos funktionierte.

Zur Fehlerbeschreibung:

  • wie gesagt, bis zum Beginn der letzten Woche tat das Ganze noch; drucken aus Evolution, aus dem PDF-Viewer oder auch aus TeXmaker tat tadellos. D.h. die prinzipielle Konfiguration war OK. Eingerichtet wurde der Drucker mal mit IPP

  • Der Drucker ist ein Brother HL-5170-DN; ein Netzwerkdrucker, der eine feste IP hat. Diese IP ist in der /etc/hosts auch angegeben. Ein Ping darauf funktioniert und wenn ich den Netzwerk-Stecker ziehe, reagiert das Ping (der Drucker ist also im Netz bekannt und wird gefunden). (Standardprozedur: Drucker aus- und wieder einschalten ist auch getan wink )

  • CUPS wird von systemd gestartet und läuft auch:

    [photor@Picard nextcloud] systemctl status cups
    ● cups.service - CUPS Scheduler
         Loaded: loaded (/usr/lib/systemd/system/cups.service; enabled; vendor preset: disable>
         Active: active (running) since Sun 2020-11-22 10:52:01 CET; 2h 48min ago
    TriggeredBy: ● cups.socket
                 ● cups.path
           Docs: man:cupsd(8)
       Main PID: 809 (cupsd)
         Status: "Scheduler is running..."
          Tasks: 1 (limit: 9367)
         Memory: 8.8M
         CGroup: /system.slice/cups.service
                 └─809 /usr/bin/cupsd -l
    
    Nov 22 10:52:01 Picard systemd[1]: Starting CUPS Scheduler...
    Nov 22 10:52:01 Picard systemd[1]: Started CUPS Scheduler.
  • Im Browser kann ich den Drucker mittels CUPS auch verwalten. Unter http://localhost:631/printers/Brother_HL-5170DNsehe ich den Drucker und kann auch die Druckaufträge sehen, und diese auch wieder canceln. Die werden allerdings nicht abgearbeitet. Selbst eine Test-Page wird nicht gedruckt (auch sie steht in der Warteschlange).

  • es macht auch keinen Untershied, den Drucker von Hand aus den Sleep-Modus aufzuwecken. Ebenso Aus- und wieder Anschalten hat keinen Einfuss (Toner ist vor 2 Monaten neu, Papier geladen - keine der entsprechenden LED meckert)

Ich bin da jetzt irgendwie am Ende meines Lateins. Keine Idee mehr, wo ich noch suchen soll und wie ich testen kann. Hat noch jemand ein Ende, an dem man ziehen kann?

Ciao,
Photor

PS: wenn weitere Info gebraucht wird, liefere ich die nach, wenn ich kann.

Offline

#2 22.11.2020 16:17:53

stefanhusmann
Moderator

Re: Problem mit CUPS

Sowas hab ich auch alle naselang. Dann hilft nur erneutes Einrichten des Druckers in der Cups-Weboberfläche.

Offline

#3 22.11.2020 16:21:53

Greg
Mitglied

Re: Problem mit CUPS

Beim letzten cups update wurde bei mir eine Warnung ausgegeben.
[2020-11-21T08:42:14+0100] [ALPM] warning: /etc/cups/cupsd.conf installed as /etc/cups/cupsd.conf.pacnew
Hast du das beachtet und die beiden Dateien verglichen bzw die neue pacnew übernommen?

Offline

#4 22.11.2020 16:23:45

Photor
Mitglied

Re: Problem mit CUPS

Moin,

echt? Sch***e. Hab da ja auch schon dran gedacht. Aber das ist so ... so ... so Windows!

Aber Ok. Wenn's nichtr anders geht, probier ich das.

Aber gut zu wissen, dass man nichts kaputt konfiguriert hat oder noch an irgendeiner Schraube drehen kann. Also einen wirklichen Auslöser gibt's nicht?

Ciao,
Photor

Offline

#5 22.11.2020 17:59:45

pipep
Mitglied

Re: Problem mit CUPS

Beim letzten cups update wurde bei mir diese Warnung ausgegeben:

Cups systemd socket and service files have been renamed by upstream decision.
Please make sure to disable/reenable the services to your need.
hint: "pacman -Ql cups | grep systemd" and "ls -lR /etc/systemd/ | grep cups"

Offline

#6 22.11.2020 18:02:52

Choo3ehi
Gast

Re: Problem mit CUPS

Vielleicht einfach mal die Meldungen, die pacman bei der Installation ausgibt, lesen und befolgen:

[2020-11-22T09:44:49+0100] [ALPM] upgraded cups (2.3.3-3 -> 2.3.3+106+ga72b0140e-1)
[2020-11-22T09:44:49+0100] [ALPM-SCRIPTLET] >>> Cups systemd socket and service files have been
[2020-11-22T09:44:49+0100] [ALPM-SCRIPTLET] >>> renamed by upstream decision. Please make sure
[2020-11-22T09:44:49+0100] [ALPM-SCRIPTLET] >>> to disable/reenable the services to your need.
[2020-11-22T09:44:49+0100] [ALPM-SCRIPTLET] >>> hint: "pacman -Ql cups | grep systemd" and
[2020-11-22T09:44:49+0100] [ALPM-SCRIPTLET] >>> "ls -lR /etc/systemd/ | grep cups" 

Ich hatte das auf zwei Rechnern während der Installation angezeigt bekommen, und nach Kontrolle und Durchführung der Korrekturen lief cups auch.

#7 22.11.2020 18:56:57

Photor
Mitglied

Re: Problem mit CUPS

Hallo,

Danke für den Hinweis. Das habe ich tatsächlich übersehen.

Ich buddel mich da mal rein. Melde mich wieder.

Ciao,
Photor

Offline

#8 22.11.2020 19:41:06

Photor
Mitglied

Re: Problem mit CUPS

Moin,

da bin ich nochmal.

@Greg: Hm. Eine cupsd.conf.pacnew gibt es nicht. Also nichts zu vergleichen.

Das andere sieht so aus:

[root@Picard ~]# pacman -Ql cups | grep systemd
cups /usr/lib/systemd/
cups /usr/lib/systemd/system/
cups /usr/lib/systemd/system/cups-lpd.socket
cups /usr/lib/systemd/system/cups-lpd@.service
cups /usr/lib/systemd/system/cups.path
cups /usr/lib/systemd/system/cups.service
cups /usr/lib/systemd/system/cups.socket

Wenn ich das richtig sehe, sind das die Files, die Cups unter SystemD insgesamt installiert.

[root@Picard ~]# ls -lR /etc/systemd/ | grep cups
lrwxrwxrwx 1 root root 33 22. Nov 18:26 cups.path -> /usr/lib/systemd/system/cups.path
lrwxrwxrwx 1 root root 43 29. Dez 2017  org.cups.cupsd.path -> /usr/lib/systemd/system/org.cups.cupsd.path
lrwxrwxrwx 1 root root 36 22. Nov 18:26 cups.service -> /usr/lib/systemd/system/cups.service
lrwxrwxrwx 1 root root 46 29. Dez 2017  org.cups.cupsd.service -> /usr/lib/systemd/system/org.cups.cupsd.service
lrwxrwxrwx 1 root root 39 22. Nov 18:24 cups-lpd.socket -> /usr/lib/systemd/system/cups-lpd.socket
lrwxrwxrwx 1 root root 35 22. Nov 18:26 cups.socket -> /usr/lib/systemd/system/cups.socket
lrwxrwxrwx 1 root root 45 29. Dez 2017  org.cups.cupsd.socket -> /usr/lib/systemd/system/org.cups.cupsd.socket

Das sind die Services und Sockets, die auf den System tatsächlich installiert sind, richtig? Ich habe mal cups.path, cups.service, cups-lpd.socket und cups.socket mal dis- und wieder enabled und neu gestartet.

Bisher aber keine Änderung. Noch ratlos.

Ciao,
Photor

PS: was hat es mit den org.cups.cupsd.* auf sich?

Offline

#9 22.11.2020 19:51:51

Greg
Mitglied

Re: Problem mit CUPS

Erwischt.
Bei mir stimmts auch nicht.
Hatte diese Meldungen wohl auch nicht beachtet. Gedruckt hatte ich die letzten 2 Tage auch nicht.
Ein

# systemctl disable org.cups.cupsd

und ein

# systemctl enable cups

hat es dann bereinigt.
Neustart.
Drucken geht wieder.

Das war früher übrigens auch schon so, da wurde von cups auf org.cups.cupsd umgestellt. Jetzt haben die Paketmacher das wieder rückgängig gemacht.

Beitrag geändert von Greg (22.11.2020 19:55:21)

Offline

#10 22.11.2020 20:13:50

Choo3ehi
Gast

Re: Problem mit CUPS

Photor schrieb:

Das sind die Services und Sockets, die auf den System tatsächlich installiert sind, richtig? Ich habe mal cups.path, cups.service, cups-lpd.socket und cups.socket mal dis- und wieder enabled und neu gestartet.

Die services wurden umbenannt, da bringt ein dis- und enable derselben services gar nichts. Zum Beispiel ist

org.cups.cupsd.service -> /usr/lib/systemd/system/org.cups.cupsd.service

jetzt ein toter Link, was man auch leicht in der Anzeige des Dateisystems sehen kann, da das Ziel /usr/lib/systemd/system/org.cups.cupsd.service nicht mehr existiert, sondern durch /usr/lib/systemd/system/cups.service ersetzt wurde, was auch der pacman-Ausgabe zu entnehmen ist.

Die richtige Maßnahme ist also, den alten Link mit "systemctl disable org.cups.cupsd.service" zu entfernen und mit "systemctl enable --now cups.service" neu zu setzen; und das für alle services, die davon betroffen sind (geht auch mit einem Befehl)

#11 23.11.2020 17:29:26

Photor
Mitglied

Re: Problem mit CUPS

Moin,

kurze Rückmeldung: drucken scheint wieder zu tun wink

Es war eine Kombi aus den Änderungen im CUPS-Paket und Drucker neu einrichten. Die Meldung zu den Änderungen hatte ich beim täglichen Update tatsächlich übersehen (Notiz an mich selbst: "Uffpasse!"). Die Versuche das mit den Tipps hier (Danke dafür) wieder hinzubiegen, habe alleine aber nicht geholfen. Ich musste dann tatsächlich den eingerichteten Drucker löschen und neu anlegen.

Danke für die gute und sachdienliche Hilfe.

Ciao,
Photor

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums