Du bist nicht angemeldet.

#1 04.09.2020 01:12:25

Pazuzu
Mitglied

DNS (leak)

Hallo,
ich würde gerne einen anderen DNS Server verwenden.

/etc/systemd/resolved.conf sieht so aus

[Resolve]
DNS=46.182.19.48 80.241.218.68 2a02:2970:1002::18 2a02:c205:3001:4558::1
FallbackDNS=176.9.93.198 2a01:4f8:151:34aa::198
#Domains=
#DNSSEC=yes
#DNSOverTLS=no
#MulticastDNS=yes
#LLMNR=yes
#Cache=yes
#DNSStubListener=yes
#ReadEtcHosts=yes
#ResolveUnicastSingleLabel=no

die /etc/resolv.conf hab ich gelöscht, wurde aber nach dem letzten boot wieder erstellt.
Vielleicht liegt hier der Fehler?

...ay, replace this symlink by a static file or a different symlink.
#
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.

nameserver 127.0.0.53
options edns0 trust-ad

Ein test auf dnsleak.com offenbart den eigetragenen Server in resolved.conf aber auch die IP des ISPs.

resolvectl status

Global
       LLMNR setting: yes                   
MulticastDNS setting: yes                   
  DNSOverTLS setting: no                    
      DNSSEC setting: no                    
    DNSSEC supported: no                    
  Current DNS Server: 2a02:c205:3001:4558::1
         DNS Servers: 46.182.19.48          
                      80.241.218.68         
                      2a02:2970:1002::18    
                      2a02:c205:3001:4558::1
Fallback DNS Servers: 176.9.93.198          
                      2a01:4f8:151:34aa::198

Link 2 (enp3s0)
      Current Scopes: none
DefaultRoute setting: no  
       LLMNR setting: yes 
MulticastDNS setting: no  
  DNSOverTLS setting: no  
      DNSSEC setting: no  
    DNSSEC supported: no  

Link 3 (wlp4s0)
      Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
DefaultRoute setting: yes                      
       LLMNR setting: yes                      
MulticastDNS setting: no                       
  DNSOverTLS setting: no                       
      DNSSEC setting: no                       
    DNSSEC supported: no                       
  Current DNS Server: 192.168.0.1              
         DNS Servers: 192.168.0.1

Aha! Wlan verwendet also weiterhin die DNS des Routers. Jemand eine Idee?

Offline

#2 04.09.2020 11:39:34

Icecube63
Mitglied

Re: DNS (leak)

Ich nutze nur die /etc/resolv.conf, und verhindere mit

# chattr +i /etc/resolv.conf

das Überschreiben durch den Router.

Offline

#3 04.09.2020 12:03:12

schard
Moderator

Re: DNS (leak)

Wie wurde das Netzwerk fürs WLAN konfiguriert? Bitte vollständige Konfigurationsdateien.

Offline

#4 04.09.2020 20:27:25

Pazuzu
Mitglied

Re: DNS (leak)

Ersteinrichtung sollte mit wpa_supplicant geschehen, führte aber zu zu vielen Fehlern sh. hier https://bbs.archlinux.de/viewtopic.php?id=33482

Über netctl hab ich dann ein Profil erstellt (manuell). Befindet sich in /etc/netctl/netctlconf.

netctl@netctlconf.service

Außerdem aktiv ist

systemd-resolved.service

Networkmanager ist nicht installiert.

uU ist hier noch was rauszulesen

$ systemctl status

├─system-netctl.slice 
             │ └─netctl@netctlconf.service 
             │   ├─796 wpa_supplicant -q -B -P /run/wpa_supplicant-wlp4s0.pid -i wlp4s0 -D nl80211,wext -c/run/netctl/wpa_supplicant-wlp4s0.conf
             │   ├─882 dhcpcd: wlp4s0 [ip4]
             │   ├─883 dhcpcd: [privileged actioneer] wlp4s0 [ip4]
             │   ├─884 dhcpcd: [control proxy] wlp4s0 [ip4]
             │   ├─893 dhcpcd: [BPF ARP] wlp4s0 192.168.0.130
             │   └─912 dhcpcd: [network proxy] 192.168.0.130

Offline

#5 05.09.2020 15:04:37

wirr
Mitglied

Re: DNS (leak)

Ich vermute, du musst in der Konfiguration von Link 3 (aktuell in einem netctl Profil) deinen DNS setzen oder verhindern, dass der DNS vom DHCP benutzt wird.

Offline

#6 05.09.2020 22:04:31

Pazuzu
Mitglied

Re: DNS (leak)

Eigentlich dachte ich dhcp(cd) wäre deaktiviert.

[pazuzu@laptop ~]$ systemctl status dhcpcd.service
● dhcpcd.service - dhcpcd on all interfaces
     Loaded: loaded (/usr/lib/systemd/system/dhcpcd.service; disabled; vendor preset: disabled)
     Active: inactive (dead)

Aber das Journal sagt was anderes

[pazuzu@laptop ~]$ journalctl -b --grep=dhcp
-- Logs begin at Tue 2020-08-18 12:19:34 CEST, end at Sat 2020-09-05 21:52:04 CEST. --
Sep 05 20:38:08 laptop dhcpcd[885]: dhcpcd-9.1.4 starting
Sep 05 20:38:09 laptop dhcpcd[888]: wlp4s0: soliciting a DHCP lease

/etc/resolve.conf ist seit dem letzten Systemupdate nicht mehr überschreibbar, in der Beschreibung wird sie von systemd-resolved verwendet.

Offline

#7 06.09.2020 07:17:12

drcux
Mitglied

Re: DNS (leak)

netctl ruft dhcpcd auf...

Solche Probleme treten immer auf, wenn man zwei verschiedene Netzwerktools gleichzeitig nutzt. In deinem Fall netctl und systemd.

Offline

#8 06.09.2020 16:20:39

wirr
Mitglied

Re: DNS (leak)

Irgendwas macht diesen DHCP Request sowieso. Diesem musst du sagen, dass du einen anderen oder keinen DNS Server benutzen willst.

Offline

#9 06.09.2020 20:56:50

Pazuzu
Mitglied

Re: DNS (leak)

Die Lösung lag in den example Dateien von netctl. Ich hab in mein netctlprofil eine DNS eingetragen.

[pazuzu@laptop ~]$ resolvectl status
Global
       LLMNR setting: yes         
MulticastDNS setting: yes         
  DNSOverTLS setting: no          
      DNSSEC setting: no          
    DNSSEC supported: no          
  Current DNS Server: 46.182.19.48
         DNS Servers: 46.182.19.48
Fallback DNS Servers: 176.9.93.198

Link 2 (enp3s0)
      Current Scopes: none
DefaultRoute setting: no  
       LLMNR setting: yes 
MulticastDNS setting: no  
  DNSOverTLS setting: no  
      DNSSEC setting: no  
    DNSSEC supported: no  

Link 3 (wlp4s0)
      Current Scopes: DNS LLMNR/IPv4 LLMNR/IPv6
DefaultRoute setting: yes                      
       LLMNR setting: yes                      
MulticastDNS setting: no                       
  DNSOverTLS setting: no                       
      DNSSEC setting: no                       
    DNSSEC supported: no                       
  Current DNS Server: 46.182.19.48             
         DNS Servers: 46.182.19.48  

Danke an alle!

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums