Du bist nicht angemeldet.

#1 03.09.2020 10:12:01

pix
Mitglied

[gelöst] Kein Update für ein bestimmtes Paket vornehmen

Hallo zusammen,

ich nutze Blender in der Version 2.83.5
Dies ist eine LTS Version für 2 Jahre. Aktuell gibt es aber schon die Version 2.90.

In der nächsten Zeit möchte ich die LTS Version behalten und kein Update für Blender durchführen.

Laut Arch Wiki muss man dazu die Datei /etc/pacman.conf bearbeiten.
Konkret die Zeile: #IgnorePkg --> die Raute davor muss weg und dahinter der Paketname, wenn ich das richtig verstehe.

Im Verzeichnis /var/cache/pacman/pkg steht für Blender konkret drin: blender-17:2.83.5-2-x86_64.pkg.tar.zst

Frage:
muss ich hinter > IgnorePkg < den gesamten Paketnamen > blender-17:2.83.5-2-x86_64.pkg.tar.zst < einsetzten?

Vielen Dank für eure Hilfe
LG

Beitrag geändert von pix (03.09.2020 17:18:14)

Offline

#2 03.09.2020 10:45:56

schard
Moderator

Re: [gelöst] Kein Update für ein bestimmtes Paket vornehmen

Ja, du musst den gesamten Paketnamen einsetzen.
Dies ist jedoch nicht zu verwechseln mit dem Dateinamen des Pakets, der zwar i.d.R. einem gewissen Schema folgt, aber eigentlich beliebig sein kann:

$ sudo pacman -U foobar.tar.zst 
[sudo] Passwort für neumann: 
Lade Pakete...
Warnung: Downgrade des Paketes linux (5.8.5.arch1-1 => 5.8.3.arch1-1)
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (1) linux-5.8.3.arch1-1

Gesamtgröße der installierten Pakete:  77,15 MiB
Größendifferenz der Aktualisierung:   0,01 MiB

:: Installation fortsetzen? [J/n] 

tl;dr:
Der vollständige Name des Pakets ist: blender
Steht so auch unmissverständlich im Wiki: https://wiki.archlinux.org/index.php/Pa … g_upgraded

Offline

#3 03.09.2020 17:17:39

pix
Mitglied

Re: [gelöst] Kein Update für ein bestimmtes Paket vornehmen

Vielen Dank für deine Hilfe.

Dann wäre der korrekte Eintrag:
IgnorePkg=blender

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums