Du bist nicht angemeldet.

#1 07.08.2020 09:47:19

LATMusic
Mitglied

[Gelöst] Kernel Module startet nach Update nicht

Nachdem ich heute ein vollständiges Systemupdate durchführte und meinen Computer neu starte, bekam ich folgende Meldung:

Starting version 245.6-8-arch
p_arch: clean, 991736/4587520 files, 13581426/18350080 blocks
[FAILED]  Failed to start Load Kernel modules 
[FAILED] Failed to mount /boot/EFI
[DEPEND] Dependency failed for Local File Systems.
You are in emergency mode. After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or "exit"
to boot into default mode.
Administratorpasswort für Wartungszwecke eingeben
(oder drücken sie Strg+D, um fortzufahren):_

(leider kann man in den Codeklammern keinen BB-Code für Farben oder Fettdrucken angeben, sonst hätte ich das getan)

Der Login in diese Shell funktioniert dann wunderbar. Ein auflisten des /boot/EFI Verzeichnis, (darin ist die EFI System Partition gemountet), zeigt, mir alle initramfs und vmlinuzs richtig an.
Ein überprüfen, ob der /etc/fstab noch richtig war, führte auch zu keinen Ergebnissen, da da alles stimmte.
Hier einmal auch der output:

? cat /etc/fstab
# /dev/sda2 LABEL=p_arch
UUID:e17a389b-dacf-4cc9-9e44-578f9708d116   /   ext4   rw,relatime   0 1

# /dev/sda1 LABEL=EFIBOOT
UUID=0A8B-5522   /boot/EFI   vfat   rw,relatime,fmask=0022,fmask=0022,Codepage=437,iocharset=iso8859-1shortname=Mixed,utf8,Errors=remount-ro   0 2

# /dev/sda4
UUID=d7ed3c64-3784-4033-9509-572822cc169c   /home   ext4   rw, relatime   0 2

#  /dev/sda3 LABEL=p_swap
UUID=87e6f47c-3939-40ba-abd5-683fa1024373   none   swap   swap   defaults    0 0

Ich besitze leider nicht das Fachwissen, um die Systemlogs richtig auszuwerten. Und da das über 1000 Zeilen sind, werde ich die nicht auch noch hier hin tippen.

Ich habe auch schon versuchte in andere Kernels zu booten, aber weder der Linux, noch der Linux-LTS oder der Linux-Zen Kernel (respektive noch mit Fallback initramfs) booten richtig und ich komme in dieses Fenster.


Weiß jemand,  wie diese Fehler entstehen, beziehungsweise wie man diese löst?

Mit freundlichen Grüßen

PS: Ja, ich kann Tools wie Timeshift aufrufen. Leider habe ich jedoch vor kurzem das Speichergerät für die Backups formatieren müssen, und habe gestern Abend nicht daran gedacht, ein neues zu erstellen weshalb diese Möglichkeit leider auch ausbleibt.

Beitrag geändert von LATMusic (07.08.2020 20:20:21)

Offline

#2 07.08.2020 09:50:24

niemand
Mitglied

Re: [Gelöst] Kernel Module startet nach Update nicht

Und da das über 1000 Zeilen sind, werde ich die nicht auch noch hier hin tippen.

Man könnte sie kopieren, oder als Datei hochladen.

Anyway – vermutlich ist bei dir das Erstellen des initramfs fehlgeschlagen. Aus welchem Grund, stand in dessen Ausgabe – die hättest du lesen sollen.

Mein Vorgehen wäre nun: Livesystem booten, kaputtes System einbinden und chrooten und das Erstellen nochmal anschubsen. Ausgabe beachten und entsprechend verfahren.

Online

#3 07.08.2020 09:54:33

LATMusic
Mitglied

Re: [Gelöst] Kernel Module startet nach Update nicht

Kopieren kann ich leider nicht, weil ich das hier übers Handy schreibe.

Beitrag geändert von LATMusic (07.08.2020 10:24:52)

Offline

#4 07.08.2020 10:50:11

LATMusic
Mitglied

Re: [Gelöst] Kernel Module startet nach Update nicht

Okay, ich bekomme folgenden Output:

==> Building image From preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==ERROR: '/lib/modules/5.7.10-arch1-1 is not a valid Kernel directory

==> Building image From preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==ERROR: '/lib/modules/5.7.10-arch1-1 is not a valid Kernel directory

Beim Überprüfen des Invaliden Verzeichnisses stellt sich heraus, das dieses gar nicht existiert, da ein neueres vorhanden ist.

Hinweis: Da ein mounten in /boot/EFI der Systempartition keine Fehlermeldungen ausgegeben hat, ich aber dennoch nicht booten könnte, habe ich sie in /boot gemountet. Dann sind die Fehler aufgetreten.
Wie lässt sich denn die directory ändern, aus der die Presets bezogen werden?

Edit: Beim Versuch ins neu gemountet System zu booten, traten die gleichen Fehler auf.

Beitrag geändert von LATMusic (07.08.2020 10:53:40)

Offline

#5 07.08.2020 11:10:14

niemand
Mitglied

Re: [Gelöst] Kernel Module startet nach Update nicht

Dann würde ich nun ein Livesystem booten, in das kaputte System chrooten, ein ›pacman -Suy‹ absetzen und die Ausgaben genau beobachten. Mein Tipp wäre, dass bei der Installation des Kernels was schiefgelaufen ist – z.B. /boot vollgelaufen, o.ä.

Online

#6 07.08.2020 11:22:26

LATMusic
Mitglied

Re: [Gelöst] Kernel Module startet nach Update nicht

Update hat Eigentlich gut funktioniert, bis hier:

(9/10) updating Linux initcpios...
=> Building image From preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==ERROR: '/lib/modules/5.7.10-arch1-1 is not a valid Kernel directory

==> Building image From preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==ERROR: '/lib/modules/5.7.10-arch1-1 is not a valid Kernel directory
error: command failed to execute correctly

Und das gleiche für die ganzen anderen Kernels. Daraus bin ich leider nicht schlauer geworden.

Edit: Noch einen Fehler gefunden:

(6/10) Creating temporary files...
Failed to open file "/sys/devices/system/cpu/microcode/reload": Read-only  file system
error: command failed to execute correctly

Beitrag geändert von LATMusic (07.08.2020 11:27:05)

Offline

#7 07.08.2020 11:29:58

niemand
Mitglied

Re: [Gelöst] Kernel Module startet nach Update nicht

… ich mach wieder mit, sobald die gesamte Ausgabe gepostet wird.

Online

#8 07.08.2020 11:46:50

LATMusic
Mitglied

Re: [Gelöst] Kernel Module startet nach Update nicht

(5/5) checking available disk space             [-----------------------]100%
:: Processing package changes
(1/5) upgrading go
(2/5) upgrading systemdlibs
(3/5) upgrading systemd
Running in chroot, ignoring command 'daemon-reexec'
(4/5) upgrading lib32-systemd
(5/5) upgrading systemd-sysvcompat
:: Running post-transaction hooks...
(1/10) Creating system user account

Ähm, Moment, habe Geistesabwesend eine Datei in vim geöffnet und komme jetzt nicht mehr an das was weiter oben stand.
Ich gebe hier nochmal ein Update, wenn ich ein neues Systemupdate durchführen kann.

Offline

#9 07.08.2020 19:03:28

LATMusic
Mitglied

Re: [Gelöst] Kernel Module startet nach Update nicht

Danke für die Hilfe, ich habe das Problem, wie auch die letzten mal als ich um Hilfe fragte dennoch selbst geschafft zu lösen.

Ich konnte den Fehler beheben, indem ich die Kernels (samt Headers) neu installiert habe. Dadurch wurden neue libraries für die Kernel Presets gebaut, weshalb mkinitcpio auf korrekte Verzeichnisse zugreifen konnte. Diese Idee ist mir erst nach einigen Fehlermeldungen gekommen, und nachdem ich durch kochen und essen meinen Kopf freibekommen habe.


Das war der Relevante Teil, hier noch ein paar Gedanken dazu:
Dennoch bin ich sehr dankbar für die Hilfe, die ich hier bekommen habe, da ich dadurch ein paar Wiki Einträge gelesen habe, auf die ich vorher nicht gekommen wäre, da mir hier neue denkweisen präsentiert wurden. Der neue Timeshift snapshot ist bereits erstellt, damit so etwas in der Zukunft leicher zu beheben ist. Inzwischen sehe ich solche Wikis auch nicht mehr als Gratis Kundensupport, sondern als Ort der letzten Zuflucht, wenn ich mit meinem Latein am Ende bin.
Wenn ich manche Probleme von Anfang an schaffe selbst zu lösen, gibt mir das immer einen Motivationschub und stärkt mein Selbstvertrauen (wie vor kurzem als EFI Arch plötzlich nicht mehr gefunden hat). Aber auch solche Erfahrungen sind wichtig, da ich so merke wie viel ich noch zu lernen habe. Denn das ist jetzt nochmal deutlich geworden.
So gesehen blicke ich aufrichtig in eine Zukunft voller Probleme, die ich lösen kann. Denn ich merke auch, wie ich durch mein neues Wissen, das ich alleine durch meine Arch Installation vor ein paar Monaten erlernt habe.
Es wird stetig mehr, und ich hoffe möglichst bald bei solchen Problemen niemand mehr belästigen zu müssen.

Falls das jetzt jemand gelesen hat, bedanke ich mich für die offenen Ohren.
MfG Laskar

Edit: Noch eine Frage als Neulings in solchen Foren: Gibt es eine Möglichkeit, den Beitrag selbst auf gelöst zu setzen, oder muss das ein Foremod machen?

Beitrag geändert von LATMusic (07.08.2020 19:04:38)

Offline

#10 07.08.2020 20:16:25

stefanhusmann
Moderator

Re: [Gelöst] Kernel Module startet nach Update nicht

Editiere den ersten Beitrag des Threads und setze ein "Gelöst" davor. Als Mitglied kannst du das.

Offline

#11 07.08.2020 20:21:55

LATMusic
Mitglied

Re: [Gelöst] Kernel Module startet nach Update nicht

Danke für den Hinweis. Es gibt einige Foren, die beim editieren des ersten Posts nicht die Möglichkeit geben, den Titel zu verändern, deshalb habe ich da nicht dran gedacht.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums