Du bist nicht angemeldet.

#1 25.05.2020 17:44:09

hellmi666
Mitglied

[gelöst] NFS Probleme

Hallo Leute,
ich bräuchte wieder einmal eure Hilfe.
Ich verbinde meinen Laptop(Client) mit dem Desktoprechner(Server) über NFS mit folgendem Befehl:

sudo mount 192.168.178.20 /mnt/Daten /mnt/PC/Daten

Allerdings muss ich sagen: verbandt. Seit einiger Zeit funktioniert diese Verbindung nicht mehr. Scheinbar durch ein Update. Wurde denn in letzter Zeit in der Konfiguration irgendwas geändert?
Oder wie/ womit kann ich denn die zwei Geräte besser miteinander verbinden?

Beitrag geändert von hellmi666 (26.05.2020 17:56:39)

Offline

#2 25.05.2020 17:50:59

schard
Moderator

Re: [gelöst] NFS Probleme

Also ich habe keine Probleme mit NFS.
Allerdings benutze ich nicht sudo, sondern ein systemd mount-Unit:

$ cat /etc/systemd/system/home.mount 
[Unit]
After=network-online.target
Requires=network-online.target

[Mount]
What=10.200.200.1:/home
Where=/home
Type=nfs
Options=defaults,_netdev,acl
ForceUnmount=true

Mir kommt bei dir das Leerzeichen zwischen IP-Adresse und Pfad allerdings seltsam vor.
Meine mount-Ausgabe hat die Doppelpunkt-Trennung:

10.200.200.1:/home on /home type nfs4 (rw,relatime,vers=4.2,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=10.200.200.2,local_lock=none,addr=10.200.200.1,_netdev)

Offline

#3 25.05.2020 18:02:03

hellmi666
Mitglied

Re: [gelöst] NFS Probleme

Mein Fehler, falsch abgetippt.

sudo mount 192.168.178.20:/mnt/Daten /mnt/PC/Daten

Mich wundert nur, dass es bis vor kurzem noch ging und auf einmal nicht mehr.

Beitrag geändert von hellmi666 (25.05.2020 18:07:36)

Offline

#4 25.05.2020 18:27:02

schard
Moderator

Re: [gelöst] NFS Probleme

Benutzt du die gleiche NFS Version auf Client und Server?
Wie sieht die Firewall-Konfiguration auf Client und Server aus?

Offline

#5 25.05.2020 19:09:43

hellmi666
Mitglied

Re: [gelöst] NFS Probleme

Installiert habe ich nfs-utils 2.4.3-2 auf Client und Server.

Ich benutze keine Firewall.

Offline

#6 25.05.2020 19:34:55

niemand
Mitglied

Re: [gelöst] NFS Probleme

[…] funktioniert […] nicht mehr.

Komische Fehlermeldung. Müsste man ’nen Bugreport schreiben, damit kann man ja mal gar nix anfangen. Sowas würde ich unter Windows erwarten, aber nicht hier.

Offline

#7 25.05.2020 21:45:10

Kabbone
Mitglied

Re: [gelöst] NFS Probleme

bevor man direkt einen Bugreport  schreibt, lieber erstmal mit "-vvv" verbose mounten, dann sieht man schon mal mehr.

Offline

#8 25.05.2020 21:47:06

niemand
Mitglied

Re: [gelöst] NFS Probleme

Falls du dich auf mich beziehst: ich wollte nur etwas Sarkasmus zum Ausdruck gebracht haben. Ich mein: was soll man mit „geht nicht“ anfangen? Kann an allem liegen – und in der Regel sagt die tatsächliche Fehlermeldung, die hier, warum auch immer, nicht geschrieben worden ist, auch ziemlich direkt, in welche Richtung man gucken muss.

Offline

#9 26.05.2020 16:40:56

hellmi666
Mitglied

Re: [gelöst] NFS Probleme

Ich schrieb keine Fehlermeldung, weil einfach keine angezeigt wurde.
Das Mountprozedere wurde nach ca. 3 min abgebrochen,

mount.nfs: Connection timed out

Hier noch einmal mit -v:

$ sudo mount -v 192.168.178.20:/mnt/Multimedia /mnt/Daten/PC/Multimedia/
mount.nfs: timeout set for Tue May 26 16:38:52 2020
mount.nfs: trying text-based options 'vers=4.2,addr=192.168.178.20,clientaddr=192.168.179.21'
mount.nfs: mount(2): Connection timed out
mount.nfs: Connection timed out

Beitrag geändert von hellmi666 (26.05.2020 16:42:02)

Offline

#10 26.05.2020 17:04:14

niemand
Mitglied

Re: [gelöst] NFS Probleme

mount.nfs: Connection timed out

… ist doch schonmal ’n Anhaltspunkt.

Die Route zwischen 192.168.179.21 und 192.168.178.20 ist okay?

Beitrag geändert von niemand (26.05.2020 17:04:59)

Offline

#11 26.05.2020 17:12:04

hellmi666
Mitglied

Re: [gelöst] NFS Probleme

niemand schrieb:

Die Route zwischen 192.168.179.21 und 192.168.178.20 ist okay?

Wie  stelle ich das fest? Ich habe jedenfalls seit dem letzmaligen Verbinden nichts verändert.

Beitrag geändert von hellmi666 (26.05.2020 17:18:02)

Offline

#12 26.05.2020 17:20:08

hellmi666
Mitglied

Re: [gelöst] NFS Probleme

Ping sagt nein:

$ ping -c3 192.168.178.20
PING 192.168.178.20 (192.168.178.20) 56(84) bytes of data.

--- 192.168.178.20 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2039ms

Allerdings weiß ich nicht, ob ping der richtige Befehl ist.

Offline

#13 26.05.2020 17:55:59

hellmi666
Mitglied

Re: [gelöst] NFS Probleme

Ich habe mich mal in der Fritzbox umgeschaut und habe festgestellt, dass sich mein Laptop (warum auch immer) mit dem Gastkonto eingeloggt hat. Dieses hat natürlich einige Beschränkungen.
Also kleine Ursache, große Wirkung. Trotzdem vielen Dank an alle, die mir helfen wollten.

Grüße Hellmi

Offline

#14 26.05.2020 18:38:14

niemand
Mitglied

Re: [gelöst] NFS Probleme

… eigentlich ist ’n Ping im Fehlerfall das Erste, was die meisten Leute probieren. Noch vor dem Schauen mit traceroute, ss, ip, und so – und entsprechend noch sehr weit vor dem Erstellen eines Threads in irgendeinem Forum wink

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums