Du bist nicht angemeldet.

#1 24.05.2020 15:46:55

jessie
Mitglied

java-openjfx 13.u14-1 Flagged out-of-date on 2020-05-23

Hallo,

ich wollte heute mein System aktualieren, was wegen:

Installation von jre-openjdk (14.0.1.u7-1) verletzt Abhängigkeit 'java-runtime-openjdk=13', benötigt von java-openjfx

fehlschlug.
Ich habe java-openjfx 13.u14-1 installiert, welches offenbar für diese Meldung ursächlich ist.
Weiß jemand, ob es sich hierbei nur um eine temporäre Angelegenheit handelt und es eine neue Version von java-openjfx geben wird? Oder muss man sich von openjfx verabschieden?

VG
Jessie

Offline

#2 24.05.2020 17:40:39

stefanhusmann
Moderator

Re: java-openjfx 13.u14-1 Flagged out-of-date on 2020-05-23

Das es kein Java 13 mehr in den Repos gibt, würde ich dies für einen Bug halten.

Offline

#3 25.05.2020 09:24:40

Gerry_Ghetto
Mitglied

Re: java-openjfx 13.u14-1 Flagged out-of-date on 2020-05-23

Ich weiss natürlich nicht, warum du Java 13/14 brauchst, aber eventuell lohnt es sich auch, wenn du zum Beispiel Java 11 (LTS) als Standard nutzt und die neueren Versionen nur dort, wo du sie auch tatsächlich brauchst.
In den meisten Fällen ist Java 11 (oder auch Java 8) völlig ausreichend.

Offline

#4 25.05.2020 13:11:05

stefanhusmann
Moderator

Re: java-openjfx 13.u14-1 Flagged out-of-date on 2020-05-23

Das mag sein, ändert aber nichts daran, dass es anscheinend in den Repos ein Paket gibt (java-openjfx), das nicht zusammen mit einem anderen (jre-openjdk) installiert werden kann, weil es eine kaputte versionierte Abhängigkeit gibt, die aus den Repos nicht auflösbar ist.

Offline

#5 25.05.2020 19:51:14

blub
Gast

Re: java-openjfx 13.u14-1 Flagged out-of-date on 2020-05-23

stefanhusmann schrieb:

Das mag sein, ändert aber nichts daran, dass es anscheinend in den Repos ein Paket gibt (java-openjfx), das nicht zusammen mit einem anderen (jre-openjdk) installiert werden kann, weil es eine kaputte versionierte Abhängigkeit gibt, die aus den Repos nicht auflösbar ist.

... gab, nicht gibt!
Trotzdem ein bisschen komisch, der Maintainer beider Pakete ist ja der gleiche, dem hätte der Versionskonflikt doch auffallen können?! Und als makedep von java-openjfx ist jdk11-openjdk nötig? Das ist auch komisch und widerspricht den Upstream Build-Anforderungen.

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums