Du bist nicht angemeldet.

#1 05.05.2020 08:45:06

sewulba
Mitglied

[gelöst]2 Bildschirme, nach Standby ist es essig.

Hallo Community.

Ich habe nun meinen letzten Laptop auf Arch umgestellt und bin soweit echt zufrieden. Alles läuft super, aber die Ansteuerung der 2 Bildschirme ist irgendwie nicht optimal.

Angeschlossen sind die 2 27"Monitore über Displayport über einen Dockingstation.

Nach dem Hochfahren ist noch alles gut. Aber, wenn ich längere Zeit nichts mache, dann gehen beide Monitore in Standby. Das Problem dabei ist nur, dass danach nicht mehr beide angehen, sondern nur noch einer von 2en. :-(

Grafikkarte: Intel Corporation UHD Graphics 620 (rev 07)

Verwendeter WindowManager ist: i3-gaps

Hier meine Anpassungen für X-org:

00-keyboard.conf

Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "nodeadkeys"
EndSection

10-monitor.conf

Section "Monitor"
    Identifier  "eDP1"
    Option	"PreferredMode" "1920x1080"
    Option 	"primary" "true"
    Option 	"DPMS" "true"
    Option	"StandbyTime"	"0"
    Option	"SuspendTime"	"0"
    Option	"OffTime"	"0"
EndSection

Section "Monitor"
    Identifier  "DP2-2"
    Option 	"PreferredMode" "1920x1080"
    Option	"RightOf" "eDP1"
    Option 	"DPMS" "true"
    Option      "StandbyTime"   "0"
    Option      "SuspendTime"   "0"
    Option      "OffTime"       "0"
EndSection

Section "Monitor"
    Identifier	"DP2-3"
    Option	"PreferredMode" "1920x1080"
    Option	"RightOf" "eDP2-2"
    Option	"DPMS" "true"
    Option      "StandbyTime"   "0"
    Option      "SuspendTime"   "0"
    Option      "OffTime"       "0"
EndSection

20-intel.conf

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

Ich dachte eigentlich, dass ich mit 'Standbytime', 'SuspendTime' und 'OffTime' auf '0' das abschalten unterbunden hätte. Aber die Bildschirme gehen immer noch aus. Helft mir mal, wie immer, weiter bitte. :-)

Gruss Sewulba

Beitrag geändert von sewulba (09.05.2020 04:29:56)

Offline

#2 05.05.2020 11:15:14

Greg
Mitglied

Re: [gelöst]2 Bildschirme, nach Standby ist es essig.

Bei mir steht es so:

Section "ServerFlags"
        Option "BlankTime"   "0"   # Zeit wann der Monitor Schwarz wird (Standard: 10 Minuten)
        Option "StandbyTime" "0"   # Zeit wann der Monitor in den Standby geht (Standard: 20 Minuten)
        Option "SuspendTime" "0"   # Zeit wann der Monitor in den Suspend geht (Standard: 30 Minuten)
        Option "OffTime"     "40"   # Zeit wann sich der Monitor abschaltet (Standard: 40 Minuten)
EndSection

Vielleicht hast du nur BlankTime vergessen.
Gruß aus DN
Greg

Offline

#3 07.05.2020 13:07:37

sewulba
Mitglied

Re: [gelöst]2 Bildschirme, nach Standby ist es essig.

Greg schrieb:

Bei mir steht es so:

Section "ServerFlags"
        Option "BlankTime"   "0"   # Zeit wann der Monitor Schwarz wird (Standard: 10 Minuten)
        Option "StandbyTime" "0"   # Zeit wann der Monitor in den Standby geht (Standard: 20 Minuten)
        Option "SuspendTime" "0"   # Zeit wann der Monitor in den Suspend geht (Standard: 30 Minuten)
        Option "OffTime"     "40"   # Zeit wann sich der Monitor abschaltet (Standard: 40 Minuten)
EndSection

Vielleicht hast du nur BlankTime vergessen.
Gruß aus DN
Greg

War eine gute Idee und habe ich umgesetzt. Aber es ist wie vorher auch bei etwa 20 Minuten gehen die 2 Bildschirme in Standby-Mode und danach geht nur noch einer an. :-(

Gruss Sewulba

Beitrag geändert von sewulba (07.05.2020 13:08:06)

Offline

#4 07.05.2020 14:31:40

schard
Moderator

Re: [gelöst]2 Bildschirme, nach Standby ist es essig.

Das hier hast du schon abgearbeitet?

Offline

#5 09.05.2020 04:29:17

sewulba
Mitglied

Re: [gelöst]2 Bildschirme, nach Standby ist es essig.

schard schrieb:

Das hier hast du schon abgearbeitet?

Ich muss schon wieder den Kopf schütteln. Ich hatte zwischenzeitlich folgende Zeile geändert von

Option	"DPMS" "true"

zu

Option	"DPMS" "false"

Für jeden Monitor, also 3 mal insgesamt. Das hatte auch nicht gereicht.

Nach dem durcharbeiten des Links vom Meister Schard (der mich andauernd rettet, danke dafür) hat die folgende Zeile nun geholfen:

Section "Extensions"
	Option	"DPMS"	"Disable"
EndSection

Das Leben kann so einfach sein, wenn man den richtigen Artikel findet und vor lauter Wald auch die Bäume sieht.

Danke, mal wieder, an alle die mir hier geholfen haben und auch dickes Danke schön an Schard für den entscheidenden Tipp.

Gruss Sewulba

PS.: Zum Glück habe ich es wenigstens auf Anhieb hinbekommen unter Arch eine asynchrone USB Verbindung zu meinem Verstärker hinzubekommen (auf DA-Wandler des Verstärkers per USB). War unter Arch auch megaeinfach. Musste nichts explizit groß nachbessern im System. :-)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums