Du bist nicht angemeldet.

#1 07.04.2020 00:36:11

diabolusUmarov
Mitglied

[GELÖST] PHP nicht mit updaten

Mahlzeit!

Ich habe da ein kleines Problem. Wenn ich meinen Server, auf dem Arch läuft, update, dann funktioniert hinterher soweit auch alles. Bis auf die kleine Tatsache, dass natürlich auch PHP upgedated wird. Das soll es aber nicht, denn das System, was ich dort laufen habe, benötigt eine ältere Version, da bei aktuelleren Versionen eine Verschlüsselung fehlt, auf die dummerweise mein ganzes System aufsetzt. Das soll zwar, wenn einige Punkte jetzt eingebaut und funktionsfähig sind, umgestellt werden, bis dahin bin ich aber auf die ältere Version angewiesen.

Kann ich denn nun Arch nicht irgendwie sagen, dass es PHP so lassen soll, wie es ist?

Beitrag geändert von diabolusUmarov (09.04.2020 14:24:14)

Offline

#2 07.04.2020 06:47:33

niemand
Mitglied

Re: [GELÖST] PHP nicht mit updaten

man pacman.conf

… dass es gerade bei PHP ’ne äußerst schlechte Idee ist, eine alte Version zu fahren, zumindest, wenn das betreffende System von außen erreichbar ist, sollte bekannt sein. Dass das Zurückhalten von Updates für ein Paket früher oder später zu kaputten Abhängigkeiten führen kann, ebenfalls.

Beitrag geändert von niemand (07.04.2020 06:48:36)

Offline

#3 07.04.2020 09:38:06

diabolusUmarov
Mitglied

Re: [GELÖST] PHP nicht mit updaten

niemand schrieb:

man pacman.conf

Danke für den Hinweis. Schaue ich mal rein.

… dass es gerade bei PHP ’ne äußerst schlechte Idee ist, eine alte Version zu fahren, zumindest, wenn das betreffende System von außen erreichbar ist, sollte bekannt sein. Dass das Zurückhalten von Updates für ein Paket früher oder später zu kaputten Abhängigkeiten führen kann, ebenfalls.

Ist mit soweit bekannt. Die Sache gefällt mir auch nicht, aber bis in meinem System mcrypt nicht raus ist, habe ich keine andere Wahl.

Offline

#4 07.04.2020 09:40:16

Dirk
Moderator

Re: [GELÖST] PHP nicht mit updaten

mcrypt ist seit mindestens vier Jahren tot. Statt PHP nicht zu upgraden wäre es nach all der Zeit doch mal angebracht, deine Anwendung upzugraden, oder? smile

Offline

#5 07.04.2020 11:19:08

diabolusUmarov
Mitglied

Re: [GELÖST] PHP nicht mit updaten

Dirk schrieb:

mcrypt ist seit mindestens vier Jahren tot. Statt PHP nicht zu upgraden wäre es nach all der Zeit doch mal angebracht, deine Anwendung upzugraden, oder? smile

Definitiv! Das steht auch auf der ToDo-Liste. Mein Problem ist dabei aber im Moment, wo ich jetzt dran arbeite ist essentiell für die, die es benutzen. Läuft das nicht, ist meine Anwendung in Kürze für die nicht mehr nutzbar und das will ich echt nicht riskieren. Deshalb hat das im Moment Vorrang.

Ist eine schmale Ausrede ich weiss. Hätte ich mich früher Schlau gemacht, oder mich auf dem Laufenden gehalten, wäre das Problem nicht passiert. Nützt aber jetzt leider nichts mehr sad

Offline

#6 07.04.2020 11:59:49

Dirk
Moderator

Re: [GELÖST] PHP nicht mit updaten

diabolusUmarov schrieb:

Das steht auch auf der ToDo-Liste.

Du hattest vier Jahre Zeit. In der IT ist das eine Ewigkeit smile

diabolusUmarov schrieb:

Nützt aber jetzt leider nichts mehr sad

Für den Fall, dass du es noch brauchst, du suchst IgnorePkg.

man pacman.conf schrieb:

       IgnorePkg = package ...
           Instructs pacman to ignore any upgrades for this package when performing a --sysupgrade.
           Shell-style glob patterns are allowed.

Offline

#7 07.04.2020 15:30:47

diabolusUmarov
Mitglied

Re: [GELÖST] PHP nicht mit updaten

Dirk schrieb:

Du hattest vier Jahre Zeit. In der IT ist das eine Ewigkeit smile

Leider, leider bin ich nicht in der Lage, dir zu widersprechen! Ich kann mich nur so rausreden, dass ich das Ende von mcrypt erst mitbekommen habe, als es aus PHP raus geflogen ist. Nein, eigentlich, als ich den neuen Server eingerichtet habe und da dann die Probleme wegen dem fehlenden mcrypt hatte. Ist aber nur eine echt schwache Ausrede, muss ich selbst zugeben.

Offline

#8 09.04.2020 14:22:28

diabolusUmarov
Mitglied

Re: [GELÖST] PHP nicht mit updaten

Dirk schrieb:

Für den Fall, dass du es noch brauchst, du suchst IgnorePkg.

Vielen Dank! Damit sollte ich ja jetzt erst einmal klar kommen. Dank der momentanen Ausgangsbeschränkung läuft bei den Anwendern meiner Anwendung im Moment eh nicht viel, da kann ich das mit dem Ändern der Verschlüsslung jetzt mal schnell in Angriff nehmen wink

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums