Du bist nicht angemeldet.

#1 20.03.2020 19:06:56

Erl
Mitglied

Problem mit "mkinitcpio": ==> ERROR: binary dependency [gelöst]

Erst einmal Entschuldigung, das ich einen neuen Post wegen eines euch bekannten Problems aufmache.
Ich finde aber keine Lösung und bin auf Hilfe angewiesen!

Mir ist der Rechner während eines Updates abgestürzt.

Beim booten folgende Meldung:

Loading Linux linux ...
error: file /boot/vmlinuz-linux' not found.
Loading initial ramdisk ...
error: you need to load the kernel first.

Press any key to continue...

Ich habe das System, in einem Livesystem, mit chroot ein update durchgeführt.

sudo pacman -Syyu

und abschliessend

[root@ubuntu /]# sudo mkinitcpio -p linux
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.5.9-arch1-2
  -> Running build hook: [base]
  -> Running build hook: [udev]
==> ERROR: binary dependency `libp11-kit.so.0' not found for `/usr/lib/systemd/systemd-udevd'
==> ERROR: binary dependency `libp11-kit.so.0' not found for `/usr/bin/udevadm'
==> ERROR: binary dependency `libp11-kit.so.0' not found for `/usr/bin/systemd-tmpfiles'
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> WARNING: errors were encountered during the build. The image may not be complete.

Error beim booten:
xuoa9

Beitrag geändert von Erl (21.03.2020 12:12:54)

Offline

#2 20.03.2020 19:50:59

Icecube63
Mitglied

Re: Problem mit "mkinitcpio": ==> ERROR: binary dependency [gelöst]

Bist du sicher dass

[root@ubuntu /]# sudo mkinitcpio -p linux

im chroot durchgeführt wurde? Habs schon lange nicht mehr gemacht, aber meine dass dies anders aussieht

EDIT:

root@archiso /# 

hatte ich in Erinnerung, aber die Ubuntu müsste auch gehen. Aber ich vermute dir ist dabei ein Fehler unterlaufen. Daher versuche es am besten nochmal nach der Anleitung aus dem Wiki.

Beitrag geändert von Icecube63 (20.03.2020 19:56:51)

Offline

#3 20.03.2020 21:35:46

stefanhusmann
Moderator

Re: Problem mit "mkinitcpio": ==> ERROR: binary dependency [gelöst]

Aufgrund deiner Angaben sehe ich erstmal zwei Ansätze.

  1. Du könntest mal versuchen, ob im chroot das Paket libp11-kit nachinstalliert werden kann. Für mich sieht es so aus, als sei es unvollständig oder gar nicht installiert.

  2. Die UUID, die im Screenshot zu sehen ist, mit der unter /dev/disk/by-UUID vergleichen (Zeichen zuviel?).

Online

#4 21.03.2020 12:11:05

Erl
Mitglied

Re: Problem mit "mkinitcpio": ==> ERROR: binary dependency [gelöst]

Ich melde mich endlich wieder von meinem Arch!
Vielen Dank!

ich habe lib11-kit nachinstalliert.
Die UUID hat übereingestimmet.

Dann ist mkinitcpio -p linux fehlerfrei durchgelaufen.

Ich könnte schwören das ich "lib11-kit" schonmal nachinstalliert hatte, dies war aber unter einem Ubuntu LiveSystem im chroot....ob dies wohl ein unterschied ausmacht?

Dennoch Danke an Alle die mir geholfen haben!!

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums