Du bist nicht angemeldet.

#1 09.03.2020 12:32:01

Hauiiuah
Mitglied

Probleme mit Mirror-Monitor

Hallo Zusammen,

ich habe folgendes Problem: Ich habe einen Schenker Laptop mit Nvidia dedizierter GPU und einer Intel Karte.
Ich habe als Treiber den xf86-video-nouveau installiert. Funktioniert auf dem Laptop soweit alles. Aufloesung passt, ich kann mit arbeiten. Jetzt wollte ich fuer ein groesseres Projekt den Komfort eines Monitors nutzen. Habe den Monitor via HDMI angeschlossen und in xrandr geschaut. Wurde auch erkannt.
Dann mit

xrandr --output eDP1 --mode 1920x1080 --output HDMI-1-1 --mode 1920x1080 --same-as eDP1 

den Bildschirm gespiegelt.  Es wird mir auch das Bild angezeigt, jedoch bis auf den Mauszeiger veraendert sich dort nichts mehr.

Link zu Gif-Video

Wie man in dem VIdeo sieht, bewegt sich die Maus auf beiden Bildschirmen, aber wenn ich z.B. ein Terminal oeffne, wird es auf dem externen Monitor nicht angezeigt.

Deaktiviere ich hingegen den externen Bildschirm und aktiviere ihn danach wieder, habe ich den aktuellen Zustand auf dem Monitor.

In der Xorg.0.log bekomme ich auch keine Fehlermeldungen.

Was mache ich falsch? Eine xorg.conf habe ich nicht.

Gruss Jan

Offline

#2 09.03.2020 13:21:32

efreak4u
Mitglied

Re: Probleme mit Mirror-Monitor

Kannst du statt --same-as mal die Option --right-of nutzen? Damit erweiterst du den Monitor, statt ihn zu spiegeln. Nur um erstmal zu Testen, ob es grundsaetzlich geht, oder du ein Problem mit dem Treiber hast.

Offline

#3 09.03.2020 14:23:20

Hauiiuah
Mitglied

Re: Probleme mit Mirror-Monitor

Habe ich gerade mal ausprobiert,  mein Monitor ist erweitert, ich sehe quasi meine Workspace 2 jetzt auf dem Monitor, aber selbes Problem. Ich kann mit der Maus rechts in den anderen Monitor, der Cursor wird angezeigt , der Rest ist wieder ein statisches Bild. Auch hier keine Fehler in den Xorg.0.log und auch nichts in dmesg.

Offline

#4 09.03.2020 15:08:35

efreak4u
Mitglied

Re: Probleme mit Mirror-Monitor

Welchen Fenstermanager/Desktop-Umgebung nutzt du? Wenn du auf dem internen Monitor ein Fenster oeffnest und dieses auf den zweiten Monitor ziehst, wird dieses dort auch nicht angezeigt?

Offline

#5 09.03.2020 16:17:08

Hauiiuah
Mitglied

Re: Probleme mit Mirror-Monitor

Ich benutze i3wm. Wenn ich das Fenster auf den zweiten Monitor ziehe, verschwindet es, und nur der Zeiger bleibt. Ich hab es auch schon mit xfce versucht, dort habe ich genau das selbe Problem.

Ebenfalls habe ich einfach mal um es auszuschliessen, einen anderen Monitor, ein anderes Kabel und auch mal statt des HDMI-1-1 mal den DP-1-1 ausprobiert, gleiches Problem.

Ich habe ebenfalls mal den Nvidia Treiber installiert, dann bekomme ich jedoch nur den HDMI Ausgang zum laufen, das interne Display bekommt dann kein Signal mehr. Egal was ich dann mache, ich brauche das externe Display sonst sehe ich nichts mehr.

Ich vermute inzwischen ich muss mir eine xorg.conf anlegen. Gerade noch aus frust eine Live-CD von Fedora, elementary-OS und Ubuntu ausprobiert. Alle erkennen den Monitor, ueberall das selbe Problem. => Es wird nur der Cursor geupdatet.

Ich werd noch verrueckt big_smile

Beitrag geändert von Hauiiuah (09.03.2020 17:42:03)

Offline

#6 09.03.2020 21:35:28

efreak4u
Mitglied

Re: Probleme mit Mirror-Monitor

Tritt das Problem auch unter einem anderen Fenstermanager auf?

Offline

#7 10.03.2020 23:51:57

Hauiiuah
Mitglied

Re: Probleme mit Mirror-Monitor

Leider ja, ich hatte ja zu testzwecken mal xfwm und compiz ausprobiert.  Wie gesagt selbst mit anderen Distros und Live-Cds hat es nicht funktioniert.

Offline

#8 13.03.2020 14:39:24

Hauiiuah
Mitglied

Re: Probleme mit Mirror-Monitor

Update:

Ich habe nochmal alles was nouveau, intel und nvidia betrifft deinstalliert. Nochmal sauber den nvidia Treiber installiert und mir die generierte xorg.conf von dem nvidia-xconfig zur Brust genommen. Habe dort noch meine Intel-Karte als weiteres device hinzugefuegt und siehe da, es funktioniert nun. Ich habe auch schon mit diff geschaut was jetzt an der Konfiguration anders ist als vorher, aber bis auf die identifier namen hat sich nichts geaendert.

Sehr seltsam.

Nichts destotrotz, vielen dank fuer eure Muehen smile

Gruss Jan

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums