Du bist nicht angemeldet.

#1 16.02.2020 12:15:14

hellmi666
Mitglied

Nummernblock aktivieren

Hallo Leute,
nachdem ich meinen Laptop mit Arch-Linux und Mate-Desktop eingerichtet und auch das Problem mit dem nicht funktionierenten Wlan mit eurer Hilfe gelöst bekommen habe, möchte ich euch nun bitten, das letzte Problem mit mir zu lösen.
Ich bekomme es nicht hin, den Nummernblock einzuschalten. Der Laptop besitzt zwar über dem Block eine "num"-Taste aber allerdings keine LED, bei der man den aktuellen Schaltzustand erkennen kann.
Hier einige Infos:

 sudo lshw -short
H/W path         Device  Class          Description
===================================================
                         system         HP Laptop 15-bw0xx (2CN90EA#ABD)
/0                       bus            8330
/0/0                     memory         128KiB BIOS
/0/4                     processor      AMD E2-9000e RADEON R2, 4 COMPUTE CORES 
/0/4/5                   memory         160KiB L1 cache
/0/4/6                   memory         1MiB L2 cache
/0/20                    memory         4GiB System Memory
/0/20/0                  memory         SODIMM DDR Synchronous [empty]
/0/20/1                  memory         4GiB SODIMM DDR4 Synchronous Unbuffered 
/0/100                   bridge         Family 15h (Models 60h-6fh) Processor Ro
/0/100/0.2               generic        Family 15h (Models 60h-6fh) I/O Memory M
/0/100/1                 display        Stoney [Radeon R2/R3/R4/R5 Graphics]
/0/100/1.1               multimedia     Advanced Micro Devices, Inc. [AMD/ATI]
/0/100/2.1               bridge         Family 15h (Models 60h-6fh) Processor Ro
/0/100/2.2               bridge         Family 15h (Models 60h-6fh) Processor Ro
/0/100/2.2/0     enp2s0  network        RTL8111/8168/8411 PCI Express Gigabit Et
/0/100/2.4               bridge         Family 15h (Models 60h-6fh) Processor Ro
/0/100/2.4/0     wlp3s0  network        RTL8723DE 802.11b/g/n PCIe Adapter
/0/100/8                 generic        Carrizo Platform Security Processor
/0/100/9.2               multimedia     Family 15h (Models 60h-6fh) Audio Contro
/0/100/10                bus            FCH USB XHCI Controller
/0/100/10/0      usb2    bus            xHCI Host Controller
/0/100/10/0/1            multimedia     HP Webcam
/0/100/10/0/3            storage        Intenso Rainbow Line
/0/100/10/0/4            storage        USB2.0-CRW
/0/100/10/1      usb3    bus            xHCI Host Controller
/0/100/11                storage        FCH SATA Controller [AHCI mode]
/0/100/12                bus            FCH USB EHCI Controller
/0/100/12/1      usb1    bus            EHCI Host Controller
/0/100/12/1/1            bus            Root Hub
/0/100/12/1/1/4          communication  802.11n WLAN Adapter
/0/100/14                bus            FCH SMBus Controller
/0/100/14.3              bridge         FCH LPC Bridge
/0/101                   bridge         Family 15h (Models 60h-6fh) Host Bridge
/0/102                   bridge         Family 15h (Models 60h-6fh) Host Bridge
/0/103                   bridge         Carrizo Audio Dummy Host Bridge
/0/104                   bridge         Stoney HT Configuration
/0/105                   bridge         Stoney Address Maps
/0/106                   bridge         Stoney DRAM Configuration
/0/107                   bridge         Stoney Miscellaneous Configuration
/0/108                   bridge         Stoney PM Configuration
/0/109                   bridge         Stoney NB Performance Monitor
/1                       power          JC04041
/2               scsi2   storage        
/3               scsi4   storage        
[hellmi555@Arch ~]$ sudo dmidecode | grep -A3 'BIOS Information' 
BIOS Information
	Vendor: Insyde
	Version: F.23
	Release Date: 04/03/2018
 nano  /etc/X11/xorg.conf.d/20-keyboard.conf                    
Section "InputClass"
        Identifier "keyboard"
        MatchIsKeyboard "yes"
        Option "XkbLayout" "de"
        Option "XkbVariant" "nodeadkeys"
        Option "XkbModel" "pc105"
EndSection

Ist das Tastaturmodel "pc105" das Richtige? Ich habe auch "pc104" probiert.
Weiterhin habe ich numlockx installiert und

 numlockx on & 

im Autostart (gestartet wird über xinitrc).
Auch ein

numlockx on

im Terminal bringt nichts.

nano .xinitrc
...
numlockx &
exec mate-session

Laut Wiki versuchte ich diese Einträge

dconf write org.mate.peripherals-keyboard remember-numlock-state false
dconf write org.mate.peripherals-keyboard numlock-state 'on'

welche nicht funktionieren, weil falsche Syntax.
Ebenso wenig Erfolg hatte ich mit

dconf write /org/mate/peripherals/keyboard remember-numlock-state false
dconf write /org/mate/peripherals/keyboard numlock-state 'on'

Wenn ihr weitere Infos braucht, um mir zu helfen, dann bitte melden.

Viele Grüße
Hellmi

Beitrag geändert von hellmi666 (16.02.2020 12:19:08)

Offline

#2 16.02.2020 16:34:28

waldbaer59
Mitglied

Re: Nummernblock aktivieren

Kannst du mal mit "xev" prüfen ob deine Num-Taste den Scancode 77 hat?
Nur zur Sicherheit....

VLG
Stephan

Offline

#3 18.02.2020 19:26:33

hellmi666
Mitglied

Re: Nummernblock aktivieren

Entschuldigt wenn ich mich hier nur sporadisch sehen lasse, aber ich bin familiär sehr stark gebunden.
Xev beim Betätigen der num-Taste:

KeyRelease event, serial 41, synthetic NO, window 0x3a00001,
    root 0x6a5, subw 0x0, time 221670, (495,183), root:(618,330),
    state 0x10, keycode 77 (keysym 0xff7f, Num_Lock), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

Offline

#4 18.02.2020 21:06:14

waldbaer59
Mitglied

Re: Nummernblock aktivieren

Hmmm, ich habe mit "numlockx on" eigentlich™ bisher nur Erfolg verzeichnen können. Und weil der Scancode auch stimmt bin ich gerade etwas ratlos. Es reicht i.a. als entsprechender User den Befehl in einem Terminal aufzurufen (in einer Terminal-Emulation innerhalb des DE) um zu testen ob es klappen kann.
Bitte mal probieren. Wenn es "funzt" sehen wir weiter.

VLG
Stephan

Beitrag geändert von waldbaer59 (18.02.2020 21:06:55)

Offline

#5 19.02.2020 20:13:11

hellmi666
Mitglied

Re: Nummernblock aktivieren

Du meinst

numlockx on

im Terminal eingeben? Wenn ja, das habe ich schon probiert, da passiert nichts.

Offline

#6 20.02.2020 16:05:02

Greg
Mitglied

Re: Nummernblock aktivieren

hellmi666 schrieb:

..da passiert nichts.

Hast du das denn überhaupt installiert?
pacman -S numlockx

Offline

#7 20.02.2020 20:42:08

hellmi666
Mitglied

Re: Nummernblock aktivieren

Aber klar doch, schrieb ich doch im ersten Post.

[hellmi555@Arch ~]$ sudo pacman -S numlockx
Warnung: numlockx-1.2-5 ist aktuell -- Reinstalliere
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (1) numlockx-1.2-5

Gesamtgröße der installierten Pakete:  0,01 MiB
Größendifferenz der Aktualisierung:  0,00 MiB

:: Installation fortsetzen? [J/n] n
[hellmi555@Arch ~]$ numlockx on
[hellmi555@Arch ~]$ 

PS: Ich schrieb doch schon mal bei meinem Wlan-Problem, dass ich noch ein Ubuntu auf dem Laptop habe. Dort funktioniert der Nummernblock. Also technisch und auch durch das Bios ist da alles in Ordnung.

Beitrag geändert von hellmi666 (20.02.2020 20:47:04)

Offline

#8 20.02.2020 21:06:48

waldbaer59
Mitglied

Re: Nummernblock aktivieren

Ich bin wirklich ratlos im Moment. Sowas ist mir seither nur dann passiert, wenn ich mit einem Kommando vorher den Zustand der NumLock Taste 'eingefroren' hatte (sowas macht man gerne, wenn die Tastatur keine LEDs hat und man einen definierten Zustand fixieren will wink ). Und ich habe unter lxde in dieser Hinsicht schon Einiges gebastelt, da kannste sicher sein....
Nötigenfalls könnten wir uns die Tage mal per Telegram oder einem Messenger zusammenfinden und live was probieren wenn du magst. Ich brauche nur noch ein wenig Zeit zum Grübeln wink ...

Offline

#9 20.02.2020 22:22:37

open-source greg
Mitglied

Re: Nummernblock aktivieren

Geht es denn auf der tty?

Ich würds mal mit anderen Treibern versuchen (evdev, libinput, keyboard).
Welchen benutzt du denn? Könnte mir vorstellen dass es bei libinput noch einige Bugs gibt, da relativ neu.

Offline

#10 21.02.2020 14:22:04

primus
Mitglied

Re: Nummernblock aktivieren

Hallo hellmi666

schau mal nach, ob Fehlermeldungen im Journal vorhanden sind?

journalctl | grep numlock*

journalctl -b --since "1 hour ago" | grep error

"1 hour ago" als Beispiel evtl. anpassen.

Gruß Primus

Beitrag geändert von primus (21.02.2020 14:37:20)

Offline

#11 21.02.2020 15:41:45

hellmi666
Mitglied

Re: Nummernblock aktivieren

open-source greg schrieb:

Geht es denn auf der tty?

Ich habe mal auf tty2 gewechselt, da funktioniert er.

primus schrieb:

schau mal nach, ob Fehlermeldungen im Journal vorhanden sind?

$ journalctl -b --since "1 hour ago" | grep error
Feb 21 14:28:15 Arch kernel: ACPI Error: Aborting method \_SB.WLBU._STA due to previous error (AE_NOT_FOUND) (20191018/psparse-529)
Feb 21 14:28:15 Arch kernel: ACPI Error: Aborting method \_SB.WLBU._STA due to previous error (AE_NOT_FOUND) (20191018/psparse-529)
Feb 21 14:28:15 Arch kernel: ACPI Error: Aborting method \_SB.WLBU._STA due to previous error (AE_NOT_FOUND) (20191018/psparse-529)
Feb 21 14:28:15 Arch systemd[1]: Couldn't move remaining userspace processes, ignoring: Input/output error
Feb 21 14:28:17 Arch kernel: platform regulatory.0: Direct firmware load for regulatory.db failed with error -2

Ich habe nur die Daten von heute genommen.

journalctl | grep numlock*
Feb 21 14:28:18 Arch systemd[1]: Started numlock.
Feb 21 14:28:18 Arch audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=numlock comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 21 14:28:18 Arch kernel: audit: type=1130 audit(1582291698.175:20): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=numlock comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 21 14:28:18 Arch systemd[432]: numlock.service: Failed to execute command: No such file or directory
Feb 21 14:28:18 Arch systemd[432]: numlock.service: Failed at step EXEC spawning /usr/local/bin/numlock: No such file or directory
Feb 21 14:28:18 Arch systemd[1]: numlock.service: Main process exited, code=exited, status=203/EXEC
Feb 21 14:28:18 Arch systemd[1]: numlock.service: Failed with result 'exit-code'.
Feb 21 14:28:18 Arch audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=numlock comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Feb 21 14:28:18 Arch kernel: audit: type=1131 audit(1582291698.205:23): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=numlock comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'

Muss der numlock.service erst gestartet werden? Wenn ja, mit systemctl?

Beitrag geändert von hellmi666 (21.02.2020 15:45:28)

Offline

#12 21.02.2020 16:52:56

stefanhusmann
Moderator

Re: Nummernblock aktivieren

Failed at step EXEC spawning /usr/local/bin/numlock: No such file or directory

Wieso /usr/local? Arch-Pakete installieren nie nach /usr/local, und auch AUR-Pakete sollten das nicht tun.

Offline

#13 21.02.2020 21:12:42

primus
Mitglied

Re: Nummernblock aktivieren

kann das sein, dass du "numlock.service" eingerichtet hast?

Console: Using a separate service
https://wiki.archlinux.org/index.php/Ac … up#Console

Beitrag geändert von primus (21.02.2020 21:22:56)

Offline

#14 22.02.2020 08:26:53

hellmi666
Mitglied

Re: Nummernblock aktivieren

stefanhusmann schrieb:

Wieso /usr/local? Arch-Pakete installieren nie nach /usr/local, und auch AUR-Pakete sollten das nicht tun.

Ich habe numlockx einfach mit pacman installiert.

primus schrieb:

kann das sein, dass du "numlock.service" eingerichtet hast?

Nicht wissentlich, drum fragte ich, ob ich es machen sollte.

Offline

#15 22.02.2020 11:01:49

primus
Mitglied

Re: Nummernblock aktivieren

Letztendlich deine Entscheidung!
Persönlich würde ich es so einfach wie möglich umsetzen.

Entferne bitte alles was mit numlock zu tun hat.
Den numlock.service, das Packet numlockx und evtl. auch das AUR Packet falls installiert.
Sowie alle Einstellungen (Script usw.) die du bisher durchgeführt hast.


Wenn du das Packet numlockx nach einen Neustart installiert hast, sollte es so bei
dir nach dem ausführen des folgenden Befehls so aussehen:

which numlockx
/usr/bin/numlockx

Bevor du den folgenden Befehl in der Konsole 1 ausführst:

numlockx on

Konsole 2 starten

journalctl -f | grep numlock*

Konsole 3 starten

journalctl -f | grep error

ausführen und prüfen, ob nun die Numlock-Tasten funktionieren.

Viel Erfolg!

Beitrag geändert von primus (22.02.2020 11:09:12)

Offline

#16 22.02.2020 16:04:42

hellmi666
Mitglied

Re: Nummernblock aktivieren

Vielen Dank für deine Hilfe.

primus schrieb:

Entferne bitte alles was mit numlock zu tun hat.
Den numlock.service, das Packet numlockx und evtl. auch das AUR Packet falls installiert.
Sowie alle Einstellungen (Script usw.) die du bisher durchgeführt hast.

Habe ich alles gemacht.

primus schrieb:

Wenn du das Packet numlockx nach einen Neustart installiert hast, sollte es so bei
dir nach dem ausführen des folgenden Befehls so aussehen:

which numlockx
/usr/bin/numlockx

Genau so siehts aus.
Die Befehle

journalctl -f | grep numlock*

und

journalctl -f | grep error

funktionieren nicht, d.h. es passiert, außer einem blinkenden Cursor eine Zeile drunter, nichts. Da du aber weiter oben den Parameter -b statt -f hattest:

$ journalctl -b | grep numlock*
Feb 22 14:48:54 Arch sudo[1069]: hellmi555 : TTY=pts/0 ; PWD=/home/hellmi555 ; USER=root ; COMMAND=/usr/bin/pacman -S numlockx<<<<<<<
$ journalctl -b | grep error
Feb 22 14:47:30 Arch kernel: ACPI Error: Aborting method \_SB.WLBU._STA due to previous error (AE_NOT_FOUND) (20191018/psparse-529)
Feb 22 14:47:30 Arch kernel: ACPI Error: Aborting method \_SB.WLBU._STA due to previous error (AE_NOT_FOUND) (20191018/psparse-529)
Feb 22 14:47:30 Arch kernel: ACPI Error: Aborting method \_SB.WLBU._STA due to previous error (AE_NOT_FOUND) (20191018/psparse-529)
Feb 22 14:47:32 Arch kernel: platform regulatory.0: Direct firmware load for regulatory.db failed with error -2

Ein beherztes

 numlockx on

bringt aber den Nummernblock nicht zum laufen. Auf tty2, tty3 usw. funktioniert er auch ohne numlockx.

Offline

#17 22.02.2020 19:53:58

open-source greg
Mitglied

Re: Nummernblock aktivieren

Bist du der Sache mit den X-Treibern schon nachgegangen?
Hab grad nachgeschaut, ubuntu scheint mittlerweile libinput zu benutzen.

Wenn du Glück hast ist die Sache also vielleicht mit einem

pacman -S xf86-input-libinput

und einem

Driver "libinput"

,in der InputSection deiner 20-input.conf, erledigt.

EDIT: Sehe grad ist bei arch ja auch Standart.
Dann vielleicht eher mit xf86-input-evdev probieren.

Beitrag geändert von open-source greg (22.02.2020 20:02:04)

Offline

#18 23.02.2020 08:50:28

hellmi666
Mitglied

Re: Nummernblock aktivieren

Als erstes möchte ich mich bedanken, dass ihr euch solch eine Mühe mit mir gebt.

Also ich habe xf86-input-evdev installiert und das ist die 10-evdev-conf:

#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Nummernblock bleibt weiterhin funktionslos. Es steht auch nichts von numlock drin.
So langsam geb ichs auf.

Beitrag geändert von hellmi666 (23.02.2020 08:51:25)

Offline

#19 23.02.2020 11:24:37

primus
Mitglied

Re: Nummernblock aktivieren

hellmi666 schrieb:

Als erstes möchte ich mich bedanken, dass ihr euch solch eine Mühe mit mir gebt.

Also ich habe xf86-input-evdev installiert und das ist die 10-evdev-conf:

#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

Nummernblock bleibt weiterhin funktionslos. Es steht auch nichts von numlock drin.
So langsam geb ichs auf.

##################################################

Bevor du das Handtuch schmeisst, probier doch noch zu guter Letzt das hier aus.
Console: Using a separate service
https://wiki.archlinux.org/index.php/Ac … up#Console
https://linux.die.net/man/1/setleds
Tip: These steps can be automated by installing the systemd-numlockonttyAUR package and enabling the numLockOnTty service.

Beitrag geändert von primus (23.02.2020 11:28:58)

Offline

#20 23.02.2020 11:49:10

hellmi666
Mitglied

Re: Nummernblock aktivieren

primus schrieb:

Bevor du das Handtuch schmeisst, probier doch noch zu guter Letzt das hier aus.
Console: Using a separate service
https://wiki.archlinux.org/index.php/Ac … up#Console
https://linux.die.net/man/1/setleds
Tip: These steps can be automated by installing the systemd-numlockonttyAUR package and enabling the numLockOnTty service.

Kein Erfolg. Der Unterschied ist, ich brauche bei tty(2...6) nicht erst die num-Taste zum Aktivieren des Nummernblocks betätigen. Er ist gleich an.

Beitrag geändert von hellmi666 (23.02.2020 13:16:13)

Offline

#21 23.02.2020 12:11:45

primus
Mitglied

Re: Nummernblock aktivieren

hellmi666 schrieb:
primus schrieb:

Bevor du das Handtuch schmeisst, probier doch noch zu guter Letzt das hier aus.
Console: Using a separate service
https://wiki.archlinux.org/index.php/Ac … up#Console
https://linux.die.net/man/1/setleds
Tip: These steps can be automated by installing the systemd-numlockonttyAUR package and enabling the numLockOnTty service.

Kein Erfolg. Der Unterschied ist, ich brauche bei tty(2...6) nicht erst die num-Taste zum Aktivieren des Nummernblocks betätigen. Er ist glein an.

########################################################################################

Besteht das Problem auch bei einem anderen Benutzer?


Du könntest mal eine Live Ubuntu CD starten und dir anschauen, welches Tastaturlayout dort verwendet wird.

setxkbmap -print -verbose 10

Folgende Dateien konntest du dir dort auch mal anschauen und vergleichen:
.bashrc
.bash_profile
.xinitrc
/etc/X11/  ob hier irgendwelche Dateien vorhanden sind, die Numlock Einstellungen beinhalten.

Beitrag geändert von primus (23.02.2020 12:26:20)

Offline

#22 23.02.2020 14:08:53

hellmi666
Mitglied

Re: Nummernblock aktivieren

Mit einem neuen Benutzer testen, ist kompliziert, weil ich durch mein automatisiertes Booten kein X mit einem anderen Benutzer starten kann.

Bei Ubuntu:
-- gibt es keine .bash_profile und .xinitrc
-- gibt es in der .bashrc keine Auffälligkeiten
-- gibt es unter /etc/X11/Xsession.d eine Datei 55numlockx

# X session startup script: /etc/X11/Xsession.d/55numlockx

# Initial settings
NUMLOCK=auto

# Load configuration
cf=/etc/default/numlockx
[ ! -r $cf ] || . $cf

# Toggle numlock if we're not removed
nlx=/usr/bin/numlockx
[ ! -x $nlx ] || {
    case $NUMLOCK in
        # 'keep' is an undocumented state (see `man 1 numlockx'), though
        # /etc/default/numlockx mentions it; do nothing
        keep)
            return 0
            ;;
        off|on|toggle)
            ;;
        *)
            NUMLOCK=on
            if [ -x /usr/sbin/laptop-detect ];then
                ltd=/usr/sbin/laptop-detect
            else
                ltd=/usr/bin/laptop-detect
            fi
            [ ! -x $ltd ] || ! $ltd || NUMLOCK=off
            # Enable numlock for USB keyboard on laptop
            if [ -f /bin/udevadm ] ; then
                for kbd in `udevadm trigger --dry-run --verbose --property-match=ID_INPUT_KEYBOARD=1` ; do
                    if udevadm info --query=env --path=$kbd | grep -q '^DEVNAME=' ; then
                        continue
                    fi
                    if udevadm info --query=env --path=$kbd | grep -q '^ID_USB_DRIVER=usbhid' ; then
                        NUMLOCK=on
                    fi
                done
            fi
            ;;
    esac
    $nlx $NUMLOCK || :
}

# EOF

Was diese bewerkstelligt entzieht sich aber meinem bescheidenen Wissen.

Beitrag geändert von hellmi666 (23.02.2020 14:09:57)

Offline

#23 23.02.2020 14:20:52

hellmi666
Mitglied

Re: Nummernblock aktivieren

Unter Ubuntu:

~$ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     de
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwertz)
types:      complete
compat:     complete
symbols:    pc+de+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwertz)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+de+inet(evdev)"	};
	xkb_geometry  { include "pc(pc105)"	};
};

Offline

#24 23.02.2020 14:26:35

hellmi666
Mitglied

Re: Nummernblock aktivieren

Und jetz das Selbe unter Arch:

$ setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      hpdv5
layout:     de
variant:    nodeadkeys
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwertz)
types:      complete
compat:     complete
symbols:    pc+de(nodeadkeys)+inet(evdev)
geometry:   hp(dv5)
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwertz)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+de(nodeadkeys)+inet(evdev)"	};
	xkb_geometry  { include "hp(dv5)"	};
};

Beitrag geändert von hellmi666 (23.02.2020 14:32:06)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums