Du bist nicht angemeldet.

#1 06.02.2020 23:58:44

parOy
Mitglied

[BUG] Chromium & VS-Code menus not loading (caused by dmenu?)

Hello Arch Com,

Since 1 month i am trying to find out why i am getting this very strange bug with chromium and also found the same one in vs code.
But i reached my limits and I hope someone here can help me.

# System informations:
- up to date arch with mainline kernel and lts tested
- i3wm
- zsh
- picom

# Short description about the bug:
Application menus are not loading, for example in chromium in the right upper corner the 3 dots button, when pressed doesnt open up the menu.
Or when click on a bookmark folder, then it also doesnt show up.
Same behaviour can be found in vs-code in the extensions section when you click on the settings button of one of your extensiosn.

# Additional information:
When you turn off your compositor ( i use picom, also tried xcompmgr with default config ) and click for example in chromium on a bookmark folder,
then you will see the outlinings of the menu which should appear for half a second, even with the correct size, but the menu will not load.

# More additional information and now things go crazy:
When you switch into fullscreen and back and then click on a menu, it loads directly.
When you start your application with rofi or manually from a terminal (urxvt with zsh and bash tested), then the menus also are loading directly.
A friend of mine who has a very similar arch setup and hardware like me, doesnt have this bug... O_o

# Last additional information:
Maybe i am wrong, but i think that i had the same problem on debian too with dmenu and gnome DE, but i am not 100% sure anymore.

# What i have tried:
I ve studied the source of both rofi and dmenu_run and tried to find some diffs.
Rofi starts the choosen application by using the same process it was started.
So i ve run the selected item by dmenu with "exec" to replace the process. Without success the bug remains.

Then i tried to directly run chromium, without invoking dmenu, this worked. O_o
Even this worked 'echo "chromium" | bash'.

I looked up the source for dmenu... nothing special, nothing which would interfer the processes.

I ve tried many more things but nothing helped, like different hotkey daemon, different WM, compositor.

# Final words
If you need more infos please ask.
I hope someone can find the solution to this mysterious bug and thanks in advance.

Beitrag geändert von parOy (08.02.2020 14:05:28)

Offline

#2 07.02.2020 15:01:32

stefanhusmann
Moderator

Re: [BUG] Chromium & VS-Code menus not loading (caused by dmenu?)

Hört sich nach einem i3-Bug an. Passiert das auch mit einem anderen Fenstermanager?

Wir stellen unsere Fragen hier bevorzugt auf deutsch. smile

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums