Du bist nicht angemeldet.

#1 04.01.2020 09:38:45

Hypershadow
Gast

Automatisches Hochstellen von Zahlen deaktivieren

Guten Tag,

irgendwie habe ich die Einstellung vorgenommen, dass bei der Tastenkombination "^2" die Zahl automatisch als Exponent geschrieben wird. Bevorzugerweise möchte gerne direkt beim Drücken der Taste "^" das Symbol "^" ausgeben. Ich vermute es liegt an meine Keyboard Einstellung. Ich weiß aber nicht, wie ich das beheben kann.

Meine derzeitigen Einstellungen sind:
   System Locale: LANG=de_DE.UTF-8
       VC Keymap: de-latin1-nodeadkeys
      X11 Layout: de
       X11 Model: pc105
     X11 Variant: nodeadkeys

Ich nutze KDE Plasma als Benutzeroberfläche.

Viele Grüße und ich hoffe, dass ihr mir helfen könnt.

#2 04.01.2020 11:21:18

Greg
Mitglied

Re: Automatisches Hochstellen von Zahlen deaktivieren

Das kennst du?
https://wiki.archlinux.de/title/Arch_Li … ch_stellen   Abschnitt X.org
Die Option "XkbVariant" "nodeadkeys" bewirkt eigentlich das was du haben möchtest. Ein^e bewirkt bei nodeathkeys ein ^ und ein e hintereinander. Ist die Variante nodeathkeys nicht mit drin, dann hast du das wie beim Französischen über dem e ist der Zirkel drauf.
Was KDE daraus macht weiss ich nicht.

Beitrag geändert von Greg (04.01.2020 11:21:48)

Offline

#3 06.01.2020 01:04:47

sanni
Mitglied

Re: Automatisches Hochstellen von Zahlen deaktivieren

Oder vielleicht im BIOS so eingestellt?

Offline

#4 06.01.2020 09:57:51

schard
Moderator

Re: Automatisches Hochstellen von Zahlen deaktivieren

Dass dies mit ohne nodeadkeys passiert ist zu erwartendes und von den Machern gewünschtes Verhalten:
https://askubuntu.com/a/484514
Vielleicht überprüfst du mal, ob nodeadkeys tatsächlich verwendet wird.
Wenn ich hier unter Gnome das Tastaturlayour zwischen mit- und ohne Akzenttasten umstelle, wirkt sich dies nicht auf die Ausgabe von localectl aus, jedoch auf das Verhalten bezüglich des Hochstellens.

Beitrag geändert von schard (06.01.2020 11:29:01)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums