Du bist nicht angemeldet.

#1 17.11.2019 17:24:22

w_m
Mitglied

systemd-nspawn xrdp

Hallo!

kann mir bitte jemand helfen XRDP zum laufen zu bringen. Ich habe einen Rechner mit Debian Buster, auf dem habe ich mehrere systemd-nspawn Container laufen, bei Debian-, Ubuntu-, Opensuse-Containern kann ich mich mittels XRDP mit dem jeweiligen Desktop verbinden, bei ArchLinux bekomme ich das nicht hin...
zum Probieren bin ich dieser Anleitng gefolgt https://archlinuxarm.org/forum/viewtopi … =30&t=7828

/var/log/xrdp.log

[20191117-15:49:48] [INFO ] address [0.0.0.0] port [3389] mode 1
[20191117-15:49:48] [INFO ] listening to port 3389 on 0.0.0.0
[20191117-15:49:48] [INFO ] xrdp_listen_pp done
[20191117-15:49:48] [DEBUG] Closed socket 7 (AF_INET 0.0.0.0:3389)
[20191117-15:49:50] [INFO ] starting xrdp with pid 40
[20191117-15:49:50] [INFO ] address [0.0.0.0] port [3389] mode 1
[20191117-15:49:50] [INFO ] listening to port 3389 on 0.0.0.0
[20191117-15:49:50] [INFO ] xrdp_listen_pp done
[20191117-15:49:58] [INFO ] Socket 12: AF_INET connection received from 192.168.0.117 port 49646
[20191117-15:49:58] [DEBUG] Closed socket 12 (AF_INET 192.168.0.240:3389)
[20191117-15:49:58] [DEBUG] Closed socket 11 (AF_INET 0.0.0.0:3389)
[20191117-15:49:58] [INFO ] Using default X.509 certificate: /etc/xrdp/cert.pem
[20191117-15:49:58] [INFO ] Using default X.509 key file: /etc/xrdp/key.pem
[20191117-15:49:58] [DEBUG] TLSv1.3 enabled
[20191117-15:49:58] [DEBUG] TLSv1.2 enabled
[20191117-15:49:58] [DEBUG] Security layer: requested 3, selected 1
[20191117-15:49:58] [INFO ] connected client computer name: PC117
[20191117-15:49:58] [INFO ] adding channel item name cliprdr chan_id 1004 flags 0xc0a00000
[20191117-15:49:58] [INFO ] TLS connection established from 192.168.0.117 port 49646: TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384
[20191117-15:49:58] [DEBUG] xrdp_00000029_wm_login_mode_event_00000001
[20191117-15:49:58] [INFO ] Loading keymap file /etc/xrdp/km-00000407.ini
[20191117-15:49:58] [WARN ] local keymap file for 0x00000407 found and doesn't match built in keymap, using local keymap file
[20191117-15:49:58] [DEBUG] xrdp_wm_log_msg: connecting to sesman ip 127.0.0.1 port 3350
[20191117-15:49:59] [INFO ] xrdp_wm_log_msg: sesman connect ok
[20191117-15:49:59] [DEBUG] xrdp_wm_log_msg: sending login info to session manager, please wait...
[20191117-15:49:59] [DEBUG] return value from xrdp_mm_connect 0
[20191117-15:50:00] [INFO ] xrdp_wm_log_msg: login successful for display 10
[20191117-15:50:00] [DEBUG] xrdp_wm_log_msg: started connecting
[20191117-15:50:03] [DEBUG] Closed socket 19 (AF_UNIX)
[20191117-15:50:07] [DEBUG] Closed socket 19 (AF_UNIX)
[20191117-15:50:11] [DEBUG] Closed socket 19 (AF_UNIX)
[20191117-15:50:14] [DEBUG] Closed socket 19 (AF_UNIX)
[20191117-15:53:26] [DEBUG] Closed socket 19 (AF_UNIX)
[20191117-15:53:30] [DEBUG] Closed socket 19 (AF_UNIX)
[20191117-15:53:33] [DEBUG] xrdp_wm_log_msg: connection problem, giving up
[20191117-15:53:33] [DEBUG] Closed socket 19 (AF_UNIX)
[20191117-15:53:33] [DEBUG] xrdp_wm_log_msg: some problem
[20191117-15:53:33] [DEBUG] xrdp_mm_module_cleanup
[20191117-15:53:33] [DEBUG] Closed socket 18 (AF_INET 127.0.0.1:37234)
[20191117-15:54:24] [DEBUG] Closed socket 12 (AF_INET 192.168.0.240:3389)
[20191117-15:54:24] [DEBUG] xrdp_mm_module_cleanup

/var/log/xrdp-sesman.log

[20191117-15:49:48] [DEBUG] libscp initialized
[20191117-15:49:48] [DEBUG] Testing if xrdp-sesman can listen on 127.0.0.1 port 3350.
[20191117-15:49:48] [DEBUG] Closed socket 1 (AF_INET 127.0.0.1:3350)
[20191117-15:49:48] [INFO ] starting xrdp-sesman with pid 38
[20191117-15:49:48] [INFO ] listening to port 3350 on 127.0.0.1
[20191117-15:49:58] [INFO ] A connection received from 127.0.0.1 port 37234
[20191117-15:50:00] [INFO ] ++ created session (access granted): username root, ip 192.168.0.117:49646 - socket: 12
[20191117-15:50:00] [INFO ] starting Xorg session...
[20191117-15:50:00] [DEBUG] Closed socket 9 (AF_INET 0.0.0.0:5910)
[20191117-15:50:00] [DEBUG] Closed socket 9 (AF_INET 0.0.0.0:6010)
[20191117-15:50:00] [DEBUG] Closed socket 9 (AF_INET 0.0.0.0:6210)
[20191117-15:50:00] [DEBUG] Closed socket 8 (AF_INET 127.0.0.1:3350)
[20191117-15:50:00] [INFO ] calling auth_start_session from pid 42
[20191117-15:50:00] [DEBUG] Closed socket 7 (AF_INET 127.0.0.1:3350)
[20191117-15:50:00] [DEBUG] Closed socket 8 (AF_INET 127.0.0.1:3350)
[20191117-15:50:00] [INFO ] Xorg :10 -auth .Xauthority -config xrdp/xorg.conf -noreset -nolisten tcp -logfile .xorgxrdp.%s.log
[20191117-15:50:10] [ERROR] X server for display 10 startup timeout
[20191117-15:50:10] [CORE ] waiting for window manager (pid 50) to exit
[20191117-15:50:10] [ERROR] X server for display 10 startup timeout
[20191117-15:50:10] [ERROR] another Xserver might already be active on display 10 - see log
[20191117-15:50:10] [DEBUG] aborting connection...
[20191117-15:50:10] [CORE ] window manager (pid 50) did exit, cleaning up session
[20191117-15:50:10] [INFO ] calling auth_stop_session and auth_end from pid 42
[20191117-15:50:10] [DEBUG] cleanup_sockets:
[20191117-15:50:10] [DEBUG] cleanup_sockets: deleting /tmp/.xrdp/xrdp_chansrv_socket_10
[20191117-15:50:10] [DEBUG] cleanup_sockets: deleting /tmp/.xrdp/xrdpapi_10
[20191117-15:50:11] [DEBUG] cleanup_sockets: failed to delete /tmp/.xrdp/xrdpapi_10
[20191117-15:50:11] [INFO ] ++ terminated session:  username root, display :10.0, session_pid 42, ip 192.168.0.117:49646 - socket: 12

~/.xrogxrdp.10.log

[ 19663.133] (WW) Failed to open protocol names file lib/xorg/protocol.txt
[ 19663.137]
X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
[ 19663.137] Build Operating System: Linux Arch Linux
[ 19663.137] Current Operating System: Linux archhead 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64
[ 19663.137] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19.0-6-amd64 root=UUID=98242e9e-ab9e-4b9e-b622-341488c345fd ro quiet
[ 19663.137] Build Date: 25 October 2019  08:43:50AM
[ 19663.137]
[ 19663.137] Current version of pixman: 0.38.4
[ 19663.137]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[ 19663.137] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 19663.138] (++) Log file: ".xorgxrdp.10.log", Time: Sun Nov 17 15:50:01 2019
[ 19663.138] (EE) Unable to locate/open config file: "xrdp/xorg.conf"
[ 19663.138] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[ 19663.138] (==) No Layout section.  Using the first Screen section.
[ 19663.138] (==) No screen section available. Using defaults.
[ 19663.138] (**) |-->Screen "Default Screen Section" (0)
[ 19663.138] (**) |   |-->Monitor "<default monitor>"
[ 19663.138] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[ 19663.138] (==) Automatically adding devices
[ 19663.138] (==) Automatically enabling devices
[ 19663.138] (==) Automatically adding GPU devices
[ 19663.138] (==) Automatically binding GPU devices
[ 19663.138] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 19663.138] (WW) The directory "/usr/share/fonts/misc" does not exist.
[ 19663.138]    Entry deleted from font path.
[ 19663.138] (WW) The directory "/usr/share/fonts/TTF" does not exist.
[ 19663.138]    Entry deleted from font path.
[ 19663.138] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[ 19663.138]    Entry deleted from font path.
[ 19663.139] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[ 19663.139]    Entry deleted from font path.
[ 19663.139] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[ 19663.139]    Entry deleted from font path.
[ 19663.139] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[ 19663.139]    Entry deleted from font path.
[ 19663.139] (==) FontPath set to:

[ 19663.139] (==) ModulePath set to "/usr/lib/xorg/modules"
[ 19663.139] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[ 19663.139] (II) Module ABI versions:
[ 19663.139]    X.Org ANSI C Emulation: 0.4
[ 19663.139]    X.Org Video Driver: 24.0
[ 19663.139]    X.Org XInput driver : 24.1
[ 19663.139]    X.Org Server Extension : 10.0
[ 19663.141] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_384
[ 19663.143] (II) xfree86: Adding drm device (/dev/dri/card0)
[ 19663.143] (EE) systemd-logind: failed to take device /dev/dri/card0: Operation not permitted
[ 19663.148] (--) PCI:*(0@0:2:0) 8086:2e12:103c:3048 rev 3, Mem @ 0xf0000000/4194304, 0xe0000000/268435456, I/O @ 0x00001230/8, BIOS @ 0x????????/131072
[ 19663.148] (--) PCI: (0@0:2:1) 8086:2e13:103c:3048 rev 3, Mem @ 0xf0400000/1048576
[ 19663.148] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[ 19663.148] (II) LoadModule: "glx"
[ 19663.149] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 19663.205] (II) Module glx: vendor="X.Org Foundation"
[ 19663.205]    compiled for 1.20.5, module version = 1.0.0
[ 19663.205]    ABI class: X.Org Server Extension, version 10.0
[ 19663.205] (==) Matched intel as autoconfigured driver 0
[ 19663.205] (==) Matched modesetting as autoconfigured driver 1
[ 19663.205] (==) Matched fbdev as autoconfigured driver 2
[ 19663.205] (==) Matched vesa as autoconfigured driver 3
[ 19663.205] (==) Assigned the driver to the xf86ConfigLayout
[ 19663.205] (II) LoadModule: "intel"
[ 19663.205] (WW) Warning, couldn't open module intel
[ 19663.206] (EE) Failed to load module "intel" (module does not exist, 0)
[ 19663.206] (II) LoadModule: "modesetting"
[ 19663.206] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[ 19663.223] (II) Module modesetting: vendor="X.Org Foundation"
[ 19663.223]    compiled for 1.20.5, module version = 1.20.5
[ 19663.223]    Module class: X.Org Video Driver
[ 19663.223]    ABI class: X.Org Video Driver, version 24.0
[ 19663.223] (II) LoadModule: "fbdev"
[ 19663.223] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[ 19663.223] (II) Module fbdev: vendor="X.Org Foundation"
[ 19663.223]    compiled for 1.20.0, module version = 0.5.0
[ 19663.223]    Module class: X.Org Video Driver
[ 19663.223]    ABI class: X.Org Video Driver, version 24.0
[ 19663.223] (II) LoadModule: "vesa"
[ 19663.223] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[ 19663.223] (II) Module vesa: vendor="X.Org Foundation"
[ 19663.223]    compiled for 1.20.0, module version = 2.4.0
[ 19663.223]    Module class: X.Org Video Driver
[ 19663.223]    ABI class: X.Org Video Driver, version 24.0
[ 19663.223] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[ 19663.223] (II) FBDEV: driver for framebuffer: fbdev
[ 19663.223] (II) VESA: driver for VESA chipsets: vesa
[ 19663.224] (EE)
Fatal server error:
[ 19663.224] (EE) parse_vt_settings: Cannot open /dev/tty0 (No such file or directory)
[ 19663.224] (EE)
[ 19663.224] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[ 19663.224] (EE) Please also check the log file at ".xorgxrdp.10.log" for additional information.
[ 19663.224] (EE)
[ 19663.224] (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
[ 19663.224] (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
[ 19663.224] (EE) Server terminated with error (1). Closing log file.

Wäre nett, wenn mir jemand weiterhelfen könnte!

Danke!

LG
Werner

Offline

#2 19.11.2019 00:33:47

w_m
Mitglied

Re: systemd-nspawn xrdp

Hallo!

mit xrdp-git funktioniert es...

Danke!

LG
Werner

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums