Du bist nicht angemeldet.

#1 17.11.2018 20:21:18

waldbaer59
Mitglied

[gelöst] Fotobuchsoftware Designer 3 : will ältere Version von SSL

Hallo zusammen,

die von fotobuch.de herunterladbare Linux-Version der Designer 3 Software funktioniert zunächst augenscheinlich ganz gut. Es kann aber keine Verbindung zu deren Server hergestellt werden. Startet man das Programm von der Kommandozeile aus, so erhält man eine Menge an Meldungen, die letztlich auf Folgendes hinauslaufen:

Warning: Incompatible version of OpenSSL

Das liegt - wie ich erfahren habe - daran, dass das Programm eine openssl Version binärkompatibel zu 1.0.2 erwartet und die bei mir Installierte 1.1.1 ist. Ein Downgrade verbietet sich für mich (selbst wenn es 'isoliert' machbar wäre, also keinen Rattenschwanz an zusätzlichen Aktionen nach sich ziehen würde).

Hatte jemand schon einmal das Problem, eine bestimmte (ältere) Library Version für ein Programm zu brauchen 'irgendwie' gelöst? Manchmal wünsch(t)e ich, dass solche nur ab und zu genutzte Software in einer statisch gelinkten Version verfügbar wäre. Das ist hier nicht der Fall und wohl auch nicht zu erwarten.

Für eine Idee bin ich dankbar. Zur Not muss ich vorübergehend eine VirtualBox hochfahren und die Übertragung auf diesem Weg machen ... allerdings natürlich sehr ungern.

VLG
Stephan

Beitrag geändert von waldbaer59 (04.11.2019 10:18:43)

Offline

#2 17.11.2018 22:20:41

chepaz
Mitglied

Re: [gelöst] Fotobuchsoftware Designer 3 : will ältere Version von SSL

Evtl. reicht es die passende .so in das Programmverzeichnis zu legen. IIRC verhält sich Linux da wie Windows mit DLLs. Einen Versuch ist es wert.

Oder mit

 ldd ./$program 

herausfinden was ihm fehlt.

Offline

#3 17.11.2018 23:18:39

niemand
Mitglied

Re: [gelöst] Fotobuchsoftware Designer 3 : will ältere Version von SSL

Du könntest die Sourcen laden und gucken, ob man es gegen die aktuelle Version gebaut bekommt.

Offline

#4 17.11.2018 23:44:26

stefanhusmann
Moderator

Re: [gelöst] Fotobuchsoftware Designer 3 : will ältere Version von SSL

openssl gibt es statisch gelinkt: im AUR

Offline

#5 18.11.2018 15:55:48

waldbaer59
Mitglied

Re: [gelöst] Fotobuchsoftware Designer 3 : will ältere Version von SSL

Vielen Dank für den Input. Ich schau mir eure Infos jetzt mal genauer an ...

VLG
Stephan

Offline

#6 04.11.2019 10:17:51

waldbaer59
Mitglied

Re: [gelöst] Fotobuchsoftware Designer 3 : will ältere Version von SSL

Nach einem Jahr wollte ich nun wenigstens noch mitteilen, dass ich das Problem 'quick & dirty' behoben habe. Zwar wissen auch die Entwickler der Software genau Bescheid, was das Problem ist (habe ich ihnen ausführlich mitgeteilt), aber um relativ flott arbeiten zu können habe ich mir die libssl_1.0 in der Version 1.0.2.g (neuere Versionen funktionieren nicht) aus einem Debian-Archiv gezogen und ins Designer3-Verzeichnis gestopft. Im Archiv von Arch Linux gibt es erst die Versionen von 'r' an.

Mir ist nicht wohl damit und ich werde die Nutzung auf das notwendige Minimum beschränken, aber manchmal gibt es solche Dinge. Da heißt es dann so zu verfahren oder zu verzichten.

VLG
Stephan

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums