Du bist nicht angemeldet.

#1 27.10.2019 15:31:02

dax67
Mitglied

Kann Abhängigkeiten nicht erfüllen

Hallo,

bei mir funktioniert das Update nicht mehr.

~]$ sudo pacman -Syu
[sudo] Passwort für fschedel:
:: Synchronisiere Paketdatenbanken...
core ist aktuell                                                       0,0   B  0,00B/s 00:00 [-------------------------------------------------------]   0%
extra ist aktuell                                                      0,0   B  0,00B/s 00:00 [-------------------------------------------------------]   0%
community ist aktuell                                                  0,0   B  0,00B/s 00:00 [-------------------------------------------------------]   0%
multilib ist aktuell                                                   0,0   B  0,00B/s 00:00 [-------------------------------------------------------]   0%
:: Starte vollständige Systemaktualisierung...
Warnung: gnome-shell-extension-dash-to-dock: Lokale Version (1:64-1) ist neuer als antergos (66-1)
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Installation vonpacman (5.2.0-2) verletzt Abhängigkeit 'pacman<5.2', benötigt von pamac

Wie kann ich das beheben?


Gruß Dax

Offline

#2 27.10.2019 16:32:47

skull-y
Mitglied

Re: Kann Abhängigkeiten nicht erfüllen

Archlinux verwenden und wenn du die Forensuxhe bemüht hättest, wärst darauf gestoßen, dass pamac mit der neuen Version von pacman nicht zurecht kommt.

Offline

#3 27.10.2019 17:00:00

matthias
Moderator

Re: Kann Abhängigkeiten nicht erfüllen

/etc/pacman.conf editieren, und alles auf die regulären Repos [core], [extra], [community] umstellen.
Antergos ist tot, du solltest aber mit bestehender Installation weiter arbeiten können. Und nimm Pacman statt pamac.

Offline

#4 27.10.2019 17:15:54

J4son
Mitglied

Re: Kann Abhängigkeiten nicht erfüllen

sudo pacman -Rns pamac

Und danach einfach mit pacman das System immer auf dem neusten Stand halten wink

Offline

#5 29.10.2019 01:24:11

dax67
Mitglied

Re: Kann Abhängigkeiten nicht erfüllen

Hallo,

vielen Dank für eure Hilfe, es funktioniert wieder.

Wie findet man heraus welche Pakete vom Antergos Repro noch vorhanden sind
und wie wird man die los?

Findet man mit

sudo pacman -Qs antergos

alle Pakete oder nur die mit antergos im Namen?

Gruß DAX

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums