Du bist nicht angemeldet.

#1 21.10.2019 21:59:34

zorrolo
Gast

keine WLAN-Verbindung nach Neuinstallation

Hallo zusammen,
ich habe entschieden nach 5 Jahren Ubuntu auf Arch umzusteigen. Habe mich jetzt eine Woche lang mehrfach an einer Installation nach "Anleitung für Einsteiger" versucht, aber bei Punkt 2.11 "Netzwerk erneut herstellen" komm ich einfach nicht weiter.

Ich versuche Arch Linux auf einem Laptop zu installieren, der auch durchaus mobil eingesetzt werden soll und daher verbinde ich ihn während der Installation mittels

wifi-menu

mit meinem WLAN. Wie in der o.g. Installationsanleitung habe ich natürlich schon vom ersten Versuch an

wpa_supplicant netctl dialog

durch

pacstrap

installiert, aber was in der Anleitung nicht steht, ist, dass man zusätzlich sämtliche Firmware für Geräte, die während der live-session bereits automatisch laufen, auch mittels

pacstrap

installieren muss, ansonsten wurde mein Wireless-Gerät nicht gefunden. Also habe ich von dem Moment an, wo ich es bemerkt habe auch immer

linux-firmware

mitinstalliert, wodurch immerhin das Wireless-Gerät gefunden wurde. Außerdem habe ich noch

dhcpcd

mitinstalliert, weil der Laptop Zuhause am Schreibtisch durchaus auch mit LAN-Kabel versorgt werden soll.

Jetzt hänge ich also nach dem reboot mitten in der Installation und kann nicht weiter fortfahren, weil ich keine Verbindung hergestellt bekomme. Mit dem Befehl

wifi-menu

bekomme ich sogar noch alle verfügbaren Dratlosnetzwerke angezeigt, wähle ich jedoch eines aus, bekomme ich folgende Meldung:

You are in emergency mode. After loging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or "exit"
to boot in default mode.
Administrationspasswort für Wartungszwecke eingeben
(oder drücken Sie Strg+D, um fortzufahren):

Nach Eingabe des Passworts, geschieht nichts. Mit

ping -c3 www.archlinux.de

kann ich keine Verbindung feststellen.

netctl start wlp5s0-mein_WLAN

produziert die selbe Ausgabe.

netctl status wlp5s0-mein_WLAN

sorgt für folgende Ausgabe:

? netctl@wlp5s0-mein_WLAN.service – Networking for netctl profile wlp5s0-mein_WLAN
    Loaded: loaded (/usr/lib/systemd/system/netctl@.service; vendor preset: disabled)
    Active: inactive (dead)
        Docs: man:netctl.profile(5)

Was in der Anleitung unter Punkt 2.11 als Anmerkung steht habe ich ebenfalls bereits erfolglos versucht.

Kann es sein, dass mir noch weitere Pakete fehlen, die ich beim

pacstrap

noch mitinstallieren muss? Falls ja, welche sind das?

Ich hatte zwischendurch auch mal versucht

mkinitcpio -p linux

erneut ausführen, weil ich dachte, dass womöglich erst nach diesem Befehl alle Module vollständig geladen werden, aber da bekomme ich auch die Fehlermeldung, dass das Kommando nicht gefunden wurde, also nehme ich an, dass mir da auf jeden Fall etwas fehlt, ohne dass ich beim nächsten Kernel-update nicht mehr richtig booten kann. Ist das bei Arch normal, dass Grundlegende Komponenten, ohne die das System nicht läuft, wie z.B. der Kernel selbst nicht zur Basisinstallation gehören? Auf was muss ich mich denn noch alles gefasst machen?

Ich brauche langsam wirklich ein funktionierendes Gerät und es wäre sehr schade, wenn ich wegen solcherlei Startschwierigkeiten das Projekt "Arch Linux" schon beerdigen muss, bevor es überhaupt richtig gestartet ist.

Kann mir bitte jemand helfen?

#2 22.10.2019 09:39:19

schard
Moderator

Re: keine WLAN-Verbindung nach Neuinstallation

zorrolo schrieb:

Ich versuche Arch Linux auf einem Laptop zu installieren, der auch durchaus mobil eingesetzt werden soll und daher verbinde ich ihn während der Installation mittels

wifi-menu

mit meinem WLAN. Wie in der o.g. Installationsanleitung habe ich natürlich schon vom ersten Versuch an

wpa_supplicant netctl dialog

durch

pacstrap

installiert, aber was in der Anleitung nicht steht, ist, dass man zusätzlich sämtliche Firmware für Geräte, die während der live-session bereits automatisch laufen, auch mittels

pacstrap

installieren muss, ansonsten wurde mein Wireless-Gerät nicht gefunden. Also habe ich von dem Moment an, wo ich es bemerkt habe auch immer

linux-firmware

mitinstalliert, wodurch immerhin das Wireless-Gerät gefunden wurde.

Du bist herzlich eingeladen, im Wiki etwaige Fehler zu korrigieren oder fehlende Informationen zu ergänzen.

zorrolo schrieb:

Mit dem Befehl

wifi-menu

bekomme ich sogar noch alle verfügbaren Dratlosnetzwerke angezeigt, wähle ich jedoch eines aus, bekomme ich folgende Meldung:

You are in emergency mode. After loging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or "exit"
to boot in default mode.
Administrationspasswort für Wartungszwecke eingeben
(oder drücken Sie Strg+D, um fortzufahren):

Das kann ich mir so nicht vorstellen.
Dies würde bedeuten, dass wifi-menu das Runlevel / systemd.target wechselt, was es definitv nicht tut.
Wahrscheinlicher ist, dass diese Meldung nach dem Booten in das installierte System kommt, was auf einen fehlerhaft konfigurierten Bootloader oder ein fehlerhaft konfiguriertes initramfs hindeutet.

zorrolo schrieb:

Nach Eingabe des Passworts, geschieht nichts. Mit

ping -c3 www.archlinux.de

kann ich keine Verbindung feststellen.

Wie kannst du denn ping ausführen, wenn du dich nicht ein Mal anmelden kannst?
Du solltest nach der Eingabe des root-Passworts in einer Shell landen (busybox, sh, bash o.ä.).
Im "emergency mode" stehen dir auch standardmäßig keine Netzwerkverbindungen bereit.
Die gibt es i.d.R. erst ab network.target bzw. multi-user.target.

zorrolo schrieb:
netctl start wlp5s0-mein_WLAN

produziert die selbe Ausgabe.

netctl status wlp5s0-mein_WLAN

sorgt für folgende Ausgabe:

? netctl@wlp5s0-mein_WLAN.service – Networking for netctl profile wlp5s0-mein_WLAN
    Loaded: loaded (/usr/lib/systemd/system/netctl@.service; vendor preset: disabled)
    Active: inactive (dead)
    Docs: man:netctl.profile(5)

Wir kennen deine netctl Konfiguration nicht. Um diesbezüglich Aussagen treffen zu können, müsstest du diese bereitstellen.

zorrolo schrieb:

Kann es sein, dass mir noch weitere Pakete fehlen, die ich beim

pacstrap

noch mitinstallieren muss? Falls ja, welche sind das?

Nein. pacstrap ist zur einmaligen Grundinstallation des Basis-Systems gedacht. Alles weitere sollte mittels pacman installiert werden.

zorrolo schrieb:

Ich hatte zwischendurch auch mal versucht

mkinitcpio -p linux

erneut ausführen, weil ich dachte, dass womöglich erst nach diesem Befehl alle Module vollständig geladen werden, aber da bekomme ich auch die Fehlermeldung, dass das Kommando nicht gefunden wurde, also nehme ich an, dass mir da auf jeden Fall etwas fehlt, ohne dass ich beim nächsten Kernel-update nicht mehr richtig booten kann.

mkinitcpio wird als Abhängigkeit der jeweiligen Kernel installiert. Das Nichtvorhandensein von mkinitcpio deutet darauf hin, dass du keinen Kernel installiert hast.
Dies würde auch erklären, warum Grub dich in den Emergency Modus droppt.

zorrolo schrieb:

Ist das bei Arch normal, dass Grundlegende Komponenten, ohne die das System nicht läuft, wie z.B. der Kernel selbst nicht zur Basisinstallation gehören?

Ja! Denn Arch ist nicht nur für den Betrieb auf Hardware ausgelegt. In meinem systemd-nspawn Container zum Paketbau benötige ich keinen Kernel.
Des Weiteren bist du hier womöglich in die Falle der Maintainer getappt, welche vor kurzem die base Gruppe durch das Gleichnamige Paket ersetzt haben.
Deswegen ist es auch wichtig, die News hier (oder auf der originalen englischen Seite) zu verfolgen.

zorrolo schrieb:

Auf was muss ich mich denn noch alles gefasst machen?

Mit ausreichend Ignoranz auf vieles.

zorrolo schrieb:

Ich brauche langsam wirklich ein funktionierendes Gerät und es wäre sehr schade, wenn ich wegen solcherlei Startschwierigkeiten das Projekt "Arch Linux" schon beerdigen muss, bevor es überhaupt richtig gestartet ist.

Tja, die Lernkurve von Arch ist flach und mit viel Frust verbunden. Da musste jeder hier irgendwann ein Mal durch. Das dadurch angeeignete Wissen ist es aber allemal Wert, auch im Berufsalltag.

zorrolo schrieb:

Kann mir bitte jemand helfen?

S.o.

Abschließend noch eine kleine Anmerkung. Bitte Poste mehrzeilige, zusammenhängende Konsolenein- / ausgaben in einem Code-Block.
Das Aufteilen in mehrere erhöht doch ziemlich den Leseaufwand.

Offline

#3 22.10.2019 21:44:16

zorrolo
Gast

Re: keine WLAN-Verbindung nach Neuinstallation

schard schrieb:

Das kann ich mir so nicht vorstellen.
Dies würde bedeuten, dass wifi-menu das Runlevel / systemd.target wechselt, was es definitv nicht tut.
Wahrscheinlicher ist, dass diese Meldung nach dem Booten in das installierte System kommt, was auf einen fehlerhaft konfigurierten Bootloader oder ein fehlerhaft konfiguriertes initramfs hindeutet.

Eine Ergänzung: auf dem Gerät wird eine Dualboot-Konfiguration mit Windows 10 verwendet und GRUB als bootloader.
Es folgen die von der Instalationsanleitung abweichenden Schritte, mit denen ich die Dualboot-Konfiguration aufgesetzt und GRUB installiert habe.
Nach dem Anlegen der Partitionen für Arch und Swap, mounte ich die Partition für Arch mit

mount -L Arch /mnt

Dann erstelle ich das Verzeichnis...

mkdir -p /mnt/boot

... in welches ich die von Windows angelegte EFI-Partition mounte mit

mount /dev/nvme0n1p2 /mnt/boot

Ab da folge ich wieder der Anleitung, bis zu dem Befehl

mkinitcpio -p linux

...und dem Erstellen eines PW mit

passwd

Dann nutze ich

pacman -S gptfdisk efibootmgr grub

, um die erforderlichen Programme zu installieren.

Ich mounte die EFI-Partition erneut, diesmal jedoch in das Verzeichnis

/boot

(Hinweis: ich bin mittlerweile mit "arch-chroot /mnt" unterwegs, gemäß der Anleitung!):

mount /dev/nvme0n1p2 /boot

Nun installiere ich GRUB mittels

grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=GRUB

(Vermutung: Ich kann mir das erneute mounten der EFI-Partition in "/boot" sparen, weil ich mittlerweile ja sowieso als "arch-chroot /mnt" im System bin, RICHTIG??
Oder sollte ich stattdessen zwar wie zuvor beschrieben mounten, jedoch beim Intallieren von GRUB "--efi-directory=" auf "/mnt/boot" setzten??)

Ich installiere

pacman -S os-prober

...dann erstelle ich ein Verzeichnis...

mkdir /mnt/Win10

...in welches ich die Windows-System-Partition einhänge mit

mount /dev/nvme0n1p4 /mnt/Win10

Abschließend erzeuge ich noch die GRUB-Konfigurationsdatei mittels

grub-mkconfig -o /boot/grub/grub.cfg

Sollte ich dabei schon offensichtliche Fehler begangen haben, ist jeder herzlich dazu eingeladen, diese aufzudecken und zu erklären, wie man diese Fehler vermeidet.


schard schrieb:

Wie kannst du denn ping ausführen, wenn du dich nicht ein Mal anmelden kannst?

Naja, bevor ich "wifi-menu" ausführe, bin ich ja angemeldet. Nach Eingabe des Kommandos wird kurz nach Netzwerken gescannt, dann öffnet sich eine textbasierte Oberfläche mit allen verfügbaren Netzwerken und wenn ich dann mein Netzwerk auswähle, erscheint die o. g. Fehelermeldung und ich muss mich erneut anmelden.

schrad schrieb:

Wir kennen deine netctl Konfiguration nicht. Um diesbezüglich Aussagen treffen zu können, müsstest du diese bereitstellen.

Was genau meinst du mit Konfiguration? Das Profil "wlp5s0-mein_WLAN" wurde durch "wifi-menu" bereits zu dem Zeitpunkt erstellt, als ich noch mit dem live-System als root unterwegs war und bevor ich das Grundsystem installiert habe. Zu diesem Zeitpunkt war auch eine Wireless-Verbindung problemlos möglich. Das Profil wurde nicht verändert.

schard schrieb:

Ja! Denn Arch ist nicht nur für den Betrieb auf Hardware ausgelegt. In meinem systemd-nspawn Container zum Paketbau benötige ich keinen Kernel.
Des Weiteren bist du hier womöglich in die Falle der Maintainer getappt, welche vor kurzem die base Gruppe durch das Gleichnamige Paket ersetzt haben.
Deswegen ist es auch wichtig, die News hier (oder auf der originalen englischen Seite) zu verfolgen.

Als Neuling bei Arch und ––offenbar–– zu schlechten englischen (Fach-)Sprachekenntnissen, erschließt sich mir nicht, was es für mich bedeutet, dass die Maintainer die base Gruppe durch das gleichnamige Paket ersetzt haben. Wie ich bereits schrieb, installiere ich beim pacstrap ja u.a. base und auch linux, wodurch ja ein Kernel installiert werden sollte.

schard schrieb:

Mit ausreichend Ignoranz auf vieles.

<- Vielen Dank für nichts sad
Da hatte ich mir eher hilfreiche Hinweise auf weitere Pakete erhofft, die ich für meinen Anwendungsfall auf jeden Fall benötigen werde, aber nicht in der Basis-Installation erhalten sind. Das würde mir weitere Stolpersteine aus dem Weg räumen, aber vielleicht ist es ja eher erwünscht, dass ich mich nun regelmäßig hier im Forum mit meinen Problemchen melde.

Sollte mir jemand ernsthaft helfen wollen, wäre ich sehr dankbar und würde mich auch gerne durch mitwirken an einer Anleitung zum erfolgreichen Einrichten eines Dualboot-Systems im Wiki revanchieren. Dazu muss ich es jedoch selbst erstmal hinkriegen.

#4 22.10.2019 23:00:30

TBone
Mitglied

Re: keine WLAN-Verbindung nach Neuinstallation

zorrolo schrieb:

Vielen Dank für nichts sad

Gerne, stets zu Diensten.

Offline

#5 22.10.2019 23:03:12

schard
Moderator

Re: keine WLAN-Verbindung nach Neuinstallation

Arch ist einer Benutzer-zentrale Distribution. Wir wissen nicht, was du damit machen möchtest, welche Vorlieben du hast und was deine Lieblingsfarbe und Automarke ist.
Daher kann dir hier keine sagen, welche Pakete du noch für deinen Anwendungsfall benötigst. Das weißt nur du.
Deine polemische Frage, auf was du dich noch gefasst machen musst zeugt von Ignoranz. Entweder hast du bei Problemen den Willen zur Selbsthilfe, oder stellst konkrete Fragen unter Bereitstellung nützlicher Informationen.
Ich habe bereits erläutert, dass das von dir in deinem ersten Post beschriebene Verhalten des Systems nicht möglich ist.
Du hast Abläufe verwechselt oder ausgelassen und scheinst das Live-System und das installierte System zu verwechseln.
Ebenso habe ich darauf hin gewiesen, dass du definitiv keinen Kernel installiert haben kannst, da ansonsten mkinitcpio zur Verfügung stünde.
Wenn du konkrete Fragen zu einem Problem hast, schildere sie hier gerne detailliert in einem neuen Thread.
Lies bitte vorher die Anleitung für Einsteiger sorgfältig erneut, wie auch meine obige Antwort.
Alles Gute!

Offline

Fußzeile des Forums