Du bist nicht angemeldet.

#1 28.09.2019 12:41:19

Gerald D.
Mitglied

Resolve 16 startet nicht

Hallo,

Mein Rechner:

System:    Host: user-pc Kernel: 4.19.75-1-lts x86_64 bits: 64 Desktop: Xfce 4.14.1
Machine:   Type: Desktop Mobo: ASRock model: Z97 Extreme4 serial: <root required> UEFI [Legacy]: American Megatrends 
           v: P2.60 date: 03/06/2018 
CPU:       Topology: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP L2 cache: 8192 KiB 
           Speed: 4035 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 4035 2: 4100 3: 3801 4: 4128 5: 4251 6: 3905 
           7: 4142 8: 3557 
Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics driver: i915 v: kernel 
           Device-2: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 435.21 
           Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits) v: 3.3 Mesa 19.1.7 

Mit pacman habe ich "davinci-resolve" installiert.
Beim Startversuch erscheint:

$ /opt/resolve/bin/resolve
ActCCMessage Already in Table: Code= c005, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c006, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c007, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= 2282, Mode=  0, Level=  0, CmdKey= 8, Option= 0
PnlMsgActionStringAdapter Already in Table: Code= 615e, Mode=  0, Level=  0, CmdKey= -1, Option= 0
log4cxx: No appender could be found for logger (BtCommon).
log4cxx: Please initialize the log4cxx system properly.
16.0 (#060) Linux/Clang
Main thread starts: 8D130B80
[0x7f6e8d130b80] | Undefined            | INFO  | 2019-09-28 12:38:34,774 | --------------------------------------------------------------------------------
[0x7f6e8d130b80] | Undefined            | INFO  | 2019-09-28 12:38:34,774 | Loaded log config from /home/user/.local/share/DaVinciResolve/configs/log-conf.xml
[0x7f6e8d130b80] | Undefined            | INFO  | 2019-09-28 12:38:34,774 | --------------------------------------------------------------------------------

Das war's ... und nichts tut sich.

Kann mir jemand helfen ?

MfG Gerald

Beitrag geändert von Gerald D. (28.09.2019 12:42:08)

Offline

#2 28.09.2019 12:53:55

niemand
Mitglied

Re: Resolve 16 startet nicht

Kann mir jemand helfen?¹

Am ehesten der Support – ist kommerzielle, geschlossene Software.



¹ Autodeplenk ausgelöst

Offline

#3 29.09.2019 11:18:35

ggrub
Mitglied

Re: Resolve 16 startet nicht

Es gibt keinen Resolve-Support für Arch.

Offline

#4 29.09.2019 11:48:38

Henrikx
Mitglied

Re: Resolve 16 startet nicht

Du könntest schauen ob a) alle Abhängigkeiten erfüllt sind,
https://aur.archlinux.org/packages/davinci-resolve/

und b) das PKBUILD durchgehen, ob du einen Fehler entdeckst.
https://aur.archlinux.org/cgit/aur.git/ … ci-resolve

Offline

#5 29.09.2019 12:13:26

chepaz
Mitglied

Re: Resolve 16 startet nicht

Nur vom Querlesen supporten die nur Centos 7 und, auf den ersten Blick, auch immer nur spezielle Versionen der Grafiktreiber (macht ja auch Sinn bei kommerzieller Software die schon recht spezifisch ist).

tl;dr: Have fun wink


Edit:
Spasshalber mal den Installer heruntergeladen und alles von Hand entpackt - das resolve-binary macht einfach einen Coredump. Sieht dann so aus:

..0_Linux/DaVinci_Resolve_16.0_Linux/bin .:] ./resolve --help
ActCCMessage Already in Table: Code= c005, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c006, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c007, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= 2282, Mode=  0, Level=  0, CmdKey= 8, Option= 0
PnlMsgActionStringAdapter Already in Table: Code= 615e, Mode=  0, Level=  0, CmdKey= -1, Option= 0
log4cxx: No appender could be found for logger (BtCommon).
log4cxx: Please initialize the log4cxx system properly.
16.0 (#060) Linux/Clang
Main thread starts: 0FFB0B80
resolve: AppConfig.cpp:178: void AppConfig::LoadAllSiteInfo(): Zusicherung »m_SiteEnabledIdx > 0« nicht erfüllt.


==========[CRASH DUMP]==========
Please send this to support:

#TIME Sun Sep 29 12:20:47 2019 - Uptime 00:00:00 (hh:mm:ss)
#PROGRAM_NAME DaVinci Resolve v16.0.0.060 (Linux/Clang)

./resolve() [0x509f8b9]
./resolve() [0x1dd64c3]
/usr/lib/libpthread.so.0(+0x13d00) [0x7f5215162d00]
/usr/lib/libc.so.6(gsignal+0x145) [0x7f5213440755]
/usr/lib/libc.so.6(abort+0x125) [0x7f521342b851]
/usr/lib/libc.so.6(+0x25727) [0x7f521342b727]
/usr/lib/libc.so.6(+0x33026) [0x7f5213439026]
./resolve() [0x1dc2820]
./resolve() [0x1dc0e72]
./resolve() [0x1dc0718]
./resolve() [0x28aa3d0]
./resolve() [0x22d53f9]
./resolve() [0x22d52fe]
./resolve() [0x1dd4ce5]
./resolve() [0x1dbc2ff]
/usr/lib/libc.so.6(__libc_start_main+0xf3) [0x7f521342cee3]
./resolve() [0x1dbb10d]
Signal Number = 6

================================
resolve: AppConfig.cpp:178: void AppConfig::LoadAllSiteInfo(): Zusicherung »m_SiteEnabledIdx > 0« nicht erfüllt.


==========[CRASH DUMP]==========
Please send this to support:

#TIME Sun Sep 29 12:20:47 2019 - Uptime 00:00:00 (hh:mm:ss)
#PROGRAM_NAME DaVinci Resolve v16.0.0.060 (Linux/Clang)

./resolve() [0x509f8b9]
./resolve() [0x1dd64c3]
/usr/lib/libpthread.so.0(+0x13d00) [0x7f5215162d00]
/usr/lib/libc.so.6(gsignal+0x145) [0x7f5213440755]
/usr/lib/libc.so.6(abort+0x125) [0x7f521342b851]
/usr/lib/libc.so.6(+0x25727) [0x7f521342b727]
/usr/lib/libc.so.6(+0x33026) [0x7f5213439026]
./resolve() [0x1dc2820]
./resolve() [0x1dc0e72]
./resolve() [0x1dc0718]
./resolve() [0x1df7ace]
./resolve() [0x1dd670e]
/usr/lib/libpthread.so.0(+0x13d00) [0x7f5215162d00]
/usr/lib/libc.so.6(gsignal+0x145) [0x7f5213440755]
/usr/lib/libc.so.6(abort+0x125) [0x7f521342b851]
/usr/lib/libc.so.6(+0x25727) [0x7f521342b727]
/usr/lib/libc.so.6(+0x33026) [0x7f5213439026]
./resolve() [0x1dc2820]
./resolve() [0x1dc0e72]
./resolve() [0x1dc0718]
./resolve() [0x28aa3d0]
./resolve() [0x22d53f9]
./resolve() [0x22d52fe]
./resolve() [0x1dd4ce5]
./resolve() [0x1dbc2ff]
/usr/lib/libc.so.6(__libc_start_main+0xf3) [0x7f521342cee3]
./resolve() [0x1dbb10d]
Signal Number = 6

================================

Das wäre für mich der Punkt wo ich schon aufhören würde das unter Arch betreiben zu wollen, es sei denn mein Chef zwingt mich wink

Edit #2:
Das Klickibunti-Intro läuft noch durch und fragt ein paar Details ab. Mahnt aber auch meine Grafikkarte an.

Beitrag geändert von chepaz (29.09.2019 12:26:53)

Offline

#6 29.09.2019 12:55:32

ggrub
Mitglied

Re: Resolve 16 startet nicht

Das Nach-Hause-Telefonieren kann man doch sicher blocken.

Ich verwende "Resolve 16 Studio", da gibt es kein log4cxx. Testweise habe ich mal "Resolve 16" auf meinem Zweitrechner installiert. Da erscheint beim Start die exakt gleiche log4cxx Meldung.

Wer also das Risiko mit log4cxx eingehen möchte, muss jeder selber entscheiden. Trotzdem stellt auch mir die Frage, wie man das nun handhaben muss, damit Resolve 16 startet unter Arch. Kann doch wohl nicht sein das alle arch-user in die Röhre schauen müssen.

Offline

#7 29.09.2019 14:03:44

Dirk
Moderator

Re: Resolve 16 startet nicht

ggrub schrieb:

Kann doch wohl nicht sein das alle arch-user in die Röhre schauen müssen.

Bei proprietärer Closed-Source-Software ist das leider so, dass man 100% auf den Hersteller angewiesen ist. Da gibt es nichts, aber auch gar nichts, was die Community dafür oder dagegen tun kann.

Offline

#8 29.09.2019 14:55:28

ggrub
Mitglied

Re: Resolve 16 startet nicht

Resolve 16 /Studio ist im AUR zu finden. "Resolve 16 Studio" (Kaufversion) läuft hier unter Arch tadelos. Nur "Resolve 16 Freeware" funktioniert nicht. Und das nur wegen "log4cxx: Please initialize the log4cxx system properly".

Wie also muss dieses Logging (log4cxx:) unter Arch installiert/aktiviert werden, damit jeder Arch-User wenigstens mal Resolve testen kann ? Das muss doch möglich sein.

Offline

#9 29.09.2019 15:06:50

niemand
Mitglied

Re: Resolve 16 startet nicht

Ich sehe zumindest in den hier geposteten Ausgaben keinen Hinweis darauf, dass das Problem mit log4cxx für das Nichtstarten verantwortlich wäre. Für mich sieht das eher wie ein nebenläufiger Fehler aus.

Wenn man aber unbedingt seine Zeit darin versenken mag, den Job des Herstellers zu machen, obwohl der festgelegt hat, dass keiner außer ihm den machen soll (anderenfalls würde er ja den Code zur Verfügung stellen), könnte man zunächst mal mit ›strace‹ und Freunden schauen, was da wie läuft und wo es hängen mag.

Offline

#10 30.09.2019 07:55:46

Dirk
Moderator

Re: Resolve 16 startet nicht

ggrub schrieb:

Resolve 16 /Studio ist im AUR zu finden

... und das ändert was genau an der Tatsache, dass es sich dabei um proprietäre Closed-Source-Software handelt, die von niemandem außer dem Anbieter vernünftig supportet werden kann?

ggrub schrieb:

Das muss doch möglich sein.

Wir drehen uns im Kreis. Frag den Anbieter der Software, es kann dir keiner helfen, da keiner weiß was das Programm macht, da es eben Closed-Source ist.

Offline

#11 30.09.2019 19:53:17

ggrub
Mitglied

Re: Resolve 16 startet nicht

Ich gehe mittlerweile auch davon aus das dieses Problem nicht mit log4cxx zu tun hat. Ich hab jetzt mal Resolve auf einem Linux-Mint Rechner installiert ... funktioniert problemlos.
Aber was juckt mich das hier überhaupt. Die Studioversion läuft ja bei mir.

@Gerald: Es gibt ein deutschsprachiges Resolveforum. Schau doch mal da vorbei.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums