Du bist nicht angemeldet.

#1 20.09.2019 16:47:59

hellmi666
Mitglied

Drucker Brother DCP-135C einrichten

Hallo Leute,

mein Linux ist perfekt eingerichtet, auch der Drucker druckt. Trotzdem besteht noch ein klitzekleine Problem.
Ich habe ein Skript geschrieben, in dem am Ende eine Textdatei geschrieben wird. Diese Datei drucke ich immer aus. Da aber mit der Zeit die Faulheit siegt, dachte ich mir, ich füge einen Druckbefehl in das Skript ein. Nämlich:

lpr /Pfad/zur/Textdatei

Prinzipiell funktioniert das auch, aber es druckt nicht in A4 sondern in Letter.
Ich habe auch

 lpr -o media=a4 /Pfad/zur/Textdatei

probiert, aber es druckt genauso wie oben.

Nun die Frage: Wie teile ich lpr mit, dass es A4 drucken soll?
Oder gibt es einen besseren Befehl für mein Skript?

Grüße Hellmi

Beitrag geändert von hellmi666 (20.09.2019 17:50:27)

Offline

#2 20.09.2019 16:54:08

schard
Moderator

Re: Drucker Brother DCP-135C einrichten

Versuche Mal A4 statt a4.

Offline

#3 20.09.2019 17:00:47

hellmi666
Mitglied

Re: Drucker Brother DCP-135C einrichten

Ich hatte es klein geschrieben, da es in der Manpage so steht. Aber leider geht es auch mit einem großen A nicht.
Und wenn, dann hätte ich mich aber richtig geärgert, dass ich da nicht selber drauf gekommen bin.

Offline

#4 20.09.2019 18:53:28

TBone
Mitglied

Re: Drucker Brother DCP-135C einrichten

Versuche Mal A4 statt a4.

Offline

#5 20.09.2019 20:07:14

danbruegge
Mitglied

Re: Drucker Brother DCP-135C einrichten

Kleine Offtopic frage, wie hast du deinen Drucker eingerichtet? Meiner druckte bis vor kurzem ganz normal und hat dann aufgehört. Nun kann ich nicht mal mehr in cups hinzufügen.

Offline

#6 13.10.2019 15:35:51

hellmi666
Mitglied

Re: Drucker Brother DCP-135C einrichten

danbruegge schrieb:

Kleine Offtopic frage, wie hast du deinen Drucker eingerichtet? Meiner druckte bis vor kurzem ganz normal und hat dann aufgehört. Nun kann ich nicht mal mehr in cups hinzufügen.

Ich habe die Datei "brother-dcp135c" aus dem AUR installiert. Und natürlich Cups.

Ich habe auch A4 statt a4 probiert, trotzdem druckt er im letter-Stil.
Hat noch jemand eine Idee, wie ich dieses Problem lösen kann?

Offline

#7 13.10.2019 20:37:55

sanni
Mitglied

Re: Drucker Brother DCP-135C einrichten

Mit der Option '-o' wird dem Drucker die nachfolgende Option zugeschickt (laut man-page).
'media=*' ist vielleicht nicht die richtige Option für deinen Drucker.
Schonmal 'papersize' oder was anderes ausprobiert?

Offline

#8 14.10.2019 08:27:59

danbruegge
Mitglied

Re: Drucker Brother DCP-135C einrichten

hellmi666 schrieb:

Ich habe die Datei "brother-dcp135c" aus dem AUR installiert. Und natürlich Cups.

Es gab wohl ein update beim Paket, nun geht es bei mir auch wieder.

Offline

#9 14.10.2019 17:09:48

hellmi666
Mitglied

Re: Drucker Brother DCP-135C einrichten

sanni schrieb:

'media=*' ist vielleicht nicht die richtige Option für deinen Drucker.

In der Manpage steht

-o media=size
            Sets  the  page  size  to size. Most printers support at least the
            size names "a4", "letter", and "legal".
sanni schrieb:

'Schonmal 'papersize' oder was anderes ausprobiert?

Bringt das selbe Ergebnis.

Offline

#10 15.10.2019 09:33:51

Greg
Mitglied

Re: Drucker Brother DCP-135C einrichten

Versuch mal folgendes aus der Konsole:

lpr -P deinDruckername -o media=A4 Dateiname

oder falls du nur einen Drucker hast:

lpr -o media=A4 Dateiname

Da sollte es dann Rückmeldungen geben, warum A4 nicht klappt.
Mit pdfs klappt das gut.

lpr -o media=A4 einepdfdatei.pdf

Beitrag geändert von Greg (15.10.2019 09:39:10)

Offline

#11 18.10.2019 16:49:31

hellmi666
Mitglied

Re: Drucker Brother DCP-135C einrichten

Greg schrieb:

Versuch mal folgendes aus der Konsole:
oder falls du nur einen Drucker hast:

lpr -o media=A4 Dateiname

Da sollte es dann Rückmeldungen geben, warum A4 nicht klappt.

Es druckt immer noch in Letter, aber wie immer ohne Fehlermeldung.
Was auch nicht unerwähnt bleiben sollte. Wenn ich eine Textdatei normal drucke, dann in der Schriftgröße, welche im Texteditor eingestellt ist, in meinem Fall 10. Drucke ich aus dem Terminal oder einem Skript die selbe Datei, dann druckt es in einer etwas größeren Schrift, bestimmt 12 oder so.

Beitrag geändert von hellmi666 (18.10.2019 16:52:31)

Offline

#12 19.10.2019 00:52:16

k.osmoff
Gast

Re: Drucker Brother DCP-135C einrichten

Hattest Du diese Dateien bearbeitet?

wiki.ubuntuusers.de schrieb:

Wegen einer falschen Papiereinstellung bei einigen Treibern wird das amerikanische Letter-Format anstelle des DIN-A4-Formats benutzt. Um dieses zu korrigieren, öffnet man mit einem Editor mit Root-Rechten die Datei /usr/local/Brother/inf/br(model name)rc. Falls die vorgenannte Datei fehlt, ist /usr/Brother/Printer/modelname/inf/br(modelname)rc zu öffnen. …

wiki.ubuntuusers.de/Drucker/Brother/#Druckbild-verschoben

#13 19.10.2019 15:16:15

hellmi666
Mitglied

Re: Drucker Brother DCP-135C einrichten

k.osmoff schrieb:

Hattest Du diese Dateien bearbeitet?

wiki.ubuntuusers.de schrieb:

Wegen einer falschen Papiereinstellung bei einigen Treibern wird das amerikanische Letter-Format anstelle des DIN-A4-Formats benutzt. Um dieses zu korrigieren, öffnet man mit einem Editor mit Root-Rechten die Datei /usr/local/Brother/inf/br(model name)rc. Falls die vorgenannte Datei fehlt, ist /usr/Brother/Printer/modelname/inf/br(modelname)rc zu öffnen. …

wiki.ubuntuusers.de/Drucker/Brother/#Druckbild-verschoben

Bei mir liegt die Datei unter /usr/share/brother/Printer/dcp135c/inf/brdcp135crc. Dort hatte ich bereits den Papiertyp auf A4 gestellt.
Ich habe auch mit der ImageableArea A4/A4: herumexperimentiert, auch in beiden Cups-Dateien. Alles ohne Erfolg.
Damit ich aus meinem Skript heraus vernünftig drucken kann, habe ich jetzt als Erstes oben eine Leerzeile eingefügt, bevor die Datei gefüllt wird. Das ist zwar Plan B, aber das Einzigste, was im Moment sicher funktioniert.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums