Du bist nicht angemeldet.

#1 15.08.2019 18:43:50

Werdck
Gast

Steam-compositor-plus Probleme

Hallo,

Ich will komplett auf Arch umsteigen, der Dualboot nervt nun doch irgendwann zu sehr.
Deshalb ziehe ich alles um, momentan Steam. Das ganze erzähle ich nur, damit ihr nen groben Hintergrund habt ^^

Im Wiki steht ja eine sehr detaillierte Anleitung zu Steam unter Arch.
Nachdem ich der allerdings gefolgt bin, startet SteamOS (bzw. der compositor) nicht vom Login aus.
Idealerweise sollte es unter Xephyr laufen können, wenn es überhaupt läuft, bin ich aber auch schon zufrieden.

Meine Versuche bis jetzt:
1. Vor dem Einloggen als WM "SteamOS" wählen -> Geht zwar, star6tet aber stattdessen (warum auch immer) i3 (meinen Standard-WM)
2. `steam -bigpicture` -> Geht zwar, nur funktionieren dann weder Tastatur noch Netzwerk in Steam
3. Parameterlos `steam` -> Klappt bestens, ist aber nicht mein Ziel

Für jegliche Hilfe bin ich sehr dankbar!
Werdck

#2 15.08.2019 20:18:44

Werdck
Gast

Re: Steam-compositor-plus Probleme

Update:
Ich habe das Ganze in einer KVM getestet, dort geht es, es existiert eine Datei /usr/share/xsessions/steam-bigpicture.desktop
in dieser wird im Exec `steam-de` aufgerufen. Diese Datei fehlt auf meinem Hostsystem komplett.

Auf das es weiterhelfe,
Werdck

#3 16.08.2019 13:11:35

Dirk
Moderator

Re: Steam-compositor-plus Probleme

Werdck schrieb:

... es existiert eine Datei /usr/share/xsessions/steam-bigpicture.desktop
in dieser wird im Exec `steam-de` aufgerufen. Diese Datei fehlt auf meinem Hostsystem komplett.

Dann leg die Datei doch mal an.

Offline

#4 16.08.2019 15:59:57

Werdck
Gast

Re: Steam-compositor-plus Probleme

Dirk schrieb:

Dann leg die Datei doch mal an.

Das habe ich jetzt getan, allerdings hilft es scheinbar nicht weiter.
Der Bildschirm bleibt diesmal bei Start der Session schwarz anstatt mich in meinen Standard-WM zu verweisen.

#5 16.08.2019 16:30:59

Werdck
Mitglied

Re: Steam-compositor-plus Probleme

Update:
Scheinbar hat sich auch dieser "Fortschritt" wieder verabschiedet.
Ich werde bei Login immer auf i3 umgeleitet.

Offline

#6 16.08.2019 19:02:54

Kabbone
Mitglied

Re: Steam-compositor-plus Probleme

am besten mal .bashrc, .bash_profile (bzw. die jeweilige Shell config) und .xinitrc prüfen was da drinsteht.

EDIT: Mir ist gerade aufgefallen, dass ich das gleiche Problem habe/hatte. Weil ich aber wusste, dass es bis vor kurzem auf diesem Rechner lief, ist mir aufgefallen, dass es an xfwm4 liegt. Downgrade auf 4.12.5-1 behebt das Problem

Beitrag geändert von Kabbone (16.08.2019 21:41:17)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums