#1 10.08.2019 00:33:09

sewulba
Mitglied

Error installing repo packages

Hallo.

Ich wollte ein Paket installieren und bekomme dann folgende Ausgabe angezeigt:

 libnsl-1.2.0-1-x86_64                                                                               59,3 MiB  9,12M/s 00:07 [###########################################################################]  99%
 vsftpd-3.0.3-6-x86_64                                                                               59,5 MiB  8,97M/s 00:07 [###########################################################################] 100%
(28/28) Prüfe Schlüssel im Schlüsselring                                                                                     [###########################################################################] 100%
(28/28) Überprüfe Paket-Integrität                                                                                           [###########################################################################] 100%
(28/28) Lade Paket-Dateien                                                                                                   [###########################################################################] 100%
(28/28) Prüfe auf Dateikonflikte                                                                                             [###########################################################################] 100%
Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
linux-api-headers: /usr/include/asm-generic/auxvec.h existiert im Dateisystem
linux-api-headers: /usr/include/asm-generic/bitsperlong.h existiert im Dateisystem
linux-api-headers: /usr/include/asm-generic/bpf_perf_event.h existiert im Dateisystem
linux-api-headers: /usr/include/asm-generic/errno-base.h existiert im Dateisystem
linux-api-headers: /usr/include/asm-generic/errno.h existiert im Dateisystem
linux-api-headers: /usr/include/asm-generic/fcntl.h existiert im Dateisystem
linux-api-headers: /usr/include/asm-generic/hugetlb_encode.h existiert im Dateisystem
.
.
.
pam: /usr/share/man/man8/pam_wheel.8.gz existiert im Dateisystem
pam: /usr/share/man/man8/pam_xauth.8.gz existiert im Dateisystem
pam: /usr/share/man/man8/unix_chkpwd.8.gz existiert im Dateisystem
pam: /usr/share/man/man8/unix_update.8.gz existiert im Dateisystem
libnsl: /usr/include/rpcsvc/nis.h existiert im Dateisystem
libnsl: /usr/include/rpcsvc/nis.x existiert im Dateisystem
libnsl: /usr/include/rpcsvc/nis_callback.h existiert im Dateisystem
libnsl: /usr/include/rpcsvc/nis_callback.x existiert im Dateisystem
libnsl: /usr/include/rpcsvc/nis_object.x existiert im Dateisystem
libnsl: /usr/include/rpcsvc/nis_tags.h existiert im Dateisystem
libnsl: /usr/include/rpcsvc/nislib.h existiert im Dateisystem
libnsl: /usr/include/rpcsvc/yp.h existiert im Dateisystem
libnsl: /usr/include/rpcsvc/yp.x existiert im Dateisystem
libnsl: /usr/include/rpcsvc/yp_prot.h existiert im Dateisystem
libnsl: /usr/include/rpcsvc/ypclnt.h existiert im Dateisystem
libnsl: /usr/include/rpcsvc/yppasswd.h existiert im Dateisystem
libnsl: /usr/include/rpcsvc/yppasswd.x existiert im Dateisystem
libnsl: /usr/include/rpcsvc/ypupd.h existiert im Dateisystem
libnsl: /usr/lib/libnsl.so existiert im Dateisystem
libnsl: /usr/lib/libnsl.so.2 existiert im Dateisystem
libnsl: /usr/lib/libnsl.so.2.0.0 existiert im Dateisystem
libnsl: /usr/lib/pkgconfig/libnsl.pc existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
Error installing repo packages

Egal, was ich installieren will, ich bekomme diesen Fehler.

Ich habe das Gefühl, dass mein Archlinux nicht mehr weiss, was alles installiert ist, oder so?!

Bin für jede Hilfe dankbar.

Gruss Sewulba

Beitrag geändert von sewulba (10.08.2019 00:43:46)

Offline

#2 10.08.2019 09:56:27

stefanhusmann
Moderator

Re: Error installing repo packages

Du hast Dateiein im Filesystem, die zu keinem Paket gehören, und pacman sagt dir dies. Soweit ist alles in der Ordnung.

Z.B.  /usr/include/asm-generic/auxvec.h sollte zu linux-headers gehören, tut es bei dir aber nicht. Ich vermute irgendein partielles Update oder eine übersehene frühere Fehlermeldung von pacman.

Reparieren würde ich es mittels pacman mit der --overwrite Option. Lies die Manpage von pacman und benutze die Suchfunktion dieses Forums. Dieserlei Problematik ist schon öfters aufgetreten.

Offline

#3 10.08.2019 13:37:11

sewulba
Mitglied

Re: Error installing repo packages

Irgendwie will das bei mir nicht funktionieren.
Ich habe folgendes probiert mit folgendem Ergebnis:

pacman -S $(pacman -Qq)
Fehler: Keine Ziel-Dateien spezifiziert (benutzen Sie -h für Hilfe)
pacman -S --overwrite $(pacman -Qqn)
pacman: Die Option »--overwrite« erfordert ein Argument

Beide Befehle gehen nicht. :-(

pacman -Q

Gibt gar nichts aus. :-(

Habe noch etwas festgestellt:

In /var/lib/pacman/local gibt es nur die Datei ALPM_DB_VERSION (size 2)

Gruss Sewulba

Beitrag geändert von sewulba (10.08.2019 14:31:44)

Offline

#4 10.08.2019 14:37:51

sewulba
Mitglied

Re: Error installing repo packages

Ich denke ich habe nun das gefunden, was mir helfen würde.

https://wiki.archlinux.org/index.php/Pa … l_database

Leider brauche ich dazu die pacutils, die nicht installiert sind. Eine Installation ist leider nicht mehr möglich.
Ich werde es wohl neu machen müssen, denke ich. :-(

Offline

#5 10.08.2019 15:55:13

stefanhusmann
Moderator

Re: Error installing repo packages

Das wäre vermutllich einfacher als alle Reperaturversuche, ja.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums