Du bist nicht angemeldet.

#1 06.08.2019 14:42:53

Schwertfisch
Mitglied

(Gnome) Systemeinstellungen starten nicht mehr

Hallo alle miteinander!

Ich habe ein kleines Problem: Die Gnome-Systemeinstellungen starten nicht mehr.
Ich habe den Verdacht, dass es eventuell damit zutun haben könnte, dass ich Pantheon installiert hatte. Ich meine, irgendwo gelesen zu haben, dass der settings manager für Pantheon gnome-control-centerals Basis nimmt. Jedenfalls habe ich mich eine Weile nicht weiter damit aufgehalten, da ich ohnehin Pantheon verwendet habe. Habe gestern wieder zu Gnome gewechselt und die Systemeinstellungen starten nicht mehr (grafisch).
Wenn ich versuche, gnome-control-center über das Terminal zu starten, erhalte ich folgendes:

gnome-control-center

(gnome-control-center:5093): GLib-GIO-ERROR **: 14:36:58.913: Settings schema 'org.gnome.desktop.privacy' does not contain a key named 'disable-camera'
Trace/Breakpoint ausgelöst (Speicherabzug geschrieben

Ein Berechtigungsproblem ist es nicht, ich erhalte allerdings interessanterweise eine andere Meldung, wenn ich das Ganze als sudoer starte:

sudo gnome-control-center
**
ERROR:../gnome-control-center/shell/cc-shell-model.c:458:cc_shell_model_set_panel_visibility: assertion failed: (valid)
Abgebrochen

Ich (als Laie) würde daher bei der ersten Fehlermeldung ansetzen... ich stelle mir jetzt vor, dass Pantheon evtl. einen Key hinzugefügt hat, den gnome nicht kennt und dass sich gnome daran jetzt aufhängt. Könnte das sein?
Ich habe bereits versucht, org.gnome.desktop.privacy mittels dconf zurückzusetzen (reset), hat allerdings nichts verändert und ich weiß auch nicht, ob das wirklich geklappt hat.
Pantheon habe ich mittlerweile so restlos wie möglich entfernt, das metapackage für gnome sowie gnome-control-center mittels pacman -Rcs entfernt und neu installiert, allerdings ohne Erfolg.

Wäre euch dankbar, wenn mir vielleicht jemand helfen könnte, macht das System zwar jetzt nicht unbrauchbar, aber nervig ist es schon ein wenig.

Vielen Dank und Beste Grüße,
Schwertfisch

*Plane, mein System in einiger Zeit neu aufzusetzen, würde damit aber gerne noch etwas warten. Ich verwende übrigens die linux-hardened Kernel, falls das etwas hilft.

Beitrag geändert von Schwertfisch (06.08.2019 14:45:01)

Offline

#2 06.08.2019 19:26:29

Schwertfisch
Mitglied

Re: (Gnome) Systemeinstellungen starten nicht mehr

Konnte das Problem selbst lösen!

rm -rf .gnome .gnome2 .gconf .gconfd .metacity .cache .dbus .dmrc .mission-control .thumbnails ~/.config/dconf/user ~.compiz*

gefolgt von einem Neustart war alles, was notwendig war... löscht allerdings SÄMTLICHE Konfigurationsdateien von GNOME, das sollte man also beachten falls jemand dasselbe Problem hat.

*edit: Als ich nun in den Systemeinstellungen unter "Datenschutz" Einstellungen vornehmen wollte, ist gnome-control-center gecrashed, selbe Fehlermeldung wie zuvor. Das Problem liegt also ganz klar dort

Beitrag geändert von Schwertfisch (06.08.2019 19:37:04)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums