#1 24.06.2019 18:45:48

QWWYZQ
Mitglied

[gelöst]grub-mkconfig akzeptiert Kernel parameter nicht

Moin allerseits!

Ich benötige den Kernel parameter

 acpi_osi=! acpi_osi="Windows 2009" 

Wenn ich den Parameter per Hand beim booten eingeben, startet er auch ohne Probleme und alles läuft.

Da ich natürlich keine lust habe das ganze jedes Mal einzugeben, bin ich dem Arch Wiki gefolgt und habe den Befehl angehängt

 GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=! acpi_osi="Windows 2009""

um danach folgendes auszuführen:

 grub-mkconfig -o /boot/grub/grub.cfg

Was dann leider wiederum zu dieser Meldung hier führt:

/etc/default/grub: Zeile 6: 2009: Kommando nicht gefunden.

Wo ist hier der Fehler? Ich gebe es in der default Grub config genau so ein, wie ich es beim booten mache.
Und warum erkennt er da das 2009 als alleinstehenden Befehl?

Beitrag geändert von QWWYZQ (24.06.2019 19:30:10)

Offline

#2 24.06.2019 19:21:00

Greg
Mitglied

Re: [gelöst]grub-mkconfig akzeptiert Kernel parameter nicht

Ich selber kann das nicht testen.
Aber laut dieser Seite:
https://iam.tj/prototype/enhancements/W … i_osi.html
müßte es dann heißen
In der /etc/default/grub/

GRUB_CMDLINE_LINUX="acpi_osi=! \"acpi_osi=Windows 2009\""

eintragen.
Ob die \ das Nötige ist ??
Gruß aus DN
Greg

Offline

#3 24.06.2019 19:29:57

QWWYZQ
Mitglied

Re: [gelöst]grub-mkconfig akzeptiert Kernel parameter nicht

Perfekt, so hat's direkt geklappt.
Vielen Dank für die schnelle Antwort!

Die Erklärung auf der Seite ist auch sehr interessant.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums