#1 10.06.2019 17:27:28

ava_corp
Mitglied

[gelöst] wifi versucht sich ständig zu verbinden

Hallo,

wenn ich dmesg im Terminal aufrufe, habe ich endlose Zeilen "IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready". Jede fünf Minuten bekomme ich einen neuen Eintrag. Ich habe ein Screenshot angehängt.
Wie kann ich dies vermeiden?

Kleine Info: Ich bin über LAN im Internet und das wifi device habe ich mit ip link set wlp1s0 down abgeschaltet. So soll es auch sein.


https://ibb.co/gytRWRf

Beitrag geändert von ava_corp (10.06.2019 21:47:37)

Offline

#2 10.06.2019 18:30:47

schard
Moderator

Re: [gelöst] wifi versucht sich ständig zu verbinden

Ich bin gerade mobil unterwegs und werde mir für ein paar Kilobytes Text kein Megabyte großes Bild herunterladen. Vielleicht hat ja jemand anderes Lust deinen Screenshot zu entziffern. Oder du postest den originalen Text hier als solchen in Code Tags.
Und wenn du dabei bist, kannst du gleich Mal die Liste der laufenden Services und die Ausgabe von

ip addr

angeben.

Offline

#3 10.06.2019 18:40:59

ava_corp
Mitglied

Re: [gelöst] wifi versucht sich ständig zu verbinden

Okay sorry, bin neu hier im Forum.

Also hier nochmal dmesg:

[Mo Jun 10 16:30:25 2019] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[Mo Jun 10 16:35:41 2019] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[Mo Jun 10 16:40:57 2019] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[Mo Jun 10 16:46:13 2019] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[Mo Jun 10 16:51:33 2019] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[Mo Jun 10 16:56:49 2019] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[Mo Jun 10 17:02:09 2019] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[Mo Jun 10 17:07:25 2019] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[Mo Jun 10 17:12:41 2019] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[Mo Jun 10 17:17:57 2019] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready

systemctl status:

         ├─user.slice
           │ └─user-1000.slice
           │   ├─user@1000.service
           │   │ ├─pulseaudio.service
           │   │ │ ├─861 /usr/bin/pulseaudio --daemonize=no
           │   │ │ └─925 /usr/lib/pulse/gsettings-helper
           │   │ ├─gvfs-daemon.service
           │   │ │ ├─ 610 /usr/lib/gvfsd
           │   │ │ ├─ 615 /usr/lib/gvfsd-fuse /run/user/1000/gvfs -f -o big_writes
           │   │ │ ├─ 827 /usr/lib/gvfsd-trash --spawner :1.11 /org/gtk/gvfs/exec_spaw/0
           │   │ │ ├─1942 /usr/lib/gvfsd-network --spawner :1.11 /org/gtk/gvfs/exec_spaw/1
           │   │ │ └─1948 /usr/lib/gvfsd-dnssd --spawner :1.11 /org/gtk/gvfs/exec_spaw/2
           │   │ ├─thunar.service
           │   │ │ └─24528 /usr/bin/Thunar --daemon
           │   │ ├─gvfs-udisks2-volume-monitor.service
           │   │ │ └─698 /usr/lib/gvfs-udisks2-volume-monitor
           │   │ ├─xfce4-notifyd.service
           │   │ │ └─694 /usr/lib/xfce4/notifyd/xfce4-notifyd
           │   │ ├─init.scope
           │   │ │ ├─547 /usr/lib/systemd/systemd --user
           │   │ │ └─548 (sd-pam)
           │   │ ├─gpg-agent.service
           │   │ │ └─581 /usr/bin/gpg-agent --supervised
           │   │ ├─gvfs-gphoto2-volume-monitor.service
           │   │ │ └─769 /usr/lib/gvfs-gphoto2-volume-monitor
           │   │ ├─at-spi-dbus-bus.service
           │   │ │ ├─669 /usr/lib/at-spi-bus-launcher
           │   │ │ ├─675 /usr/bin/dbus-daemon --config-file=/usr/share/defaults/at-spi2/accessibility.conf --nofork --print-address 3
           │   │ │ └─677 /usr/lib/at-spi2-registryd --use-gnome-session
           │   │ ├─gvfs-metadata.service
           │   │ │ └─866 /usr/lib/gvfsd-metadata
           │   │ ├─dbus.service
           │   │ │ ├─ 570 /usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
           │   │ │ ├─ 576 /usr/lib/xfce4/xfconf/xfconfd
           │   │ │ └─1410 /usr/lib/dconf-service
           │   │ └─gvfs-afc-volume-monitor.service
           │   │   └─762 /usr/lib/gvfs-afc-volume-monitor
           │   └─session-1.scope
           │     ├─  496 login -- ava
           │     ├─  554 -bash
           │     ├─  557 xinit /etc/xdg/xfce4/xinitrc -- /etc/X11/xinit/xserverrc vt1
           │     ├─  558 /usr/lib/Xorg -nolisten tcp :0 vt1
           │     ├─  564 sh /etc/xdg/xfce4/xinitrc
           │     ├─  572 xfce4-session
           │     ├─  579 /usr/bin/ssh-agent -s
           │     ├─  583 xfwm4 --display :0.0 --sm-client-id 20fbcea9d-6c85-4e30-bf86-f3046579ef2e
           │     ├─  584 xfce4-panel --display :0.0 --sm-client-id 2a36efaab-7e70-43e0-9439-63e673fcedad
           │     ├─  586 xfsettingsd --display :0.0 --sm-client-id 2f0d13cf5-624f-420a-97dc-1938969a105a
           │     ├─  591 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libdatetime.so 1 8388633 datetime Datum und Uhrzeit >
           │     ├─  593 /usr/lib/xfce4/panel/wrapper-1.0 /usr/lib/xfce4/panel/plugins/libcpugraph.so 2 8388634 cpugraph CPU-Graph Grafisch>
           │     ├─  596 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libgenmon.so 5 8388635 genmon Allgemeine  berwachung>
           │     ├─  597 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libdiskperf.so 6 8388636 diskperf Festplattenleistun>
           │     ├─  598 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libnetload.so 7 8388637 netload Netzwerkmonitor Netz>
           │     ├─  599 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libnetload.so 3 8388638 netload Netzwerkmonitor Netz>
           │     ├─  600 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libfsguard.so 9 8388639 fsguard Speicherplatzpr fung>
           │     ├─  601 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libfsguard.so 8 8388640 fsguard Speicherplatzpr fung>
           │     ├─  602 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libfsguard.so 4 8388641 fsguard Speicherplatzpr fung>
           │     ├─  603 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libfsguard.so 14 8388642 fsguard Speicherplatzpr fun>
           │     ├─  604 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libfsguard.so 15 8388643 fsguard Speicherplatzpr fun>
           │     ├─  605 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libsystemload.so 10 8388644 systemload berwachung de>
           │     ├─  606 /usr/lib/xfce4/panel/wrapper-1.0 /usr/lib/xfce4/panel/plugins/libweather.so 11 8388645 weather Wetterbericht Aktue>
           │     ├─  607 /usr/lib/xfce4/panel/wrapper-2.0 /usr/lib/xfce4/panel/plugins/libxkb.so 12 8388646 xkb Tastaturbelegung Erweiterun>
           │     ├─  691 xfce4-power-manager --restart --sm-client-id 2245af34d-217f-4c5b-87cb-965cb143f74b
           │     ├─  802 /usr/bin/python3 /usr/bin/guake
           │     ├─  805 usr/share/jetbrains-toolbox/jetbrains-toolbox --minimize
           │     ├─  833 /home/ava/.local/share/JetBrains/Toolbox/bin/jetbrains-toolbox --minimize
           │     ├─  845 /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1
           │     ├─  860 /usr/bin/python3 /usr/bin/guake
           │     ├─  921 /tmp/.mount_jetbraKcTVzA/usr/share/jetbrains-toolbox/CEF/jetbrains-toolbox-cef --toolbox-server-ws=ws://127.0.0.1:>
           │     ├─  958 /tmp/.mount_jetbraKcTVzA/usr/share/jetbrains-toolbox/CEF/jetbrains-toolbox-cef-helper --type=zygote --no-sandbox ->
           │     ├─  979 /tmp/.mount_jetbraKcTVzA/usr/share/jetbrains-toolbox/CEF/jetbrains-toolbox-cef-helper --type=gpu-process --no-sand>
           │     ├─ 1015 /tmp/.mount_jetbraKcTVzA/usr/share/jetbrains-toolbox/CEF/jetbrains-toolbox-cef-helper --type=renderer --no-sandbox>
           │     ├─ 1408 /bin/bash
           │     ├─ 1427 /bin/bash
           │     ├─ 8983 /usr/lib/firefox/firefox -contentproc -childID 87 -isForBrowser -prefsLen 9325 -prefMapSize 182245 -parentBuildID >
           │     ├─ 9028 /usr/lib/firefox/firefox -contentproc -childID 233 -isForBrowser -prefsLen 9392 -prefMapSize 182245 -parentBuildID>
           │     ├─ 9174 dmesg -w
           │     ├─ 9187 /usr/bin/xfce4-terminal
           │     ├─ 9191 bash
           │     ├─ 9265 systemctl status
           │     ├─ 9266 less
           │     ├─15486 xfdesktop --display :0.0 --sm-client-id 2ec5ce11d-e862-4cfe-a4c7-93603e3ae98e
           │     ├─17374 volumeicon
           │     ├─18231 /usr/lib/firefox/firefox
           │     ├─18412 /usr/lib/firefox/firefox -contentproc -childID 2 -isForBrowser -prefsLen 5912 -prefMapSize 182245 -parentBuildID 2>
           │     ├─18451 /usr/lib/firefox/firefox -contentproc -childID 3 -isForBrowser -prefsLen 6033 -prefMapSize 182245 -parentBuildID 2>
           │     ├─20894 /usr/lib/firefox/firefox -contentproc -parentBuildID 20190604174832 -greomni /usr/lib/firefox/omni.ja -appomni /us>
           │     ├─23508 pavucontrol
           │     ├─25250 gpg-agent --homedir /etc/pacman.d/gnupg --use-standard-socket --daemon
           │     └─25315 dirmngr --daemon --homedir /etc/pacman.d/gnupg
           ├─init.scope
           │ └─1 /sbin/init
           └─system.slice
             ├─systemd-udevd.service
             │ └─218 /usr/lib/systemd/systemd-udevd
             ├─polkit.service
             │ └─471 /usr/lib/polkit-1/polkitd --no-debug
             │ └─218 /usr/lib/systemd/systemd-udevd
             ├─polkit.service
             │ └─471 /usr/lib/polkit-1/polkitd --no-debug
             ├─rtkit-daemon.service
             │ └─876 /usr/lib/rtkit-daemon
             ├─bluetooth.service
             │ └─4919 /usr/lib/bluetooth/bluetoothd
             ├─wpa_supplicant.service
             │ └─470 /usr/bin/wpa_supplicant -u
             ├─systemd-journald.service
             │ └─207 /usr/lib/systemd/systemd-journald
             ├─colord.service
             │ └─507 /usr/lib/colord
             ├─org.cups.cupsd.service
             │ └─493 /usr/bin/cupsd -l
             ├─NetworkManager.service
             │ └─371 /usr/bin/NetworkManager --no-daemon
             ├─vnstat.service
             │ └─495 /usr/sbin/vnstatd -n
             ├─lvm2-lvmetad.service
             │ └─213 /usr/bin/lvmetad -f
             ├─upower.service
             │ └─705 /usr/lib/upowerd
             ├─udisks2.service
             │ └─702 /usr/lib/udisks2/udisksd
             ├─dbus.service
             │ └─370 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
             ├─avahi-daemon.service
             │ ├─369 avahi-daemon: running [archlabs.local]
             │ └─382 avahi-daemon: chroot helper
             └─systemd-logind.service
               └─367 /usr/lib/systemd/systemd-logind

ip addr:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether ec:8e:b5:79:12:d2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.113/24 brd 192.168.2.255 scope global dynamic noprefixroute enp2s0
       valid_lft 1459865sec preferred_lft 1459865sec
    inet6 2003:c0:f70b:91fd:726c:111c:f7b0:e1f8/64 scope global deprecated dynamic noprefixroute 
       valid_lft 444104sec preferred_lft 0sec
    inet6 2003:c0:f70b:9187:6d1a:185e:69e2:a43f/64 scope global deprecated dynamic noprefixroute 
       valid_lft 357815sec preferred_lft 0sec
    inet6 2003:c0:f70b:914e:a30f:1294:117e:c5a8/64 scope global deprecated dynamic noprefixroute 
       valid_lft 271527sec preferred_lft 0sec
    inet6 2003:c0:f70b:9149:cf13:f744:865a:99bf/64 scope global deprecated dynamic noprefixroute 
       valid_lft 185238sec preferred_lft 0sec
    inet6 2003:c0:f70b:910d:3f3a:e208:c9cb:ecf7/64 scope global dynamic noprefixroute 
       valid_lft 604780sec preferred_lft 86380sec
    inet6 fe80::1cb3:8933:5494:47d6/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlp1s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether be:2c:e1:3a:43:c2 brd ff:ff:ff:ff:ff:ff

Beitrag geändert von ava_corp (10.06.2019 18:41:24)

Offline

#4 10.06.2019 21:12:34

stefanhusmann
Moderator

Re: [gelöst] wifi versucht sich ständig zu verbinden

Je nachdem wie hart du herangehen willst:

Du könntest die wifi-Pakete deinstallieren:

pacman -Rcs wireless_tools wpa_supplicant

Du könntest auch alternativ den entsprechenden Service deaktivieren.

systemctl disable wpa_supplicant.service

Offline

#5 10.06.2019 21:35:17

ava_corp
Mitglied

Re: [gelöst] wifi versucht sich ständig zu verbinden

stefanhusmann schrieb:

Je nachdem wie hart du herangehen willst:

Du könntest die wifi-Pakete deinstallieren:

pacman -Rcs wireless_tools wpa_supplicant

Du könntest auch alternativ den entsprechenden Service deaktivieren.

systemctl disable wpa_supplicant.service

Ich habe mich mal für 2. entschieden.

Ich habe zwar den service deaktiviert, aber es hat sich nichts an der Situation geändert. Siehe hier:

 
● wpa_supplicant.service - WPA supplicant
   Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; disabled; vendor preset: disabled)
   Active: active (running) since Mon 2019-06-10 21:24:14 CEST; 6min ago
 Main PID: 401 (wpa_supplicant)
    Tasks: 1 (limit: 4915)
   Memory: 3.8M
   CGroup: /system.slice/wpa_supplicant.service
           └─401 /usr/bin/wpa_supplicant -u

Jun 10 21:24:14 archlabs systemd[1]: Starting WPA supplicant...
Jun 10 21:24:14 archlabs systemd[1]: Started WPA supplicant.
Jun 10 21:24:14 archlabs wpa_supplicant[401]: Successfully initialized wpa_supplicant
Jun 10 21:24:18 archlabs wpa_supplicant[401]: wlp1s0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=COUNTRY alpha2=DE
Jun 10 21:29:59 archlabs wpa_supplicant[401]: wlp1s0: Reject scan trigger since one is already pending

Die Pakete zu deinstallieren fällt für mich eigentlich weg, weil ich ab und zu auf WLAN zurückgreife und ich das immer wieder neu installieren und einrichten müsste.

Meine Vorstellung:
Das device deaktivieren (habe ich durch ip link gemacht) und wenn ich es wieder brauche, aktivieren. Aber eben ohne die Meldungen im dmesg. Ich weiß ja garnicht ob das überhaupt möglich ist.

Offline

#6 10.06.2019 21:36:01

TBone
Mitglied

Re: [gelöst] wifi versucht sich ständig zu verbinden

Hast du auch rebooted? Oder den Service gestoppt?

Offline

#7 10.06.2019 21:45:42

ava_corp
Mitglied

Re: [gelöst] wifi versucht sich ständig zu verbinden

TBone schrieb:

Hast du auch rebooted? Oder den Service gestoppt?

Rebootet habe ich, aber nicht gestoppt.

Ich habe einfach mal

systemctl stop wpa_supplicant.service

eingegeben und es funktioniert. Ich dachte immer deaktivieren also

systemctl disable

reicht.

Oh man, es kann so einfach sein. Danke euch.

Offline

#8 10.06.2019 22:04:50

Galde75
Mitglied

Re: [gelöst] wifi versucht sich ständig zu verbinden

"disable" deaktiviert den automatischen Start beim booten, "stop" nur den aktuell laufenden Dienst.

Wenn er trotz disable nach einem Neustart läuft wird ein anderer Prozess diesen anfordern und starten (die Netzwerk-Manager zB).

Auch kann es sein das zwar der XXXXX.service deaktiviert ist aber zB ein XXXXX.socket diesen weiterhin startet.

Beitrag geändert von Galde75 (10.06.2019 22:07:39)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums