#1 08.06.2019 16:23:56

akarvi
Mitglied

[SOLVED] Alsa (über Pulse): Kann Auto-Mute nicht wieder Enablen

Hi,

folgende Frage:

Ich habe vor einigen Tagen per amixer den Auto-Mute Mode (Lautsprecher schalten stumm, sobald Kopfhörer in Frontbuchse eingesteckt wird) deaktiviert, da ich zwei Ausgabegeräte gleichzeitig betreiben wollte.

$ amixer -c 0 sset 'Auto-Mute Mode' Disabled
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Speaker Only' 'Line Out+Speaker'
  Item0: 'Disabled'
$

Nun habe ich einen Adapter bekommen, über den beide Ausgabegeräte über den hinteren Lautsprecheranschluß am PC betrieben werden.

Ich wollte demzufolge Auto-Mute wieder aktivieren:

$
amixer -c 0 sset 'Auto-Mute Mode' Enabled
amixer: Invalid command!
$

Auto-Mute steht natürlich immer noch auf 'Disabled'!

$ amixer -c 0 sget 'Auto-Mute Mode'
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Speaker Only' 'Line Out+Speaker'
  Item0: 'Disabled'
$

Was ist da denn kaputt? Bug in amixer?

Ich habs jetzt manuell in der /etc/asound.state geändert. Kennt jemand dieses Verhalten?

EDIT:

Mhh, Auch nach Änderung und Neustart von Alsa bleibt alles beim Alten.

$ grep -A 8 Mute /etc/asound.state
        name 'Auto-Mute Mode'
        value Enabled
        comment {
            access 'read write'
            type ENUMERATED
            count 1
            item.0 Enabled
            item.1 Enabled
        }
$

$ amixer -c 0 sget 'Auto-Mute Mode'
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Speaker Only' 'Line Out+Speaker'
  Item0: 'Disabled'
$

Kann mir jemand sagen, wie wieder zu funktionierendem Auto-Mute gelange? smile

Gruß

Alex
***

Beitrag geändert von akarvi (10.06.2019 20:36:38)

Offline

#2 08.06.2019 17:33:05

akarvi
Mitglied

Re: [SOLVED] Alsa (über Pulse): Kann Auto-Mute nicht wieder Enablen

Lösung: Man muss das per alsamixer machen.
Mittels F6 passende Soundkarte auswählen und dort Auto-Mute auf Line-Out stellen.

Aber warum funktioniert das nicht mit amixer?

Gruß
Alex

Offline

#3 10.06.2019 20:35:56

akarvi
Mitglied

Re: [SOLVED] Alsa (über Pulse): Kann Auto-Mute nicht wieder Enablen

LÖSUNG:

Anstatt "Enabled" muss man dem System anscheinend mitteilen, welche Anschlüsse ins Auto-Muting einbezogen werden sollen:

$ amixer -c 0 sset 'Auto-Mute Mode' 'Line Out+Speaker'
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Speaker Only' 'Line Out+Speaker'
  Item0: 'Line Out+Speaker'

Da soll man nun erstmal drauf kommen... big_smile (Naja, er schlägt sie in der Items-Zeile sogar vor...)

Beitrag geändert von akarvi (10.06.2019 20:46:10)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums