#1 09.05.2019 08:23:26

cipher
Mitglied

[gelöst] virtmanager Fehlermeldung

Hallo zusammen,

Beim erstellen einer neuen VM mit virtmanager kommt gleich bei Schritt 2 eine Fehlermeldung.

Fehler beim Einstellen des Standardnamens.
'utf-8' codec can't decode byte 0xfc in position 39: invalid start byte

bildschirmfoto_2019-0ogkxq.png

Wo liegt der Fehler?

gruss

Beitrag geändert von cipher (30.05.2019 14:43:47)

Offline

#2 09.05.2019 09:01:58

schard
Moderator

Re: [gelöst] virtmanager Fehlermeldung

Das sieht nach einem Python UnicodeDecodeError Text aus. Was ist denn der Standardname? Offensichtlich enthält dieser ein nicht-UTF-8 Zeichen.

Online

#3 09.05.2019 09:14:03

cipher
Mitglied

Re: [gelöst] virtmanager Fehlermeldung

Im ersten Schritt gebe ich nur an wie ich das Betriebssystem installieren möchte. Wähle hier "lokales Installationsmedium".

bildschirmfoto_2019-0vwksk.png

Offline

#4 09.05.2019 14:53:46

blub
Gast

Re: [gelöst] virtmanager Fehlermeldung

Hast du irgendwo ein "ü" verwendet?
0xfc ist nach ISO 8859-1 und UTF-16 ein kleines ü, in UTF-8 allerdings ein ungültiger Bytecode.

#5 10.05.2019 08:47:23

cipher
Mitglied

Re: [gelöst] virtmanager Fehlermeldung

Ich kann ja an dieser Stelle noch nirgendwo etwas reinschreiben. Im Pfad des Images sind keine Sonderzeichen vorhanden. Spielt auch keine Rolle welches Image ich auswähle. Die Fehlermeldung ist immer die gleiche.

Offline

#6 10.05.2019 11:31:45

schard
Moderator

Re: [gelöst] virtmanager Fehlermeldung

Welchen virtmanager benutzt du eigentlich?
Der von Arch Linux heißt "virt-manager" und hat eine andere GUI.
Benutzt du überhaupt Arch Linux?

Beitrag geändert von schard (10.05.2019 11:31:59)

Online

#7 10.05.2019 14:05:20

cipher
Mitglied

Re: [gelöst] virtmanager Fehlermeldung

Ich benutze arch und die Version 2.1.0-2 aus dem repo.
Wie kommst du darauf das das nicht der virt-manager ist?
Das ist der normale Dialog zum neuerstellen eines KVM Gastes.

Offline

#8 10.05.2019 17:27:13

schard
Moderator

Re: [gelöst] virtmanager Fehlermeldung

Ich habe gefragt, weil bei mir die Dialoge andere Inhalte haben. So fehlt hier z.B. Die Auswahloption für eine Architektur und ich habe bei der Betriebssystemauswahl noch eine Checkbox drunter "Automatically detect from the installation media / source".
Welche Art Verbindung benutzt du denn?

Online

#9 11.05.2019 09:20:26

cipher
Mitglied

Re: [gelöst] virtmanager Fehlermeldung

Die Auswahloption für die Architektur ist doch auf dem Screenshot in Beitrag #3 zu sehen. Oder meinst du eine andere?
Bei der Betriebssystemauswahl kommt nochmals ein kleines Fenster hoch, dort wähle ich Server 2016. Automatisch erkennt er nichts.
Die Verbindung läuft über ssh.

Noch etwas vergessen.
Ich habe gestern mit einer ubuntu Installation das ganze nochmals getestet. Dort ist die Version 1.5.1 im Einsatz, und funktioniert das ISO-Image einwandfrei. Keine Ahnung ob dies an der Version liegt oder an der Version des KVM Hosts, die ja auch schon etwas älter zu sein scheint.
Müssen vielleicht die Versionen am Host und Client die gleiche Version haben?

Beitrag geändert von cipher (11.05.2019 09:27:01)

Offline

#10 25.05.2019 15:13:52

cipher
Mitglied

Re: [gelöst] virtmanager Fehlermeldung

Bin ich der einzige mit dem Problem?

Offline

#11 25.05.2019 17:43:59

chepaz
Mitglied

Re: [gelöst] virtmanager Fehlermeldung

cipher schrieb:

Bin ich der einzige mit dem Problem?

Scheint so wink Hast du mal probiert das ISO um zu benennen?


Edit: Mounte das ISO mal oder schau was 'file' dazu sagt. Evtl. Ist es kein ISO, oder ist korrupt?

Beitrag geändert von chepaz (25.05.2019 17:46:08)

Offline

#12 26.05.2019 11:38:13

cipher
Mitglied

Re: [gelöst] virtmanager Fehlermeldung

Hallo chepaz,

Umbenannt habe ich das ISO nicht. Aber ich habe mehrere andere ISO-Images ausprobiert. Die Fehlermeldung ist immer die gleiche.

Ich habe dann mit dem virt-manager unter ubuntu die neue Maschine erstellt (mit dem gleichen ISO-Image). Die Maschine lies sich problemlos erstellen und installieren.

Ich habe eigentlich den Verdacht das es sich um einen Versionskonflikt handelt. Der KVM Host ist eine gentoo Maschine mit Version 1.5.1, und ich benutze arch mit Version 2.1.0.

Werde mit 'file' mal nachschauen was kommt. Auf was muss ich achten? Ich kenne 'file' nicht.

Offline

#13 26.05.2019 20:52:34

chepaz
Mitglied

Re: [gelöst] virtmanager Fehlermeldung

cipher schrieb:

Ich habe eigentlich den Verdacht das es sich um einen Versionskonflikt handelt. Der KVM Host ist eine gentoo Maschine mit Version 1.5.1, und ich benutze arch mit Version 2.1.0.

Kann schon sein. Hatte auch schon Probleme Maschinen auf einem CentOS-Cluster zu verschieben mit einer "zu neuen Version" von virt-manager.

cipher schrieb:

Werde mit 'file' mal nachschauen was kommt. Auf was muss ich achten? Ich kenne 'file' nicht.

 man file 

wink

Auf nichts. Einfach 'file ISOdeinesVertrauens.iso'.
Nur um zu prüfen das dein ISO auch das ist was es zu sein scheint. Alternativ das ISO mounten und reinschauen. Oder noch besser, falls vorhanden, md5sum/sha256sum prüfen. Wenn dein Ubuntu damit klarkommt kannst du aber davon ausgehen das es nicht am ISO liegt.

Offline

#14 27.05.2019 12:56:03

cipher
Mitglied

Re: [gelöst] virtmanager Fehlermeldung

chepaz schrieb:

Auf nichts. Einfach 'file ISOdeinesVertrauens.iso'.
Nur um zu prüfen das dein ISO auch das ist was es zu sein scheint. Alternativ das ISO mounten und reinschauen. Oder noch besser, falls vorhanden, md5sum/sha256sum prüfen. Wenn dein Ubuntu damit klarkommt kannst du aber davon ausgehen das es nicht am ISO liegt.

Das zeigt die Ausgabe von 'file':

file SW_DVD9_Win_Server_STD_CORE_2016_64Bit_German_-4_DC_STD_MLF_X21-70528.ISO
SW_DVD9_Win_Server_STD_CORE_2016_64Bit_German_-4_DC_STD_MLF_X21-70528.ISO: ISO 9660 CD-ROM filesystem data 'SSS_X64FREV_DE-DE_DV9' (bootable)

Offline

#15 30.05.2019 14:43:22

cipher
Mitglied

Re: [gelöst] virtmanager Fehlermeldung

Konnte das Problem eingrenzen.
Das Problem war, das der KVM Host (gentoo) die locale 'de_DE.UTF-8 UTF-8' nicht kannte. Nachdem ich dies umkonfiguriert hatte läuft nun alles.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums