#1 03.02.2019 01:06:59

SUSEDJAlex
Mitglied

[Gelöst] Update-Fehler Python5

Hallo miteinander,

gerade eben einen Update durchgezogen wobei folgende Pakete von Python 5 aktualisiert werden:

python-pyqt5-5.11.3-4
pyqt5-common-5.11.3-4

kommt zum Schluss die Fehlermeldung:

Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc existiert im Dateisystem
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Hier muss als Lösung der betreffende Ordner gelöscht werden ( mit Root-Rechten )

rm -rf /usr/lib/python3.7/site-packages/PyQt5/__pycache__/

Danach das Update nochmal durchlaufen lassen

LG SUSEDJAlex

Beitrag geändert von SUSEDJAlex (10.02.2019 00:35:46)

Online

#2 03.02.2019 08:18:44

niemand
Mitglied

Re: [Gelöst] Update-Fehler Python5

Es gibt kein Python 5 wink

Ansonsten lief’s bei mir gerade problemlos durch, die betreffende Datei stammt also nicht von der alten Version.

Offline

#3 04.02.2019 10:14:57

schard
Mitglied

Re: [Gelöst] Update-Fehler Python5

Da hat wohl jemand ohne Sinn und Verstand mit pip hantiert. Lasst sowas sein, wenn ihr euch der Folgen nicht bewusst seid.

Offline

#4 08.02.2019 22:27:35

manit
Mitglied

Re: [Gelöst] Update-Fehler Python5

Hallo SUSEDJAlex,
danke für Deinen Beitrag. Dein Lösungsvorschlag hat mir geholfen. Ich habe 2x Arch auf 2 Festplatten und eine war von dem Fehler betroffen.
@schard wer mit Arch unterwegs ist, macht nichts " ohne Sinn und Verstand " sondern aus Unkenntnis und darum ist ein Forum da.
MfG. manit

Offline

#5 10.02.2019 00:35:08

SUSEDJAlex
Mitglied

Re: [Gelöst] Update-Fehler Python5

schard schrieb:

Da hat wohl jemand ohne Sinn und Verstand mit pip hantiert. Lasst sowas sein, wenn ihr euch der Folgen nicht bewusst seid.

ich will niemanden auf die Füße treten....

Aber nur zu deiner Information:

Python brauch ich aus den folgenden Gründen:

pacman -Qi python
Name                     : python
Version                  : 3.7.2-3
Beschreibung             : Next generation of the python high-level scripting language
Architektur              : x86_64
URL                      : http://www.python.org/
Lizenzen                 : custom
Gruppen                  : Nichts
Stellt bereit            : python3
Hängt ab von             : expat  bzip2  gdbm  openssl  libffi  zlib  libnsl
Optionale Abhängigkeiten : python-setuptools
                           python-pip
                           sqlite [Installiert]
                           mpdecimal: for decimal
                           xz: for lzma [Installiert]
                           tk: for tkinter
Benötigt von             : libixion  libreoffice-fresh  whatsie
Optional für             : btrfs-progs  glib2  libnewt  libproxy  usbutils  util-linux  volume_key
In Konflikt mit          : Nichts
Ersetzt                  : python3
Installationsgröße       : 145,61 MiB
Packer                   : Felix Yan <felixonmars@archlinux.org>
Erstellt am              : Fr 11 Jan 2019 00:51:51 CET
Installiert am           : Fr 25 Jan 2019 13:46:10 CET
Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript     : Nein
Verifiziert durch        : Signatur

da sieht man dass libreoffice das python benötigt....

Und: nein python-pip habe ich nicht installiert, wie du sehen kannst

Ich wünsche dir ein schönes WE

LG SUSEDJAlex

Online

#6 10.02.2019 09:58:02

niemand
Mitglied

Re: [Gelöst] Update-Fehler Python5

Naja, aber irgendwas hat ja bei dir nunmal die Datei am Paketmanagement vorbei erstellt. Wäre schon sinnvoll, mal zu gucken, was denn da mit Rootrechten am System rumfuhrwerkt, finde ich.

Offline

#7 10.02.2019 13:35:03

Galde75
Mitglied

Re: [Gelöst] Update-Fehler Python5

manit schrieb:

wer mit Arch unterwegs ist, macht nichts " ohne Sinn und Verstand " sondern aus Unkenntnis und darum ist ein Forum da

Man kann aber Archlinux ohne Sinn und Verstand nutzen. Zum Beispiel wenn man keinen Plan/Lust hat sich mit dem System zu befassen, aber die coolste Distri haben muss. Und müssen dann 1:1 alles vorgekaut bekommen, begegnet man immer wieder...
(Womit ich nicht sagen will das du dazu gehörst)

Offline

#8 10.02.2019 16:39:55

chepaz
Mitglied

Re: [Gelöst] Update-Fehler Python5

Vermutlich ist das gebashe hier unangebracht. Siehe https://bbs.archlinux.org/viewtopic.php?id=243795

Sieht eher nach einem unglücklichen Umstand aus. Und jetzt erzähle hier keiner er startet nie aus seiner Usersession mal ein $grafischesprogramm als root wink

Offline

#9 10.02.2019 16:42:14

niemand
Mitglied

Re: [Gelöst] Update-Fehler Python5

Und jetzt erzähle hier keiner er startet nie aus seiner Usersession mal ein $grafischesprogramm als root

Ich erzähle genau das.

Offline

#10 10.02.2019 16:44:37

chepaz
Mitglied

Re: [Gelöst] Update-Fehler Python5

niemand schrieb:

Und jetzt erzähle hier keiner er startet nie aus seiner Usersession mal ein $grafischesprogramm als root

Ich erzähle genau das.

Dann [r,H][u,oo]t ab.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums