#1 06.02.2019 21:16:45

dab895
Mitglied

Monitor wird nicht erkannt

Hallo,

nachdem ich ich nun schon eine Weile ArchLinux nutze, habe ich mir nun einen neuen Rechner zugelegt und damit auch ein Problem

CPU     ->    AMD Rayzen 2600X
GPU     ->    AMD Vega 64

Als Haupt Monitor ein Asus PG278Q   2560x1440 144hz   ->  Angeschlossen per Displayport
Zweitmonitor 1600x1050 60hz  -> Angeschlossen per DVI

Beim Booten geht der DP Monitor an Grub begrüßt mich mit der vollen Auflösung.
Sobald dann aber amdgpu geladen wird ändert sich die Auflösung auf 640x480, der Monitor zeigt wohl immer noch
Die volle Auflösung weshalb ich nur ein kleines Fenster in der Mitte des Monitors habe mit 640x480.... bekomme es nicht besser beschrieben :-)

gleichzeitig mit dem laden von amdgpu springt aber nun auch der 2. Monitor an der ohne Probleme mit passender Auflösung das gleiche Bild wiedergibt.

Der Asus Monitor hat nur einen DP Anschluss.

Klemme ich den 2. Monitor ab bleib das Problem gleich.
Klemme ich den 1. Monitor ab und benutze nur den DVI hab ich kein problem.

Wenn ich den X-Server starte bleibt das Problem gleich. In den Monitoreinstellungen wird der 2. Monitor korrekt erkannt .

Beim DP Monitor steht -> Anzeige nicht erkannt.

zum Test habe ich mit einen Manjaro Stick erstellt  -->  gleiches Problem

Ubuntu und Linux Mint --> alles wird automatisch erkannt mit passender Auflösung (alles super nur das es kein Arch ist -.-)

start von Arch mit     nomodeset    Auflösung passt....


wär für jeder Hilfe dankbar.

Beitrag geändert von dab895 (06.02.2019 21:17:10)

Offline

#2 06.02.2019 23:49:47

tomizius
Mitglied

Re: Monitor wird nicht erkannt

Hast du schon versucht mit xrandr über die Konsole die Auflösung anzupassen?

Welche GUI verwendest du?

Offline

#3 07.02.2019 05:04:37

Galde75
Mitglied

Re: Monitor wird nicht erkannt

In der Grub-Config "GRUB_GFXPAYLOAD_LINUX" auskommentiert?
Dann nutzt der Kernel die Auflösung die bei GRUB verwendet wurde

So sollte es aussehen:
/etc/default/grub

GRUB_GFXPAYLOAD_LINUX="keep"

Danach mit

grub-mkconfig -o /boot/grub/grub.cfg

die Config schreiben

AMDGPU  und(!) RADEON in mkinitcpio.conf eingetragen?

/etc/mkinitcpio.conf

MODULES="amdgpu radeon *Rest was sonst noch drin steht*"

Reihenfolge ist wichtig!
Dort natürlich auch

mkinitcpio -p linux

RADEON sollte auch nicht Blacklisted sein, da AMDGPU Teile davon verwendet


Man kann auch irgendwo eintragen welcher Anschluss der Default beim Booten ist, ich weis jedoch nicht wo.

Beitrag geändert von Galde75 (07.02.2019 05:07:16)

Offline

#4 07.02.2019 20:13:58

dab895
Mitglied

Re: Monitor wird nicht erkannt

hallo,

die Grub Config war schon passend eingestellt.

das Hinzufügen von amdgpu  und  radeon hat keine Verbesserung gebracht.

xrandr gibt aus  -> cant open Display

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums