#1 13.01.2019 13:21:17

JanH
Mitglied

[gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

Hallo zusammen, ich packe der Thread hier mal ins Hardwareforum, weil ich das Problem hardwareseitig vermute. Wenn es nicht passt, bitte verschieben :-)

Als ich heute morgen den PC anschaltete empfing mich diese Fehlermeldung: https://www.janhacke.de/wp-content/uplo … 110107.jpg
Die relevanten Daten des PCs:
Desktop-PC
Festplatte /dev/sda 120 GB-SSD Luks-verschlüsselte Platte mit LVM.
Die SSD ist ca 2 Jahre alt
sda1: Boot
sda2 LVM: main/root und main/swap

eine zweite ssd wird von Win10 genutzt

Vor 3 Tagen hatte ich diese Fehlermeldung schon einmal. Weil ich einen Hardware-Defekt vermutete, hatte ich die zweite SSD mit Win10 gebootet und die Linux-SSD mit dem Program SSD-Z untersucht. Da wurden aber keine Fehler angezeigt. Lesen/Schreiben und SMART-Parameter. Als ich dann wieder Linux booten wollte ging alles wieder. (Ich hatte natürlich sofort ein Backup mittels DD in ein .gz- Archiv gemacht)

Jetzt trat das Problem wieder auf. Folgende Schritte habe ich heute unternommen:
Lubuntu-Live-DVD gebootet und versucht auf das LVM zuzugreifen:
Cryptsetup-Passwort wird angenommen.
Danach habe ich per pvscan lvscan und lvdisplay versucht auf Root zuzugreifen und mittels mount das volume zu mounten, aber seht selbst: https://www.janhacke.de/wp-content/uplo … 120210.jpg

Wie gesagt vermute ich einen Hardware-Schaden, weil das Problem unabhängig von Pacman-Updates auftritt. Als Das Problem zum ersten mal auftrat hatte ich direkt davor keine administrativen Sachen(wie z.B. Updates oder ähnliches) gemacht. Danach hatte ich ein Systemupdate gemacht und mehrfach neu gebootet, was funktionierte.

Vielleicht bin ich aber auch auf einer falschen Fährte, weil das Win-Diagnosetool SSD-z keinen Fehler findet? Was sagt ihr dazu?
Edit: Twitter-Links durch Links auf meinem Webspace ersetzt

Beitrag geändert von JanH (27.01.2019 19:46:58)

Offline

#2 13.01.2019 13:26:02

niemand
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

Gibt’s die Meldungen noch woanders zu sehen, als in einem der unsozialen Trackingnetzwerke? Idealerweise hier, als Text in Code-Tags?

Offline

#3 13.01.2019 14:07:08

frostschutz
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

Das Fallback-Image tut auch nicht?

Wenn du in die rootfs shell kommst, was sagen diese Befehle

cat /proc/cmdline
cat /proc/partitions
ls -l /dev/mapper

Wie sieht deine /etc/mkinitcpio.conf und /etc/lvm/lvm.conf aus?

edit: ich glaube auf deinem 2. bild hast du einfach das vgchange -a y vergessen?

Beitrag geändert von frostschutz (13.01.2019 14:14:06)

Online

#4 13.01.2019 14:35:14

JanH
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

@frostschutz: das vgchange -ay ist eine Spur, auf der ich auch gerade bin. Die beiden LVs waren inaktiv.
Wenn ich bei frühreren Problemen die LIVE-DVD gebootet habe und das LVM gebootet habe musste ich "vgchange -ay" nicht extra eingeben.

Nachdem ich /dev/sda2 mittels cryptsetup gebootet und per "apt install lvm2 lvm im Lve-System installiert habe, habe ich folgende Schritte gemacht:

root@lubuntu:/home/lubuntu# pvscan
  PV /dev/mapper/luks-2c5cd3c2-d3c7-454f-83e7-aaa11af9e4ed   VG main            lvm2 [118,74 GiB / 0    free]
  Total: 1 [118,74 GiB] / in use: 1 [118,74 GiB] / in no VG: 0 [0   ]
root@lubuntu:/home/lubuntu# lvscan
  inactive          '/dev/main/swap' [4,00 GiB] inherit
  inactive          '/dev/main/root' [114,74 GiB] inherit
root@lubuntu:/home/lubuntu# vgchange -ay
  2 logical volume(s) in volume group "main" now active
root@lubuntu:/home/lubuntu# lvscan
  ACTIVE            '/dev/main/swap' [4,00 GiB] inherit
  ACTIVE            '/dev/main/root' [114,74 GiB] inherit
root@lubuntu:/home/lubuntu# mount /dev/main/root /mnt
root@lubuntu:/home/lubuntu# ls /mnt
bin   dev  home  lib64       mnt  proc  run   srv  tmp  var
boot  etc  lib   lost+found  opt  root  sbin  sys  usr
root@lubuntu:/home/lubuntu#

jetzt kann ich auf die Dateien im Live-System zugreifen.

Das Problem ist, dass beim booten von Arch die beiden LVs wieder inaktiv werden. Nachdem ich rebootet habe tritt das Prob aber wieder auf.
Wie im ersten Post geschrieben, habe ich dierekt vor dem Problem weder Updates noch andere adminstrativen Sachen gemacht.

Da ich gerade auf das Root-Volume zugreifen kann, hier die /etc/mkinitcpio.conf und die /etc/lvm/lvm.conf:

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES="piix ide_disk reiserfs"
MODULES=""

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=""

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=""

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS="base"
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS="base udev autodetect block filesystems"
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS="base udev block filesystems"
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS="base udev block mdadm encrypt filesystems"
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS="base udev block lvm2 filesystems"
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap encrypt lvm2 filesystems fsck"

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=""

Die lvm.conf ist original, also nicht von  mir bearbeitet und zu groß, dass ich sie hier posten könnte. Wie kann ich die am Besten posten?

Beitrag geändert von JanH (13.01.2019 14:36:16)

Offline

#5 13.01.2019 14:44:48

JanH
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

Ich wollte eben in die rootfs-Shell, um die Befehle

cat /proc/cmdline
cat /proc/partitions
ls -l /dev/mapper

einzugeben. Jetzt konnte ich wieder Arch booten.
Das Problem tritt also sporadisch auf, was die Fehlersuche nicht leichter macht.

Offline

#6 21.01.2019 13:11:09

JanH
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

Hallo zusammen, das Problem besteht immer noch, ich konnte es etwas eingrenzen:
Das Starten der Archlinux-SSD gestaltet sich nach wie vor schwierig: Ich starte den PC und manchmal bootet Arch im ersten Anlauf, manchmal muss ich, wenn die emegency shell kommt, neu starten. 2 - 6 Anläufe brauche ich etwa. Das Problem tritt also sporadisch auf.
Ich hatte die SSD im Verdacht. Die Ausgabe von Smartctl bestätigte den Verdacht nicht(vielleicht übersah ich auch etwas?).

$ sudo smartctl --all /dev/sda
smartctl 7.0 2018-12-30 r4883 [x86_64-linux-4.20.3-arch1-1-ARCH] (local build)
Copyright (C) 2002-18, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Device Model:     ADATA SU800
Serial Number:    2H2020024195
LU WWN Device Id: 5 707c18 1004e3135
Firmware Version: Q0125A
User Capacity:    128.035.676.160 bytes [128 GB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    Solid State Device
Form Factor:      2.5 inches
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ACS-3 (minor revision not indicated)
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Mon Jan 21 10:03:04 2019 UTC
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status:  (0x00) Offline data collection activity
                                        was never started.
                                        Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0) The previous self-test routine completed
                                        without error or no self-test has ever 
                                        been run.
Total time to complete Offline 
data collection:                (    0) seconds.
Offline data collection
capabilities:                    (0x71) SMART execute Offline immediate.
                                        No Auto Offline data collection support.
                                        Suspend Offline collection upon new
                                        command.
                                        No Offline surface scan supported.
                                        Self-test supported.
                                        Conveyance Self-test supported.
                                        Selective Self-test supported.
SMART capabilities:            (0x0002) Does not save SMART data before
                                        entering power-saving mode.
                                        Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                        General Purpose Logging supported.
Short self-test routine 
recommended polling time:        (   2) minutes.
Extended self-test routine
recommended polling time:        (  10) minutes.
Conveyance self-test routine
recommended polling time:        (   2) minutes.
SCT capabilities:              (0x0035) SCT Status supported.
                                        SCT Feature Control supported.
                                        SCT Data Table supported.

SMART Attributes Data Structure revision number: 1
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x0000   100   100   000    Old_age   Offline      -       0
  5 Reallocated_Sector_Ct   0x0000   100   100   000    Old_age   Offline      -       0
  9 Power_On_Hours          0x0000   100   100   000    Old_age   Offline      -       1422
 12 Power_Cycle_Count       0x0000   100   100   000    Old_age   Offline      -       949
160 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       0
161 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       38
163 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       6
164 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       29446
165 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       116
166 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       12
167 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       58
148 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       51016
149 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       1526
150 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       1410
151 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       1500
168 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       1500
169 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       100
177 Wear_Leveling_Count     0x0000   100   100   050    Old_age   Offline      -       64
181 Program_Fail_Cnt_Total  0x0000   100   100   000    Old_age   Offline      -       0
182 Erase_Fail_Count_Total  0x0000   100   100   000    Old_age   Offline      -       0
187 Reported_Uncorrect      0x0000   100   100   000    Old_age   Offline      -       0
192 Power-Off_Retract_Count 0x0000   100   100   000    Old_age   Offline      -       56
194 Temperature_Celsius     0x0000   100   100   000    Old_age   Offline      -       28
196 Reallocated_Event_Count 0x0000   100   100   016    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0000   100   100   050    Old_age   Offline      -       1
225 Unknown_SSD_Attribute   0x0003   100   100   000    Pre-fail  Always       -       92356
232 Available_Reservd_Space 0x0000   100   100   000    Old_age   Offline      -       100
241 Total_LBAs_Written      0x0000   100   100   000    Old_age   Offline      -       92356
242 Total_LBAs_Read         0x0000   100   100   000    Old_age   Offline      -       89850
245 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       235568

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
    6        0    65535  Read_scanning was never started
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

Ich hatte aber trotzdem eine baugleiche SSD bestellt und hatte diese in eine USB-Docking-Station eingesteckt. Ich bootete Lubuntu und wollte die eingabaute SSD mittels "dd if=/dev/sda of=dev/sdi" spiegeln. Der Prozess hing sich nach einer Zeit auf. Ich konzentrierte mich auf die neue SSD, ob diese defekt wäre. Ich formatierte sie mit ext4 und ntfs, doch der Formatierungsprozess schlug fehl. Die Ausgabe von smartctl brachte mich auf eine Spur:

$ sudo smartctl --all /dev/sdi
smartctl 7.0 2018-12-30 r4883 [x86_64-linux-4.20.3-arch1-1-ARCH] (local build)
Copyright (C) 2002-18, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Device Model:     ADATA SU800
Serial Number:    2H2920074685
LU WWN Device Id: 5 707c18 10054e186
Firmware Version: Q0518BS
User Capacity:    128.035.676.160 bytes [128 GB]
Sector Size:      512 bytes logical/physical
Rotation Rate:    Solid State Device
Form Factor:      2.5 inches
Device is:        Not in smartctl database [for details use: -P showall]
ATA Version is:   ACS-3 (minor revision not indicated)
SATA Version is:  SATA 3.1, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Mon Jan 21 10:04:53 2019 UTC
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART Status not supported: Incomplete response, ATA output registers missing
SMART overall-health self-assessment test result: PASSED
Warning: This result is based on an Attribute check.

General SMART Values:
Offline data collection status:  (0x00) Offline data collection activity
                                        was never started.
                                        Auto Offline Data Collection: Disabled.
Self-test execution status:      (   0) The previous self-test routine completed
                                        without error or no self-test has ever 
                                        been run.
Total time to complete Offline 
data collection:                (    0) seconds.
Offline data collection
capabilities:                    (0x71) SMART execute Offline immediate.
                                        No Auto Offline data collection support.
                                        Suspend Offline collection upon new
                                        command.
                                        No Offline surface scan supported.
                                        Self-test supported.
                                        Conveyance Self-test supported.
                                        Selective Self-test supported.
SMART capabilities:            (0x0002) Does not save SMART data before
                                        entering power-saving mode.
                                        Supports SMART auto save timer.
Error logging capability:        (0x01) Error logging supported.
                                        General Purpose Logging supported.
Short self-test routine 
recommended polling time:        (   2) minutes.
Extended self-test routine
recommended polling time:        (  10) minutes.
Conveyance self-test routine
recommended polling time:        (   2) minutes.
SCT capabilities:              (0x003d) SCT Status supported.
                                        SCT Error Recovery Control supported.
                                        SCT Feature Control supported.
                                        SCT Data Table supported.

SMART Attributes Data Structure revision number: 1
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x0000   100   100   000    Old_age   Offline      -       0
  5 Reallocated_Sector_Ct   0x0000   100   100   000    Old_age   Offline      -       0
  9 Power_On_Hours          0x0000   100   100   000    Old_age   Offline      -       12
 12 Power_Cycle_Count       0x0000   100   100   000    Old_age   Offline      -       13
160 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       0
161 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       35
163 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       10
164 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       5620
165 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       18
166 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       5
167 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       11
148 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       2111
149 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       84
150 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       1
151 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       62
159 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       0
168 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       1500
169 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       100
177 Wear_Leveling_Count     0x0000   100   100   050    Old_age   Offline      -       0
181 Program_Fail_Cnt_Total  0x0000   100   100   000    Old_age   Offline      -       0
182 Erase_Fail_Count_Total  0x0000   100   100   000    Old_age   Offline      -       0
192 Power-Off_Retract_Count 0x0000   100   100   000    Old_age   Offline      -       6
194 Temperature_Celsius     0x0000   100   100   000    Old_age   Offline      -       49
195 Hardware_ECC_Recovered  0x0000   100   100   000    Old_age   Offline      -       117
196 Reallocated_Event_Count 0x0000   100   100   016    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0000   100   100   050    Old_age   Offline      -       930
232 Available_Reservd_Space 0x0000   100   100   000    Old_age   Offline      -       100
241 Total_LBAs_Written      0x0000   100   100   000    Old_age   Offline      -       12652
242 Total_LBAs_Read         0x0000   100   100   000    Old_age   Offline      -       7993
245 Unknown_Attribute       0x0000   100   100   000    Old_age   Offline      -       50580

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
No self-tests have been logged.  [To run self-tests, use: smartctl -t]

SMART Selective self-test log data structure revision number 1
 SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
    1        0        0  Not_testing
    2        0        0  Not_testing
    3        0        0  Not_testing
    4        0        0  Not_testing
    5        0        0  Not_testing
    6        0    65535  Read_scanning was never started
Selective self-test flags (0x0):
  After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.
199 UDMA_CRC_Error_Count    0x0000   100   100   050    Old_age   Offline      -       930

Der hohe Wert von knapp 1000 besagt laut Internet dass ein Kabel oder der Cotroller defekt sein kann. Ich steckte die neue SSD im PC-Gehäuse anstelle einer HDD, dort wurde die SSD noch nicht einmal im BIOS erkannt.
Ich steckte die SSD wieder in die USB-Dockingstation und schloss sie an ein Laptop an, wo die SSD mittels

sudo shred -vn 1 /dev/sdc

mit Zufallszahlen beschrieben wurde. Das Funktionierte tadellos.

Da im PC mit der Daten-HDD und der Win10-m.2-SSD keine Probleme auftauchen vermute ich direkt ein Problem mit den Controller, dass er defekt ist und ein spezielles Problem mit 2,5-Zoll SSDs hat. Meine Frage an euch ist: liegt meine Vermutung richtig, oder bin ich auf dem Holzweg?
Wie kann ich den Festplatten-Controller auf Herz und Nieren prüfen?(Kabel habe ich testweise getauscht)

Offline

#7 24.01.2019 10:58:09

JanH
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

Gestern Lief der PC ohne Probleme. Ich hatte mich heute noch einmal dem PC angenommen, nachdem beim verschiedenen Bootvorgängen plötzlich andere Fehlermeldungen auftauchten:

[failed] Failed to mount /boot
unbekannter Dateisystemtyp vfat

oder auch:

/bin/plymouth missing

Ich hatte die alte SSD abgeklemmt und die neue angehängt, um ein neues Archlinux darauf zu installieren. Ich bootete von der "Arch 2018.11.01"-DVD und begann nach dieser Anleitung die SSD vorzubereiten: https://legacy.thomas-leister.de/arch-l … llieren-2/
Nachdem wieder verschiedene Fehlermeldungen auftauchten, die alle mit der SSD zu tun hatten(frisch formatiert und dann bei der nächsten Eingabe "wrong fs type" oder "resource busy", habe ich den Installtionsvorgang abgebrochen.

Wie gesagt, Kabel wurden getauscht und die SSDs wurden an verschiedenen Steckplätzen und auch per USB angeschlossen.

Jetzt die Frage: welche Komponente muss ich tauschen, damit ich den Festplattencontroller tausche. Etwa das ganze Board? Oder habt ihr andere Ideen?

Beitrag geändert von JanH (24.01.2019 10:58:44)

Offline

#8 24.01.2019 16:10:00

GerBra
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

JanH schrieb:

Wie gesagt, Kabel wurden getauscht und die SSDs wurden an verschiedenen Steckplätzen und auch per USB angeschlossen.

Jetzt die Frage: welche Komponente muss ich tauschen, damit ich den Festplattencontroller tausche. Etwa das ganze Board? Oder habt ihr andere Ideen?

Ohne jetzt alles verfolgt zu haben:
Ich meine, wenn es ein **Onboard-Controller** ist, dann bleiben ja nur die Möglichkeiten Mainboard tauschen oder externen neuen Controller kaufen/einbauen (und den Onboard stilllegen->BIOS)

Du könntest testweise auch mal einen anderen Kernel probieren, der linux-lts bietet sich unter Archlinux dafür an. Es köönte ja auch eine Treiber/Modul-Softwaregeschichte mit dem aktuellen Default-Kernel sein. Oder auch mal andere Boot/Live-Medien mit anderen Kernelversionen austesten. Wenn es dort auch Probleme gibt - unabhängig der Kernelversion - dann spricht nochmehr für einen Hardwaredefekt.

Offline

#9 26.01.2019 20:45:20

JanH
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

@GerBra die Probleme traten auch mit verschiedenen Live-CDs und Live-DVDs auf(Lubuntu17.04 und Arch 2018.11.01

Derjenige, der den PC zusammengestellt hat(und dies auch beruflich tut) meinte, dass ich den RAM-Speicher prüfen solle. <- Test verlief mit der Arch-Live-CD fehlerfrei

Ich habe an einer Sata-Controller-Karte das DVD-Laufwerk und eine neue SSD angeschlossen, um darauf Arch zu installieren, was auch problemlos klappte. Alles, was am Board direkt war habe ich abgeklemmt. <- was die Theorie vom defekten-Board-Festplattencontroller bestätigt.

Mit dem neuen Arch und auch der Lubuntu-DVD(beide an der Controllerkarte)  habe ich dann Kopierversuche mit anderen USB-Platten unternommen. Da fror der Kopierprozess auch ein<- also hat die USB-Geschichte auch einen Defekt.

Ich werde wohl nicht um ein neues Board drumrum kommen

Offline

#10 26.01.2019 22:13:32

GerBra
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

JanH schrieb:

...
also hat die USB-Geschichte auch einen Defekt.
Ich werde wohl nicht um ein neues Board drumrum kommen

Kann sein. Das ist halt eine teils eklige Geschichte, da es u.U. ja auch eine defekte CPU sein könnte (gerade wenn noch unreproduzierbare Abstürze hinzukommen würden). Dann ist oft guter Rate teuer (im wörtlichen Sinn <g>): kaufe ich ein neues Mainboard und es war dann doch die CPU? Oder umgekehrt? Gerade MBs oder CPUs hat man ja nun nicht gerade "passend" zum Gegentesten im Regal rumliegen...

Warum ich das jetzt noch schreibe: Ich bin wahrlich kein Experte in Hardware, was mir aber sehr oft untergekommen ist sind Probleme bei etwas älteren (manchmal auch "junge") PCs die als Ursache das Netzteil hatten - mit teils kuriosesten Auswirkungen.
Netzteile sind oftmals die billigste Komponente, die man tauschen kann, v.a. wenn es zum Mainboard keine kostenadäquate CPU mehr gibt oder umgekehrt. Ich habe immer 1, 2 Netzteile rumliegen um so einen Fall kostengünstig austesten zu können. Und oftmals reichte dann wirklich ein neues Netzteil, da halt bestimmte Komponenten des Rechners nicht mehr zuverläsig mit den Spannungen versorgt wurden.
Evtl. hast du ja auch noch eines, oder kannst dir eines ausborgen (Freunde,PC-Geschäft,etc.). Auch vom handwerklichen Aufwand ist so ein Test ja schnell erledigt ohne große Aus-/Umbau-Aktionen.

Viel Glück auf jeden Fall...

Offline

#11 27.01.2019 12:05:20

Galde75
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

Hab jetzt nicht komplett alles durchgelesen...

Hast Du mal einfache Problemlösung versucht? SATA Kabel tauschen zB?
Die sind durchaus bekannt mal Probleme zu machen wenn sie zu billig sind oder zu alt werden. Oder starke Störquellen wie Motoren, Funktelefone, Trafos usw in der Nähe sind.
Auch gibt es einige SATA-Controller die gerne mal Probleme machen (Die alten Asmedia beispielsweise).

Offline

#12 27.01.2019 19:46:22

JanH
Mitglied

Re: [gelöst]Luks-verschlüsselte Platte mit LVM startet nicht mehr

Ein Speicherriegel war der Verursacher: Mir wurde geraten, die Speicherriegel einzeln auszubauen und das Kopieren von USB-Platte zu USB-Platte, was ja auch  schief ging, zu reproduzieren. Bei einem ausgebauten Riegel ging das Kopieren dann.
Ich tauschte die Riegel und dann ging gar nichts mehr. <- also war der zuerst ausgebaute Riegel defekt.
Da das Kopieren jetzt funktioniert und auch das Betriebssystem bootet, denke ich dass der Fehler gefunden wurde. Danke für die Hilfestellung.

Beitrag geändert von JanH (31.01.2019 22:52:35)

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums