#1 08.01.2019 21:49:44

floyd423
Gast

Update nicht möglich: Paket-Defekte und Abhängigkeiten. Hilfe.

Hi Leute,
Mein Laptop hat's schon schlimm erwischt (KDE komplett zerlegt, irgendwas mit icu, muss wahrscheinlich neu aufgesetzt werden. Ich hab den Überblick verloren...), jetzt auch noch meinen Stand-PC.
Wenn ich ein Update machen will, kommt immer folgende Meldung:


Fehler: ncurses: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/ncurses-6.1-4-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: krb5: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/krb5-1.16.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: libtiff: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/libtiff-4.0.10-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: libcap-ng: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/libcap-ng-0.7.9-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: audit: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/audit-2.8.4-2-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: libpsl: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/libpsl-0.20.2-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: jre8-openjdk-headless: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/jre8-openjdk-headless-8.u192-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: jre8-openjdk: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/jre8-openjdk-8.u192-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: jdk8-openjdk: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/jdk8-openjdk-8.u192-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: ant: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/ant-1.10.5-1-any.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: autoconf-archive: signature from "Eli Schwartz <eschwartz@archlinux.org>" is unknown trust
:: Datei /var/cache/pacman/pkg/autoconf-archive-1:2019.01.06-1-any.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: clamav: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/clamav-0.101.0-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: ctags: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/ctags-1:r20181015+g45968eff-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: patch: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/patch-2.7.6-7-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: exfat-utils: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/exfat-utils-1.3.0-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: libgexiv2: signature from "Eli Schwartz <eschwartz@archlinux.org>" is unknown trust
:: Datei /var/cache/pacman/pkg/libgexiv2-0.10.8-2-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: mypaint-brushes: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/mypaint-brushes-1.3.0-3-any.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: lua52: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/lua52-5.2.4-3-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: ruby-yard: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/ruby-yard-0.9.14-1-any.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: lib32-libgpg-error: signature from "Eli Schwartz <eschwartz@archlinux.org>" is unknown trust
:: Datei /var/cache/pacman/pkg/lib32-libgpg-error-1.32-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: lib32-pcre: signature from "Eli Schwartz <eschwartz@archlinux.org>" is unknown trust
:: Datei /var/cache/pacman/pkg/lib32-pcre-8.42-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: lib32-ncurses: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/lib32-ncurses-6.1-3-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: lib32-lz4: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/lib32-lz4-1.8.3-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: lib32-zstd: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/lib32-zstd-1.3.7-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: lib32-libtiff: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/lib32-libtiff-4.0.10-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: lib32-libice: signature from "Eli Schwartz <eschwartz@archlinux.org>" is unknown trust
:: Datei /var/cache/pacman/pkg/lib32-libice-1.0.9-3-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: lib32-libvorbis: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/lib32-libvorbis-1.3.6-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: libdvbpsi: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/libdvbpsi-1:1.3.2-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: libupnp: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/libupnp-1.6.25-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: cabextract: signature from "Alad Wenter <alad@mailbox.org>" is unknown trust
:: Datei /var/cache/pacman/pkg/cabextract-1.9-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: steam: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/steam-1.0.0.56-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: aribb24: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/aribb24-1.0.3-2-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: vlc: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/vlc-3.0.4-7-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: wget: signature from "Levente Polyak (anthraxx) <levente@leventepolyak.net>" is unknown trust
:: Datei /var/cache/pacman/pkg/wget-1.20.1-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
Soll die Datei entfernt werden? [J/n] 
Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

Außerdem kommt bei meinem Stand-PC zusätzlich (also wenn man nicht die Abhängigkeitsüberprüfung mit -d überspringt)  ein gigantisches Abhängigkeitsproblem:

Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: ffmpeg2.8: das Entfernen von libx264 verletzt Abhängigkeit von 'libx264.so=152-64'
:: ffmpeg2.8: das Installieren von x265 (2.9-1) verletzt Abhängigkeit von 'libx265.so=146-64'
:: libxfont: das Entfernen von fontsproto verletzt Abhängigkeit von 'fontsproto>=2.1.3'

Ich bin grad irgendwie hilflos. Wenn mein Stand-PC jetzt auch noch abschmiert, hab ich echt Probleme.
Sowas hatte ich vorher noch nie mit Arch Linux. Ist es bei euch ähnlich?

Danke im Vorraus.

#2 08.01.2019 22:02:22

schard
Moderator

Re: Update nicht möglich: Paket-Defekte und Abhängigkeiten. Hilfe.

Nein, das ist bei den meisten wohl nicht ähnlich, da sie regelmäßig updaten.
Der ausgediente Keyring und die uralten Fehler mit ffmpeg2.8 und libxfont sind Asbach uralt.
Die Forensuche  löst all deine Probleme.

Offline

#3 08.01.2019 22:12:21

floyd423
Gast

Re: Update nicht möglich: Paket-Defekte und Abhängigkeiten. Hilfe.

Ich gebe zu, dieser Stand-PC ist lag einige Zeit auf Eis. Als Backup. Der Laptop allerdings, war brandaktuell. Nach dem Update hatte ich den selben Fehler wie man ihn oben sieht. Ich habe mich bereits auf anderen Seiten umgeschaut. Vielleicht war ich etwas zu hektisch. Ich setz mich am Wochenende mal dran und nutz bis dahin den veralteten Rechner, der noch läuft.
Danke.

#4 08.01.2019 22:51:56

Ailae5ec
Gast

Re: Update nicht möglich: Paket-Defekte und Abhängigkeiten. Hilfe.

(1) führe vor dem Systemupdate "pacman -S archlinux-keyring" aus, um die aktuellen Signaturen zu installieren, und
(2) entferne das Paket ffmpeg2.8, da es sich nicht mehr in den aktuellen Paketquellen befindet und im Konflikt mit den aktuellen Versionen von libx264 und x265 steht

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums