Du bist nicht angemeldet.

#26 07.01.2019 10:21:39

schard
Moderator

Re: [gelöst] Fehlermeldung bei "sudo -i"

Welche Shell hat der Benutzer root und welche Shell hat der Benutzer, mit welchem du sudo -i ausführst?
Was passiert bei sudo -s?

Offline

#27 07.01.2019 13:56:24

HansHiasl
Mitglied

Re: [gelöst] Fehlermeldung bei "sudo -i"

Hallo schard

Ich hab jetzt viel im Netz gesucht. Ich habe herausgefunden, dass dieses Verhalten normal zu sein scheint.
https://superuser.com/questions/453988/ … out-hyphen

Warum es bei anderen Usern nicht so ist? Gute Frage.

Ich versuch jetzt mal, das ganze ganz einfach zu umgehen.
https://wiki.archlinux.org/index.php/Su

"You may wish to add an alias to ~/.bashrc for this:"
alias su="su -l"

Bericht heute abend.

Ich denke, wir sollten es dabei belassen.

Offline

#28 07.01.2019 17:10:58

k.osmo
Mitglied

Re: [gelöst] Fehlermeldung bei "sudo -i"

Hallo HansHiasl,

wozu benötigst Du die Gruppenzugehörigkeit "audio" bzw. "power"? Falls die nur "auf Verdacht" bestehen, mal entfernen und prüfen, ob's einen Unterschied macht. Siehe:

There are some notable exceptions which require adding a user to some of these groups: for example if you want to allow users to access the device even when they are not logged in. However, note that adding users to the groups can even cause some functionality to break (for example, the audio group will break fast user switching and allows applications to block software mixing).

Users_and_groups#Pre-systemd_groups

Gruß, k.osmo

Offline

#29 07.01.2019 18:02:50

HansHiasl
Mitglied

Re: [gelöst] Fehlermeldung bei "sudo -i"

Hallo k.osmo

Die Herkunft der Gruppenzugehörigkeit zu audio und power kenn ich nicht.
Hab sie entfernt. Mal sehen, ob was nicht mehr funktioniert. Bisher nichts festgestellt.

su mit dem Alias in der .bashrc funktioniert.
Keine Fehlermeldung mehr.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums