#1 20.12.2018 14:34:08

J4son
Mitglied

[gelöst] Doppelte Verbindung via Wlan zum gleichen Router

Hallo zusammen,

ich komme leider mit eigener Suche nach der Fehlerquelle nicht weiter. Mein Arch verbindet sich irgendwie immer doppelt zu meinem Router.
Bei der FritzBox war das bisher kein Problem, der neue Router "zickt da jedoch etwas rum" und ich bekomme keine dauerhafte Verbindung mit
folgender Fehlermeldung:

[  566.968297] wlp2s0: Connection to AP 2c:58:4f:97:57:45 lost
[  571.355307] wlp2s0: aborting authentication with 2c:58:4f:97:57:45 by local choice (Reason: 3=DEAUTH_LEAVING)

Wenn ich z.B. bei meinem alten Router die Wifi Verbindung anzeigen lassen bekomme ich das hier:

    inet 192.168.43.209/24 brd 192.168.43.255 scope global dynamic noprefixroute wlp2s0
       valid_lft 3506sec preferred_lft 3506sec
    inet 192.168.43.210/24 brd 192.168.43.255 scope global secondary noprefixroute wlp2s0
       valid_lft forever preferred_lft forever 

Die 192.168.43.209 ist die IP welche über die Verbindung mit dem NetworkManager zustande komment. Bei der .210 habe ich keine Ahnung durch
welchen Dienst diese kommt.

Ich habe versucht raus zu finden ob ein 2. Dient läuft, jedoch kann ich hier in den Outputs nicht finden:

systemctl list-unit-files --state=enabled
systemctl list-units | grep -iE '(net|dhcp|wpa|conn|wicd)'
UNIT FILE                                   STATE  
org.cups.cupsd.path                         enabled
autovt@.service                             enabled
bumblebeed.service                          enabled
cronie.service                              enabled
dbus-org.freedesktop.NetworkManager.service enabled
dbus-org.freedesktop.nm-dispatcher.service  enabled
dhcpcd.service                              enabled
display-manager.service                     enabled
getty@.service                              enabled
lightdm-plymouth.service                    enabled
NetworkManager-dispatcher.service           enabled
NetworkManager-wait-online.service          enabled
NetworkManager.service                      enabled
org.cups.cupsd.service                      enabled
teamviewerd.service                         enabled
org.cups.cupsd.socket                       enabled
remote-fs.target                            enabled
  sys-devices-pci0000:00-0000:00:1c.0-0000:02:00.0-net-wlp2s0.device                          loaded active plugged   Wireless 7260 (Dual Band Wireless-AC 7260)                                   
  sys-devices-pci0000:00-0000:00:1c.4-0000:03:00.0-net-enp3s0.device                          loaded active plugged   RTL810xE PCI Express Fast Ethernet controller                                
  sys-devices-virtual-net-tun0.device                                                         loaded active plugged   /sys/devices/virtual/net/tun0                                                
  sys-subsystem-net-devices-enp3s0.device                                                     loaded active plugged   RTL810xE PCI Express Fast Ethernet controller                                
  sys-subsystem-net-devices-tun0.device                                                       loaded active plugged   /sys/subsystem/net/devices/tun0                                              
  sys-subsystem-net-devices-wlp2s0.device                                                     loaded active plugged   Wireless 7260 (Dual Band Wireless-AC 7260)                                   
  sys-fs-fuse-connections.mount                                                               loaded active mounted   FUSE Control File System                                                     
  dhcpcd.service                                                                              loaded active running   dhcpcd on all interfaces                                                     
  NetworkManager-wait-online.service                                                          loaded active exited    Network Manager Wait Online                                                  
  NetworkManager.service                                                                      loaded active running   Network Manager                                                              
  wpa_supplicant.service                                                                      loaded active running   WPA supplicant                                                               
  network-online.target                                                                       loaded active active    Network is Online                                                            
  network.target                                                                              loaded active active    Network          

Was übersehe ich?

Beitrag geändert von J4son (20.12.2018 16:27:23)

Offline

#2 20.12.2018 14:37:26

schard
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

J4son schrieb:
dhcpcd.service                              enabled
NetworkManager.service                      enabled

Was übersehe ich?

Viele Köche verderben den Brei.

Offline

#3 20.12.2018 14:53:20

J4son
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

Hm, dhcpcd.service disabled...rebootet und es werden immer noch 2 Verbindungen aufgebaut sad

Offline

#4 20.12.2018 14:58:52

schard
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

Wie sieht denn deine Netzwerkkonfiguration im NetworkManager aus?
Die findest du übrigens unter dem entsprechenden Namen in

/etc/NetworkManager/system-connections/

Offline

#5 20.12.2018 15:06:17

J4son
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

Danke erst mal dass du dir die Zeit nimmst um mir zu helfen!

Hier die aktuell aktive Connection:

[connection]
id=Automatisch AndroidAP9286
uuid=bd376678-2175-4868-af2d-48ad2bf2bf2d
type=wifi
permissions=

[wifi]
mac-address=80:86:F2:AE:5F:D8
mac-address-blacklist=
mode=infrastructure
ssid=AndroidAP9286

[wifi-security]
auth-alg=open
key-mgmt=wpa-psk
psk=meinwlanpasswort

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto 

Offline

#6 20.12.2018 15:28:01

schard
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

Was passiert denn, wenn du diese Verbindung ausschaltest, bzw. Mal auch den NetworkManager deaktivierst und neu startest?
Wenn dann keine IP Adresse mehr auftaucht, ist definitiv der NetworkManager bzw. der DHCP Server die Ursache.
Eventuell schau Mal in deiner FritzBox, ob diese womöglich zwei DHCP Leases an die MAC Addresse deines Rechners vergibt.

Offline

#7 20.12.2018 16:26:51

J4son
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

Ok ich markiere den Thread mal als "gelöst".

Ich kann zwar den Grund warum es nicht funktioniert hat genauso wenig nachvollziehen wie die "Lösung" dafür...

Ich hab einfach mal in /etc/NetworkManager/system-connections/ die Config Dateien von "'Automatisch Netzwerkname'" auf "Netzwerkname"
geändert und neu gestartet. Jetzt verbindet der NetworkManager zwar beim ersten Versuch nicht. Aber beim zweiten Versuch kommt dann die
Verbindung.

Und es wird auch nur eine Verbindung aufgebaut... Keine Ahnung warum aber es reicht mir solange es funktioniert.

Danke jedenfalls für deine Hilfe!

Offline

#8 20.12.2018 20:10:13

drcux
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

Naja, gelöst ist schon ein wenig geschönt.... :-D

Verschiebe doch mal alles aus /etc/NetworkManager/system-connections/ nach zB /root/NW:

# systemctl stop NetworkManager.service
# mkdir /root/NW
# mv /etc/NetworkManager/system-connections/* /root/NW
# systemctl start NetworkManager.service

Dann die Verbindung neu aufbauen und schauen, ob der "*#+§" wieder zweimal verbindet....

PS: Achja, und immer das Journal im Auge behalten. Mich würde schon interessieren, warum der Dummvogel zweimal verbinden will.... ;-)

Beitrag geändert von drcux (20.12.2018 20:13:05)

Offline

#9 21.12.2018 10:28:25

J4son
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

Ich weiß dass "gelöst" etwas geschönt ist.

Das waren anscheinend zwei Probleme die ich da hatte:

1. Problem dhcpcd.service und NetworkManager.service...da durch kam es zur doppelten Verbindung.

Ich habe dann zeitweise den dhcpcd nicht nur deaktiviert sondern auch gelöscht (inkl. aller config files und "Dateileichen")

2. Problem und das ist nach wie vor vorhanden

Der NetworkManager zickt ab und zu etwas. Wenn ich zwischen Wlan Netzwerken in einer Sitzung wechsle kann kommt es ab
und an zu Problemen beim ersten Verbindungsaufbau. Passwörter etc. stimmen und ich finde auch in den logs keine Hilfreichen
Fehlermeldungen. Alles was da drin steht sieht so aus:

Dez 21 09:25:09 arch-dell wpa_supplicant[917]: wlp2s0: SME: Trying to authenticate with d4:ab:82:31:7c:7d (SSID='Homenet' freq=5240 MHz)
Dez 21 09:25:09 arch-dell kernel: wlp2s0: authenticate with d4:ab:82:31:7c:7d
Dez 21 09:25:09 arch-dell kernel: wlp2s0: send auth to d4:ab:82:31:7c:7d (try 1/3)
Dez 21 09:25:09 arch-dell kernel: wlp2s0: authenticated
Dez 21 09:25:09 arch-dell NetworkManager[714]: <info>  [1545380709.5674] device (wlp2s0): supplicant interface state: scanning -> authenticating
Dez 21 09:25:10 arch-dell kernel: iwlwifi 0000:02:00.0: No beacon heard and the time event is over already...
Dez 21 09:25:10 arch-dell kernel: wlp2s0: Connection to AP d4:ab:82:31:7c:7d lost
Dez 21 09:25:14 arch-dell NetworkManager[714]: <warn>  [1545380714.4022] device (wlp2s0): Activation: (wifi) association took too long, failing activation
Dez 21 09:25:14 arch-dell NetworkManager[714]: <info>  [1545380714.4022] device (wlp2s0): state change: config -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
Dez 21 09:25:14 arch-dell NetworkManager[714]: <info>  [1545380714.4027] manager: NetworkManager state is now CONNECTED_LOCAL
Dez 21 09:25:14 arch-dell kernel: wlp2s0: aborting authentication with d4:ab:82:31:7c:7d by local choice (Reason: 3=DEAUTH_LEAVING)
Dez 21 09:25:14 arch-dell wpa_supplicant[917]: wlp2s0: CTRL-EVENT-DISCONNECTED bssid=d4:ab:82:31:7c:7d reason=3 locally_generated=1
Dez 21 09:25:14 arch-dell NetworkManager[714]: <warn>  [1545380714.4054] device (wlp2s0): Activation: failed for connection 'Homenet'
Dez 21 09:25:14 arch-dell NetworkManager[714]: <warn>  [1545380714.4055] sup-iface[0x55ba249f1390,wlp2s0]: connection disconnected (reason -3)
Dez 21 09:25:14 arch-dell NetworkManager[714]: <info>  [1545380714.4057] device (wlp2s0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Dez 21 09:25:14 arch-dell kernel: IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
Dez 21 09:25:14 arch-dell NetworkManager[714]: <info>  [1545380714.4072] device (wlp2s0): set-hw-addr: set MAC address to DA:76:F9:7A:DC:99 (scanning)
Dez 21 09:25:14 arch-dell NetworkManager[714]: <info>  [1545380714.4091] device (wlp2s0): supplicant interface state: authenticating -> disconnected
Dez 21 09:25:14 arch-dell kernel: IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
Dez 21 09:25:14 arch-dell NetworkManager[714]: <info>  [1545380714.4140] device (wlp2s0): supplicant interface state: disconnected -> disabled
Dez 21 09:25:14 arch-dell NetworkManager[714]: <info>  [1545380714.4564] device (wlp2s0): supplicant interface state: disabled -> disconnected

Nach ein paar Versuchen zu verbinden klappt es dann aber. Keine Ahnung woran das liegt. Bei Neustart des Rechners klappt es aber ohne Probleme.

Offline

#10 22.12.2018 12:50:34

drcux
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

Zum iwlwifi tauchen immer mal wieder Bugreports zu ähnlichen Symtomen/Fehlermeldungen auf. Du könntest mal den LTS-Kernel testen oder die Kernel-Firmware downgraden, aber ob es hilft....

Offline

#11 02.01.2019 19:58:41

J4son
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

drcux schrieb:

Zum iwlwifi tauchen immer mal wieder Bugreports zu ähnlichen Symtomen/Fehlermeldungen auf. Du könntest mal den LTS-Kernel testen oder die Kernel-Firmware downgraden, aber ob es hilft....

Es scheint wohl wirklich am iwlwifi gelegen haben. Seit heute läuft auf meinem "großen" Laptop die Kernel Version 4.20.0 und damit sind die Verbindungsprobleme welche ich zum Schluss hatte nicht mehr vorhanden.

Ein Versuch sich zu einem Wlan Netzwerk zu verbinden klappt beim ersten mal...jedes Mal. smile

Beitrag geändert von J4son (02.01.2019 19:59:23)

Offline

#12 02.01.2019 22:48:01

drcux
Mitglied

Re: [gelöst] Doppelte Verbindung via Wlan zum gleichen Router

Na, das ist doch mal nen guter Start ins neue Jahr! big_smile

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums