#1 24.12.2018 22:55:54

DanielS
Gast

Grub2 findet normal.mod nicht

Hallo,

ich habe von Knoppix aus mit DD ein 1:1 Abbild des gesamten Systemlaufwerks auf eine externe platte erstellt. nach Deaktivierung des SATA Controller im BIOS habe ich versucht, von der externen Platte zu booten.

GRUB hängt hierbei mit der Fehlermeldung /boot/grub/i386-pc/normal.mod not found und öffnet die Rescue-Konsole.

ls zeigt (hd0) und (hd0,msdos1) an.

ls (hd0,1)/boot zeigt nur ein leeres Verzeichnis an. Vom Livesystem betrachtet sind allerdings Grub, Kernel usw. im Verzeichnis enthalten.

Ich habe zum Test einen Ordner boot2 erstellt und den Inhalt von boot hineinkopiert. Danach konnte ich von der Rescue-Konsole aus das System über das Verzeichnis boot2 starten:
set prefix=(hd0,1)/boot2/grub
set root=(hd0,1)
insmod normal
insmod linux
linux /boot2/vmlinux...
initrd /boot2/initrd...
boot

Neukonfiguration und Neuinstallation von Grub aus dem dann laufenden System brachten keine Änderung. boot wird von der Rescue Konsole aus immer leer angezeigt. Auch wenn ich boot lösche und boot2 zu boot umbenenne, wird der Inhalt nicht erkannt. Die Inhalte anderer Verzeichnisse werden dagegen problemlos erkannt.

Das System ist ein alter i5 mit H55DE3. UEFI usw. sind nicht im Einsatz.

Von einem Lenovo T61 bootet das System einwandfrei!

Mit weihnachtlichen Grüßen
Daniel

#2 25.12.2018 12:54:22

stefanhusmann
Moderator

Re: Grub2 findet normal.mod nicht

Ist /boot eine eigene Partition? Wird das Verzeichnis vielleicht durch einen Mountvorgang überblendet?

Offline

#3 25.12.2018 16:42:39

DanielS
Gast

Re: Grub2 findet normal.mod nicht

Hallo,

könnte grub etwas über ein bestehendes /boot mounten und somit den Inhalt verstecken?

Laut gparted gibt es nur eine einzige, 250GB große EXT4-Partition. /boot ist direkt in dieser Partition und wurde zuletzt manuell mit mkdir erstellt. Wenn ich diese Partition unter dem laufenden Arch oder unter Knoppix mounte, sehe ich /boot mit Inhalt ganz normal.

Das fragliche System bootet am, Lenovo Thinkpad auch ganz normal!

Ich dachte, dass evtl. das BIOS des H55DE3 keinen Zugriff auf Daten hinter einer gewissen Grenze von z.B. 2GB sehen kann. Dann dürfte aber auch der manuelle Bootvorgang aus /boot2 heraus nicht funktionieren.

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums