#1 25.10.2018 10:26:34

The_H4nZ
Mitglied

Audioprobleme: nur Kopfhörer und keine Lautstärkeregelung

Hallo zusammen!

Ich habe seit einiger Zeit Probleme mit meiner Audioausgabe. Es funktioniert nur noch die Ausgabe über die 3,5mm Klinke und ich kann keine Lautstärke mehr ändern.
Leider ist das gesamte Audiosystem ein großes Rätsel für mich, da Ich das System vor ~2 Jahren unter Anleitung eingerichtet habe und immer alles funktionierte.
Ich weiß immerhin, dass unter Anderem pasystray verwendet wird. Dort wird allerdings kein sink, keine source und kein server gefunden.

Wenn ich beispielsweise die Lautstärke mit

pactl set-sink-volume 0 +5%

ändern will, kommt

Verbindungsfehler: Verbindung verweigert
pa_context_new() fehlgeschlagen: Verbindung verweigert

Hat jemand eine Idee oder einen Hinweis wie ich das Problem lösen kann?


Vielen Dank schon mal!
~Hannes

Edit: Ein Paar Infos zum System:

                   -`                     
                  .o+`                   ---------------- 
                 `ooo/                   OS: Arch Linux x86_64 
                `+oooo:                  Host: Aspire VN7-592G V1.12 
               `+oooooo:                 Kernel: 4.18.16-arch1-1-ARCH 
               -+oooooo+:                Uptime: 49 mins 
             `/:-:++oooo+:               Packages: 1486 (pacman) 
            `/++++/+++++++:              Shell: zsh 5.6.2 
           `/++++++++++++++:             Resolution: 1920x1080, 1920x1080 
          `/+++ooooooooooooo/`           WM: i3 
         ./ooosssso++osssssso+`          Theme: Adwaita [GTK2/3] 
        .oossssso-````/ossssss+`         Icons: Adwaita [GTK2/3] 
       -osssssso.      :ssssssso.        Terminal: urxvt 
      :osssssss/        osssso+++.       CPU: Intel i7-6700HQ (8) @ 3.500GHz 
     /ossssssss/        +ssssooo/-       GPU: Intel HD Graphics 530 
   `/ossssso+/:-        -:/+osssso+-     GPU: NVIDIA GeForce GTX 960M 
  `+sso+:-`                 `.-/+oso:    Memory: 4822MiB / 15903MiB 
 `++:.                           `-/+/
 .`                                 `/                           

Beitrag geändert von The_H4nZ (25.10.2018 10:33:55)

Offline

#2 26.10.2018 13:06:06

Trigun
Mitglied

Re: Audioprobleme: nur Kopfhörer und keine Lautstärkeregelung

Ist Pulsaudio installiert bzw. auch Pulseaudio-Alsa?

sudo pacman -Q pulseaudio pulseaudio-alsa

Hatte nach nem Update eine ähnliche Schwierigkeit.


Gegebenenfalls Neu installieren.


Deinstallieren

sudo pacman -Rs  alsa pulseaudio pulseaudio-alsa

Installieren

sudo pacman -S  alsa pulseaudio pulseaudio-alsa

Gruß Trigun

Beitrag geändert von Trigun (26.10.2018 13:09:17)

Offline

#3 26.10.2018 13:29:03

The_H4nZ
Mitglied

Re: Audioprobleme: nur Kopfhörer und keine Lautstärkeregelung

Danke Trigun,

Ja das ist alles installiert. Ich habe mal alles neu installiert, leider bleibt das Problem wie zuvor.

Ich nutze i3wm und die Lautstärketasten triggern den Befehl oben:

pactl set-sink-volume 0 +5%

Eben habe ich den befehl für alsa direkt getestet:

amixer set Master,0 75% unmute

Mit Erfolg! Daraus schließe ich, dass der Fehler eher bei pulseaudio oder pasystray liegt.

Jedenfalls funktioniert der Ton immer noch nur über Kopfhörer..

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums