#1 06.10.2018 11:09:56

puk
Mitglied

Sound Problem Atom BayTrail ThinkPad 8 RealTek Chip

Hallo ihr Lieben,

ich habe kürzlich ein ThinkPad erstanden und Arch von einem ThinkPad T61 auf das Tablet gecloned und eingerichtet.
Alles läuft soweit.
Einige Fallstricke gab es>
Bluetooth benötigte eine Windows-HCD-Datei (BCM4324B5_002.006.006.0601.0603.hcd), die ich von Windows kopiert habe.
Wifi ben;tigte ebenfalls eine Firmware(brcmfmac43241b5-sdio.txt) und lief dann mit dem brcmfmac Treiber problemlos.
Als Window-Manager verwende ich aktuell KDE (XFCE war nicht zu gebrauchen).

Eine Hürde ist noch zu nehmen: SOUND!

Die Webseite
https://thinkwiki.de/ThinkPad_8
schreibt, das Gerät hat einen Atom BayTrail Prozesor.
Als Soundkarte kommt anscheinend ein Realtek ALC5672 zum Einsatz.

sudo lspci -H1
00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0d)
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0d)
00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0d)
00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0d)
00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0d)

dmesg | grep audio
[    5.075601] [drm] HDaudio controller not detected, using LPE audio instead
[    6.394946] input: Intel HDMI/DP LPE Audio HDMI/DP,pcm=0 as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input12
[    6.395092] input: Intel HDMI/DP LPE Audio HDMI/DP,pcm=1 as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input13

dmesg | grep hd
[    0.076998] NMI watchdog: Enabled. Permanently consumes one hw-PMU counter.
[    6.394946] input: Intel HDMI/DP LPE Audio HDMI/DP,pcm=0 as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input12
[    6.395092] input: Intel HDMI/DP LPE Audio HDMI/DP,pcm=1 as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input13

aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: Audio [Intel HDMI/DP LPE Audio], Gerät 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: Audio [Intel HDMI/DP LPE Audio], Gerät 1: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1199:a001 Sierra Wireless, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

in /etc/modprobe.d/sound.conf werden folgende Module geladen:
snd-soc-rt5670
snd-soc-sst-cht-bsw-rt5672
snd-bt-sco

daher wohl die Ausgabe?:
dmesg | grep snd
[    5.305440] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    5.397928] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    5.397932] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    5.411666] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    5.411670] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    5.482854] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    5.482857] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    5.552401] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    5.552405] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    5.783309] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    5.783313] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    6.395491] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    6.395607] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    8.099736] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    8.099828] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    8.863955] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    8.863963] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    8.864188] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    8.864193] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    8.994286] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    8.994295] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[    9.042441] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[    9.042459] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[  394.297194] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[  394.297202] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517
[12985.281412] bytcr_rt5640 bytcr_rt5640: ASoC: CODEC DAI snd-soc-dummy-dai not registered
[12985.281426] bytcr_rt5640 bytcr_rt5640: devm_snd_soc_register_card failed -517

eventuell sollte ich das Modul rt5640 Blacklisten? Hm ich teste das mal schnell...

Offline

#2 07.10.2018 01:08:09

puk
Mitglied

Re: Sound Problem Atom BayTrail ThinkPad 8 RealTek Chip

keine Verbesserung durch Blacklisting....

lsmod | grep snd
snd_hdmi_lpe_audio     28672  1
snd_soc_rt5670        135168  0
snd_soc_rl6231         16384  1 snd_soc_rt5670
snd_intel_sst_acpi     16384  1
snd_intel_sst_core     65536  1 snd_intel_sst_acpi
snd_soc_sst_atom_hifi2_platform   110592  1 snd_intel_sst_core
snd_soc_acpi           16384  1 snd_intel_sst_acpi
snd_soc_acpi_intel_match    20480  1 snd_intel_sst_acpi
snd_soc_core          270336  2 snd_soc_rt5670,snd_soc_sst_atom_hifi2_platform
snd_compress           24576  1 snd_soc_core
ac97_bus               16384  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_pcm               131072  5 snd_soc_rt5670,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_pcm_dmaengine
snd_timer              36864  1 snd_pcm
snd                    98304  8 snd_timer,snd_compress,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_pcm
soundcore              16384  1 snd
mod | grep snd
snd_hdmi_lpe_audio     28672  1
snd_soc_rt5670        135168  0
snd_soc_rl6231         16384  1 snd_soc_rt5670
snd_intel_sst_acpi     16384  1
snd_intel_sst_core     65536  1 snd_intel_sst_acpi
snd_soc_sst_atom_hifi2_platform   110592  1 snd_intel_sst_core
snd_soc_acpi           16384  1 snd_intel_sst_acpi
snd_soc_acpi_intel_match    20480  1 snd_intel_sst_acpi
snd_soc_core          270336  2 snd_soc_rt5670,snd_soc_sst_atom_hifi2_platform
snd_compress           24576  1 snd_soc_core
ac97_bus               16384  1 snd_soc_core
snd_pcm_dmaengine      16384  1 snd_soc_core
snd_pcm               131072  5 snd_soc_rt5670,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_pcm_dmaengine
snd_timer              36864  1 snd_pcm
snd                    98304  8 snd_timer,snd_compress,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_pcm
soundcore              16384  1 snd

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums