#1 12.09.2018 11:02:18

Fansurfer
Mitglied

Soundbox wiedergabe funktioniert nicht [gelöst]

Hallo,

bei mir funktionieren meine Lautsprecher-System nicht mehr am PC. Das Lautsprecher-System ist aber in Ordnung, denn ich habe es mit meinem Tablet getestet. Selbst wenn ich alles auf Laut stelle und verschiedene Anwendungen nutze, kommt kein Ton raus. Ein neues Update habe ich auch nicht installiert.

Was kann ich machen um den Fehler zu finden?

Beitrag geändert von Fansurfer (14.09.2018 15:12:15)

Offline

#2 12.09.2018 12:52:52

niemand
Mitglied

Re: Soundbox wiedergabe funktioniert nicht [gelöst]

Was kann ich machen um den Fehler zu finden?

In Erfahrung bringen, welches Soundsystem verwendet wird. Gucken, ob damit ähnliche Probleme bekannt sind. Ansonsten mal auf der unteren Ebene anfangen, Pulse (oder Jack oder welches Soundsystem denn genutzt wird) stoppen und mit aplay eine Testdatei explizit auf dem gewünschten Device/Kanal ausgeben lassen. Eventuell auftauchende Meldungen lesen. Bei Nichtverstehen diese posten.

Offline

#3 12.09.2018 13:36:55

Fansurfer
Mitglied

Re: Soundbox wiedergabe funktioniert nicht [gelöst]

niemand schrieb:

Was kann ich machen um den Fehler zu finden?

In Erfahrung bringen, welches Soundsystem verwendet wird. Gucken, ob damit ähnliche Probleme bekannt sind. Ansonsten mal auf der unteren Ebene anfangen, Pulse (oder Jack oder welches Soundsystem denn genutzt wird) stoppen und mit aplay eine Testdatei explizit auf dem gewünschten Device/Kanal ausgeben lassen. Eventuell auftauchende Meldungen lesen. Bei Nichtverstehen diese posten.

Tut mir leid, aber dass ist für mich eine neue Herausforderung, denn ich habe absolut keine Ahnung. Wie finde ich den welches Soundsystem verwendet wird?

Offline

#4 12.09.2018 13:40:58

hcjl
Mitglied

Re: Soundbox wiedergabe funktioniert nicht [gelöst]

Fansurfer schrieb:

Tut mir leid, aber dass ist für mich eine neue Herausforderung, denn ich habe absolut keine Ahnung. Wie finde ich den welches Soundsystem verwendet wird?

Welches hast Du denn installiert und konfiguriert?

Offline

#5 12.09.2018 13:55:27

Fansurfer
Mitglied

Re: Soundbox wiedergabe funktioniert nicht [gelöst]

Also die Hardware besteht aus einem Crative A250 Soundsystem und meiner Onboard Soundkarte. Das ist eine HDA Intel, siehe unten. Bis gestern hat soweit alles noch Funktioniert.

cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xdf220000 irq 124
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xdf080000 irq 17

Mit aplay habe ich versucht eine Datei abzuspielen, hier das Ergebnis:

sudo aplay /usr/share/sounds/alsa/Front_Center.wav
[sudo] Passwort für ralf: 
Wiedergabe: WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono

Soweit ist wohl noch alles in Ordnung, aber hören kann man nichts. Mit pacman habe ich mal nach Pulseaudio gesucht und auch gefunden. Das ist wohl dann das Soundsystem mit Alsa zusammen, oder?

Beitrag geändert von Fansurfer (12.09.2018 13:57:48)

Offline

#6 12.09.2018 18:01:32

niemand
Mitglied

Re: Soundbox wiedergabe funktioniert nicht [gelöst]

Man sollte niemals Sachen als Root laufen lassen, wenn sie’s nicht benötigen. Sound abspielen benötigt’s nicht.

Wie auch immer – wenn da kein Fehler, aber auch kein Sound kam, ist eine mögliche Ursache, dass das falsche Device genutzt wurde. Etwa der Audioteil der verbauten Grafikkarte, der den Ton via HDMI an einen entsprechenden Monitor ausgeben würde. Daher mal das Audiointerface, an dem das Lautsprechersystem hängt, bei aplay explizit als Ausgabedevice angeben. Eine andere Möglichkeit wäre, dass das entsprechende Device gemuted ist – das kann man z.B. mit alsamixer prüfen (unter den Reglern sollte sowas wie 00 stehen, nicht aber MM).

Offline

#7 14.09.2018 11:34:47

Fansurfer
Mitglied

Re: Soundbox wiedergabe funktioniert nicht [gelöst]

Ok, die Soundkarte ist allen Anschein in Ordnung, ein Ton kam raus mit dem Befehl:

aplay --device="plughw:PCH" /usr/share/sounds/alsa/Front_Center.wav
Wiedergabe: WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono

Im alsamixer sind 3 Soundkarten anwählbar. Wenn ich den aslamixer aufrufe, wird dort PulsAudio angezeigt als Gerät. Sollte da nicht als erstes meine Soundkarte drin stehen?

Offline

#8 14.09.2018 12:09:36

niemand
Mitglied

Re: Soundbox wiedergabe funktioniert nicht [gelöst]

Passt schon, das beantwortet immerhin die Frage nach dem Soundsystem: du benutzt Pulse. Du solltest dann in Pulse das richtige Device als Ausgabedevice einstellen, und es sollte tun.

Offline

#9 14.09.2018 15:11:36

Fansurfer
Mitglied

Re: Soundbox wiedergabe funktioniert nicht [gelöst]

Danke jetzt geht es wieder. In Pulsaudio Volume Controll hatte ich wohl versehentlich das Ausgabegerät von Internes Audio Analog Stereo auf einen HDMI-Ausgang gelegt.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums