Du bist nicht angemeldet.

#1 11.02.2018 20:50:26

Dambedei
Gast

LightDM Anmeldung bleibt hängen

Hallo,

habe seit kurzem das Problem, dass nach Eingabe der Zugangsdaten meine Desktopumgebung (XFCE) nicht richtig gestartet wird.
Die Anwendungen aus dem autostart werden korrekt ausgeführt aber ich sehe weder xfce4-panel noch desktop icons.
Zum test habe ich einen neuen Nutzer angelegt, mit dem gelingt das anmelden. Somit bin ich von einem "kaputten" Profil ausgegangen
und habe zum test die .config/.cache Ordner umbenannt, was aber auch nichts gebracht hat sad
Selbst ein backup des home ordners vom Januar, als es noch ging, läuft nun nicht mehr.
Mein workaround: wechsel auf tty1 und zurück auf tty7, dann ist alles wieder gut bis zum nächsten reboot.
Weiss leider nicht wie ich das Problem debuggen kann, jemand eine Idee?

.xsessions-errors:

Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `XfcePanelImage::force-gtk-icon-sizes' of type `gboolean' from rc file value "((GString*) 0x5631ff1f7100)" of type `GString'

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

(thunderbird:16599): Gtk-CRITICAL **: gtk_icon_theme_append_search_path: assertion 'path != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `XfcePanelImage::force-gtk-icon-sizes' of type `gboolean' from rc file value "((GString*) 0x55f6c7383ce0)" of type `GString'
Gtk-Message: (for origin information, set GTK_DEBUG): failed to retrieve property `XfcePanelImage::force-gtk-icon-sizes' of type `gboolean' from rc file value "((GString*) 0x55f6c73dbba0)" of type `GString'

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

(Roger Router:16597): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (Roger Router:16597): WARNING **: Could not connect to socket. Error: Verbindungsaufbau abgelehnt

** (Roger Router:16597): WARNING **: Could not connect to FTP-Port 21

** (Roger Router:16597): WARNING **: Could not connect to socket. Error: Verbindungsaufbau abgelehnt

** (Roger Router:16597): WARNING **: Could not connect to FTP-Port 21

** (Roger Router:16597): WARNING **: Could not init ftp connection. Please check that ftp is enabled

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

(mousepad:19035): GtkSourceView-CRITICAL **: gtk_source_style_scheme_get_id: assertion 'GTK_SOURCE_IS_STYLE_SCHEME (scheme)' failed

(mousepad:19035): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed

(mousepad:19035): GtkSourceView-CRITICAL **: gtk_source_style_scheme_get_id: assertion 'GTK_SOURCE_IS_STYLE_SCHEME (scheme)' failed

(mousepad:19035): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed

(mousepad:19035): GtkSourceView-CRITICAL **: gtk_source_style_scheme_get_id: assertion 'GTK_SOURCE_IS_STYLE_SCHEME (scheme)' failed

(mousepad:19035): Gtk-WARNING **: Theme parsing error: <data>:2:29: The style property GtkButton:default-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(mousepad:19035): Gtk-WARNING **: Theme parsing error: <data>:3:37: The style property GtkButton:default-outside-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(mousepad:19035): Gtk-WARNING **: Theme parsing error: <data>:4:27: The style property GtkButton:inner-border is deprecated and shouldn't be used anymore. It will be removed in a future version

(mousepad:19035): Gtk-WARNING **: Theme parsing error: <data>:5:31: The style property GtkWidget:focus-line-width is deprecated and shouldn't be used anymore. It will be removed in a future version

(mousepad:19035): Gtk-WARNING **: Theme parsing error: <data>:6:28: The style property GtkWidget:focus-padding is deprecated and shouldn't be used anymore. It will be removed in a future version

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

** (devilspie:16587): CRITICAL **: e_sexp_eval: assertion 'f->tree != NULL' failed

(xfce4-terminal:20626): Gtk-WARNING **: Allocating size to GtkScrollbar 0x55b1cead64d0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

Gruß
Dambedei

#2 11.02.2018 23:06:32

XeroHero
Mitglied

Re: LightDM Anmeldung bleibt hängen

Hallo,

was für eine Grafiktreiber nutzt du und welchen Kernel?

Ich habe das gleiche Problem, aber nur mit dem neusten Updates, ich habe den Kernel 4.15.1 / 4.15.2 und den nvidia-390.25-9 Treiber... leider steht der Nvidia-Treiber in Abhängigkeit zur Kernelversion 4.15.x
Anders als bei dir läuft bei mir alles mit meinem Backup, dort habe ich die Kernelversion 4.14.15-1 und den Nvidia-Treiber 387.34-21 am laufen.

Meine aktuelle Updateliste sieht wie folgt aus:

btrfs-progs-4.15-1  cantarell-fonts-1:0.100-1  compositeproto-0.4.2-3 [Entferne]
            damageproto-1.2.1-3 [Entferne]  dbus-1.12.4-1  dmxproto-2.3.1-3 [Entferne]  ffmpeg-1:3.4.1-4
            ffmpeg2.8-2.8.13-5  firefox-58.0.2-1  firefox-i18n-de-58.0.2-1  fixesproto-5.0+9+g4292ec1-1 [Entferne]
            fontsproto-2.1.3-2 [Entferne]  gvfs-1.34.2-1  gvfs-afc-1.34.2-1  gvfs-gphoto2-1.34.2-1  gvfs-mtp-1.34.2-1
            gvfs-nfs-1.34.2-1  gvfs-smb-1.34.2-1  iana-etc-20180131-1  inputproto-2.3.2-1 [Entferne]
            kbproto-1.0.7-1 [Entferne]  lib32-dbus-1.12.4-1  lib32-dbus-glib-0.110-1  lib32-libwebp-0.6.1-1
            lib32-nvidia-utils-390.25-1  lib32-sdl2_image-2.0.2-1  lib32-systemd-237.0-1  libice-1.0.9-2
            libreoffice-fresh-6.0.1-1  libreoffice-fresh-de-6.0.1-1  libsystemd-237.0-2  libtirpc-1.0.2-3
            libvpx-1.7.0-1  libxau-1.0.8-3  libxdamage-1.1.4-3  libxfixes-5.0.3-2  libxnvctrl-390.25-1
            libxrandr-1.5.1-2  linux-4.15.2-2  lz4-1:1.8.1.2-1  man-db-2.8.1-1  man-pages-4.15-1  mpv-1:0.27.1-1
            nvidia-390.25-9  nvidia-settings-390.25-1  nvidia-utils-390.25-2  p7zip-16.02-4
            python2-setuptools-1:38.5.1-1  qpdf-7.1.1-1  randrproto-1.5.0-1 [Entferne]  recordproto-1.14.2-2 [Entferne]
            renderproto-0.11.1-3 [Entferne]  rubberband-1.8.1-4  scrnsaverproto-1.2.2-2 [Entferne]  sdl2_image-2.0.2-1
            systemd-237.0-2  systemd-sysvcompat-237.0-2  thunderbird-52.6.0-2  v4l-utils-1.14.1-1
            videoproto-2.3.3-1 [Entferne]  vlc-2.2.8-4  vulkan-icd-loader-1.0.68.0-1  xextproto-7.3.0-1 [Entferne]
            xf86dgaproto-2.1-3 [Entferne]  xf86vidmodeproto-2.3.1-3 [Entferne]  xineramaproto-1.2.1-3 [Entferne]
            xkeyboard-config-2.23.1-2  xorgproto-2018.1-1  xproto-7.0.31-1 [Entferne]  xulrunner-41.0.2-14

Nachtrag: ich hab jetzt mal meine /home Daten behalten und nur das Wurzelverzeichniss zurückgespielt und hier geht auch alles, kann also nicht an der config liegen

Beitrag geändert von XeroHero (11.02.2018 23:52:56)

Offline

#3 11.02.2018 23:58:18

Dambedei
Gast

Re: LightDM Anmeldung bleibt hängen

Hm, gut möglich dass es am Nvidia Treiber liegt. Nutze die gleiche Kombo (Kernel 4.15.2 + Nvidia proprietary).
Verstehe aber nicht warum mein neu angelegter Nutzer nicht vom Problem betroffen war. Kannst Du das mal nachstellen?
Anscheinend ist nicht jeder davon betroffen, sonst wäre hier mehr los, da das ganze schon gut 1 Woche andauert.
Nutzt Du zufällig ForceFullCompositionPipeline bzw. ForceCompositionPipeline?

Ich glaube, dieser Fehler ist neu seit 390.25:

[ 12792.130] (WW) NVIDIA(0): Resume swap group failed.
[ 12792.130] (WW) NVIDIA(0): Suspend swap group failed.

#4 12.02.2018 23:10:15

XeroHero
Mitglied

Re: LightDM Anmeldung bleibt hängen

Also ich hab jetzt auch noch mal einen neuen Benutzer erstellt und mit diesem klappt auch alles... und ich habe ebenfalls ForceFullCompositionPipeline und ForceCompositionPipeline aktiviert. Das heißt, ich war mir sicher es gemacht zu haben, ich wunder mich nur gerade das ich keine "20-nvidia.conf" mehr hab... ich hätte gedacht ich habe es in dieser config reingeschrieben.

aber ich habe eine kleine Spur

unter /var/log/lightdm/lightdm.log steht folgendes

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.24.0, UID=0 PID=433
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Monitoring logind for seats
[+0.00s] DEBUG: New seat added from logind: seat0
[+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.00s] DEBUG: Seat seat0: Starting
[+0.00s] DEBUG: Seat seat0: Creating greeter session
[+0.00s] DEBUG: Seat seat0: Creating display server of type x
[+0.00s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.00s] DEBUG: Using VT 7
[+0.00s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.00s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.00s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.00s] DEBUG: XServer 0: Launching X Server
[+0.00s] DEBUG: Launching process 441: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.00s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.00s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.01s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
[+0.01s] DEBUG: Loading user config from /etc/lightdm/users.conf
[+0.01s] DEBUG: User xerohero added
[+1.17s] DEBUG: Got signal 10 from process 441
[+1.17s] DEBUG: XServer 0: Got signal from X server :0
[+1.17s] DEBUG: XServer 0: Connecting to XServer :0
[+1.22s] CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[+1.22s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+1.22s] DEBUG: Session pid=471: Started with service 'lightdm-greeter', username 'lightdm'
[+1.24s] DEBUG: Session pid=471: Authentication complete with return value 0: Success
[+1.24s] DEBUG: Seat seat0: Session authenticated, running command
[+1.24s] DEBUG: Session pid=471: Running command /usr/bin/lightdm-gtk-greeter
[+1.24s] DEBUG: Creating shared data directory /var/lib/lightdm-data/lightdm
[+1.24s] DEBUG: Session pid=471: Logging to /var/log/lightdm/seat0-greeter.log
[+1.27s] DEBUG: Activating VT 7
[+1.27s] DEBUG: Activating login1 session c1
[+1.27s] DEBUG: Seat seat0 changes active session to c1
[+1.27s] DEBUG: Session c1 is already active
[+1.46s] DEBUG: Greeter connected version=1.24.0 api=1 resettable=false
[+1.67s] DEBUG: Greeter start authentication for xerohero
[+1.67s] DEBUG: Session pid=517: Started with service 'lightdm', username 'xerohero'
[+1.67s] DEBUG: Session pid=517: Got 1 message(s) from PAM
[+1.67s] DEBUG: Prompt greeter with 1 message(s)
[+23.04s] DEBUG: Continue authentication
[+23.06s] DEBUG: Session pid=517: Authentication complete with return value 0: Success
[+23.06s] DEBUG: Authenticate result for user xerohero: Success
[+23.06s] DEBUG: User xerohero authorized
[+23.09s] DEBUG: Greeter requests session xfce
[+23.09s] DEBUG: Seat seat0: Stopping greeter; display server will be re-used for user session
[+23.09s] DEBUG: Terminating login1 session c1
[+23.09s] DEBUG: Session pid=471: Sending SIGTERM
[+23.10s] DEBUG: Greeter closed communication channel
[+23.10s] DEBUG: Session pid=471: Exited with return value 0
[+23.10s] DEBUG: Seat seat0: Session stopped
[+23.10s] DEBUG: Seat seat0: Greeter stopped, running session
[+23.10s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
[+23.10s] CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[+23.10s] DEBUG: Session pid=517: Running command /etc/lightdm/Xsession startxfce4
[+23.10s] DEBUG: Creating shared data directory /var/lib/lightdm-data/xerohero
[+23.10s] DEBUG: Session pid=517: Logging to .xsession-errors
[+23.13s] DEBUG: Activating VT 7
[+23.13s] DEBUG: Activating login1 session c2
[+23.13s] DEBUG: Seat seat0 changes active session to 
[+23.13s] DEBUG: Seat seat0 changes active session to c2
[+23.13s] DEBUG: Session c2 is already active
[+27.94s] DEBUG: Seat seat0 changes active session to 
[+30.95s] DEBUG: Seat seat0 changes active session to c2
[+30.95s] DEBUG: Session c2 is already active

vielleicht kann uns damit jemand weiterhelfen.

Beitrag geändert von XeroHero (12.02.2018 23:46:02)

Offline

#5 13.02.2018 00:39:16

Dambedei
Gast

Re: LightDM Anmeldung bleibt hängen

Den critical habe ich auch im log, allerdings schon länger, würde ich also ausschliessen. die Warnung fehlt bei mir.
Wegen ForceFullCompositionPipeline/ForceCompositionPipeline gibt es wohl 3 Möglichkeiten:
/etc/X11/xorg.conf (hier habe ich es drin)
/etc/X11/xorg.conf.d/
/usr/share/X11/xorg.conf.d

Habe gerade mal erfolglos lightdm neu installiert (inkl neue config)...

#6 13.02.2018 13:06:50

sc44
Mitglied

Re: LightDM Anmeldung bleibt hängen

Hallo,
hier mal mein log, läuft alles einwandfrei auch nach dem Update auf Kernel 4.15 und Nvidia 390.25. Habe ich letzte Woche ganz Frisch auf meinem Testrechner installiert. Lightdm, lightdm-gtk-greeter, xfce4.

[+0.03s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.03s] DEBUG: Starting Light Display Manager 1.24.0, UID=0 PID=336
[+0.03s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.03s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.03s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.03s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.03s] DEBUG: Registered seat module local
[+0.03s] DEBUG: Registered seat module xremote
[+0.03s] DEBUG: Registered seat module unity
[+0.03s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.49s] DEBUG: Monitoring logind for seats
[+0.49s] DEBUG: New seat added from logind: seat0
[+0.49s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.49s] DEBUG: Seat seat0: Starting
[+0.49s] DEBUG: Seat seat0: Creating user session
[+0.49s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
[+0.50s] DEBUG: Loading user config from /etc/lightdm/users.conf
[+0.65s] DEBUG: User sc44 added
[+1.01s] DEBUG: Seat seat0: Creating display server of type x
[+1.01s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+1.01s] DEBUG: Using VT 7
[+1.01s] DEBUG: Seat seat0: Starting local X display on VT 7
[+1.01s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+1.01s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+1.01s] DEBUG: XServer 0: Launching X Server
[+1.02s] DEBUG: Launching process 347: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+1.02s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+1.02s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+1.02s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+5.12s] DEBUG: Got signal 10 from process 347
[+5.12s] DEBUG: XServer 0: Got signal from X server :0
[+5.12s] DEBUG: XServer 0: Connecting to XServer :0
[+5.12s] CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[+5.12s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+5.12s] DEBUG: Session pid=709: Started with service 'lightdm-autologin', username 'sc44'
[+5.32s] DEBUG: Session pid=709: Authentication complete with return value 0: Success
[+5.32s] DEBUG: Seat seat0: Session authenticated, running command
[+5.32s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
[+5.33s] CRITICAL: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
[+5.33s] DEBUG: Session pid=709: Running command /etc/lightdm/Xsession startxfce4
[+5.33s] DEBUG: Creating shared data directory /var/lib/lightdm-data/sc44
[+5.33s] DEBUG: Session pid=709: Logging to .xsession-errors
[+5.73s] DEBUG: Activating VT 7
[+5.73s] DEBUG: Activating login1 session c1
[+5.73s] DEBUG: Seat seat0 changes active session to c1
[+5.73s] DEBUG: Session c1 is already active

Eventuell hilft es euch ja weiter.

Offline

#7 13.02.2018 14:06:55

zathras
Gast

Re: LightDM Anmeldung bleibt hängen

Hallo,

das gleiche Problem tritt auch bei mir auf mit linux-lts  4.14.18-1 und nvidia-lts  1:390.25-2 beim Login über lightdm auf die Mate Umgebung.
Erst nach dem Wechsel zu VT 2 und zurück zu VT 7 erscheint der Desktop.
Das Problem ist bei mir der Eintrag:  Option  "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
in der 20-nvidia.conf. Vor dem Update funzte das noch alles so.
Lösung: Eintrag auskommentieren und als Autostart in die Destopumgebung einbauen.
$ nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceCompositionPipeline=On, ForceFullCompositionPipeline=On }" als nvidia tearing fix in den Autostart.

Unter Mate funzt das super sollte aber unter XFCE auch möglich sein.

#8 13.02.2018 15:23:04

XeroHero
Mitglied

Re: LightDM Anmeldung bleibt hängen

Ok, ich konnte den Fehler jetzt eingrenzen, ich habe einen neuen Benutzer erstellt und Stück für Stück die User-Ordner kopiert und getestet.

Sobald ich den /home/user/.config/xfce4/* ersetzte bekomme ich das gleiche Fehlerbild. Vielleicht liegt es an einer Schriftart?

Offline

#9 13.02.2018 16:23:02

hcjl
Mitglied

Re: LightDM Anmeldung bleibt hängen

XeroHero schrieb:

Sobald ich den /home/user/.config/xfce4/* ersetzte bekomme ich das gleiche Fehlerbild. Vielleicht liegt es an einer Schriftart?

Oder am Theme?

Offline

#10 13.02.2018 16:49:31

sc44
Mitglied

Re: LightDM Anmeldung bleibt hängen

Hatte ich vorhin vergessen, was man auch noch testen könnte wenn man lightdm deaktiviert, und sich nach dem
booten anmeldet und dann startxfce4 ausführt ob dann auch Fehlermeldungen kommen und welche. Syslog fällt mir auch noch ein.

zathras schrieb:

20-nvidia.conf

Das könnte natürlich der Grund sein, ich habe zwei Arch Syteme bei beiden habe ich die Config Datei nie erstellen lassen,
wozu auch wenn alles läuft, steht ja auch im Arch wiki. Kann natürlich sein das die neuen Nvidia Treiber nicht mit der Config laufen.
Dann würde ich mir einfach mal eine neue erstellen lassen, oder ganz entfernen.
https://wiki.archlinux.org/index.php/NVIDIA

Beitrag geändert von sc44 (13.02.2018 17:46:42)

Offline

#11 14.02.2018 17:09:29

XeroHero
Mitglied

Re: LightDM Anmeldung bleibt hängen

Mein Problem ist mehr oder weniger gelöst, bei mir lag es wirklich an der 20-nvidia.conf ich hab diese jetzt raus genommen und jetzt geht LightDM wieder, nur habe ich jetzt wieder das Problem mit tearing. Hier mal meine config (lief ja knappe 2Jahre damit):

Section "Device"
	Identifier	"Nvidia Card"
	Driver		"nvidia"
	VendorName	"NVIDIA Corporation"
	BusID		"PCI:01:00:0"
	Option		"Coolbits" "31"
EndSection


Section "Screen"
    Identifier     "Screen0"
    Option         "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }" // ist jetzt auskommentiert
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
EndSection

@zathras hätte ich doch gleich auf dich gehört^^

ich hab jetzt versucht mit

systemctl enable nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceCompositionPipeline=On, ForceFullCompositionPipeline=On }

und über Automatisch gestartete Anwendung in den Einstellungen, leider auch ohne Erfolg...

wenn ich den Befehl ins Terminal eingebe behebt es das Problem allerdings auch nicht

Beitrag geändert von XeroHero (14.02.2018 18:27:13)

Offline

#12 14.02.2018 22:26:23

sc44
Mitglied

Re: LightDM Anmeldung bleibt hängen

Hi,
ich habe das jetzt auch mal gemacht weil ich das wissen wollte. Als erstes habe ich mir mit dem Nvidia-settings Manager alles eingestellt.
Dann habe ich das als Datei gespeichert, bei mir sieht die so aus,

 nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 390.25  (builduser@anthraxx)  Thu Feb  8 13:45:56 CET 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Ancor Communications Inc VE248"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 610"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

das habe ich dann in "/etc/X11/xorg.conf.d/20-nvidia.conf" eingefügt. Die Einstellungen wurden übernommen und das booten ging auch ohne Probleme,
allerdings konnte ich das nicht so lassen, da ich Compiz verwende und dann die ganzen Effekte nicht mehr laufen.
Ist mir aber egal, da ich zum einen kein Tearing habe, und zweitens das eh nur meine dammel Kiste ist.

Offline

#13 14.02.2018 22:44:14

XeroHero
Mitglied

Re: LightDM Anmeldung bleibt hängen

Ich nehme an, dass das Einloggen bei dir mit LightDM auch geklappt hat (weil du schreibst booten)? Das hatte ich auch schon getestet, geht bei mir aber nicht. Dann habe ich den Fehler bei LightDM wieder, ich müsste die Nvidia-Settings erst laden wenn ich mich einlogge und nicht schon mit dem starten von X-Server. Ohnehin glaube ich das da noch etwas anderes mit rein spielt, warum sollte es sonst beim Anlegen eines neuen Benutzers funktionieren.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums