#1 11.01.2018 19:03:03

Icecube63
Mitglied

[gelöst] Updateproblem von libx264

Beim heutigen Update habe ich folgende Fehlermeldung:

ffmpeg0.10: das Installieren von libx264 (2:152.20171224-1) verletzt Abhängigkeit von 'libx264.so=148-64'

Wie kann ich das lösen?

Beitrag geändert von Icecube63 (25.01.2018 19:01:09)

Offline

#2 11.01.2018 19:35:11

stefanhusmann
Moderator

Re: [gelöst] Updateproblem von libx264

Das sind alles AUR-Pakete, wobei ffmpeg0.10 mal in [community] war. Es sollte reichen, das PKGBUILD von ffmpeg0.10 aus dem AUR neu zu bauen. Nach den AUR-Kommentaren gelingt das aber anscheinend nicht immer.

Offline

#3 11.01.2018 20:21:31

Icecube63
Mitglied

Re: [gelöst] Updateproblem von libx264

ffmpeg0.10 wird aktuell gar nicht aktualisiert, wenn ich es neu baue habe ich den gleichen Fehler.

libx264 ist aber noch in extra:

$ pacaur -Qu

:: extra      libx264                             2:148.20170521-1          ->  2:152.20171224-1

Offline

#4 11.01.2018 22:41:09

stefanhusmann
Moderator

Re: [gelöst] Updateproblem von libx264

Was sagt pacman -Qi ffmpeg0.10?

Offline

#5 11.01.2018 22:57:57

niemand
Mitglied

Re: [gelöst] Updateproblem von libx264

Im Wesentlichen:

Name                     : ffmpeg0.10                                                                                                                                                        
Version                  : 0.10.16-2                                                                                                                                                         
Beschreibung             : Complete solution to record, convert and stream audio and video                                                                                                   
Architektur              : x86_64                                                                                                                                                            
URL                      : http://ffmpeg.org/                                                                                                                                                
Lizenzen                 : GPL                                                                                                                                                               
Gruppen                  : Nichts                                                                                                                                                            
Stellt bereit            : ffmpeg-compat  libavcodec.so=53-64  libavutil.so=51-64  libpostproc.so=52-64  libswscale.so=2-64  libswresample.so=0-64  libavformat.so=53-64                     
                           libavfilter.so=2-64  libavdevice.so=53-64                                                                                                                         
Hängt ab von             : alsa-lib  bzip2  gsm  lame  libass  libmodplug  libpulse  libtheora  libva  opencore-amr  openjpeg  rtmpdump  schroedinger  sdl  speex  v4l-utils  xvidcore  zlib 
                           libvorbisenc.so=2-64  libvorbis.so=0-64  libvpx.so=4-64  libx264.so=148-64                                                                                        
Optionale Abhängigkeiten : Nichts                                                                                                                                                            
Benötigt von             : Nichts                                                                                                                                                            
Optional für             : Nichts                                                                                                                                                            
In Konflikt mit          : Nichts                                                                                                                                                            
Ersetzt                  : ffmpeg-compat                                                                                                                                                     
Installationsgröße       : 9,75 MiB                                                                                                                                                          
Packer                   : Maxime Gauduin <alucryd@archlinux.org>                                                                                                                            
Erstellt am              : Sa 23 Jul 2016 11:15:49 CEST                                                                                                                                      
Installiert am           : Sa 06 Aug 2016 18:38:42 CEST                                                                                                                                      
Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket                                                                                                                
Installations-Skript     : Nein                            

Ich hatte den Fehler auch gerade, und bin mir ziemlich halbwegs sicher, nix mit Bezug dazu aus‘m AUR draufgetan zu haben. Hab’s mal deinstalliert, offensichtlich gab’s da nix mehr, was diese Version brauchte.

Beitrag geändert von niemand (11.01.2018 23:03:16)

Online

#6 12.01.2018 05:35:01

stefanhusmann
Moderator

Re: [gelöst] Updateproblem von libx264

Das ist die letzte Version aus dem Repo. Eine Version aus dem AUR dürfte pkgrel 3 und einen anderen Packager liefern. und beim AUR-Paket ist auch keine versionierte Abhängigkeit libx264.so=148-64  mehr drin.

Leider baut das Ding bei mir nicht.

Offline

#7 13.01.2018 02:26:17

LinLin
Mitglied

Re: [gelöst] Updateproblem von libx264

Gibt es einen Unterschied zwischen ffmpeg0.10 und ffmpeg 1:3.4.1-3?

Tun die nicht beide das gleiche. Versteh ich nicht warum er 0.10 haben will.

Offline

#8 13.01.2018 10:44:59

stefanhusmann
Moderator

Re: [gelöst] Updateproblem von libx264

Bestimmt gibt es einen Unterschied (ffmpeg0.10 ist älter), aber worin der besteht und ob der noch relevant ist, erschließt sich mir nicht. Ich würde auf ffmpeg0-10 verzichten, wenn ich es installiert hätte.

Offline

#9 13.01.2018 12:03:16

niemand
Mitglied

Re: [gelöst] Updateproblem von libx264

Versteh ich nicht warum er 0.10 haben will.

Wer will das denn bei dir? Bei mir war’s, wie ich schon schrieb: es wurde zwar irgendwann als Abhängigkeit für irgendwas mitgezogen, diese Abhängigkeit scheint aber heute nicht mehr zu bestehen und es ließ sich problemlos deinstallieren.

Online

#10 13.01.2018 14:40:36

LinLin
Mitglied

Re: [gelöst] Updateproblem von libx264

@niemand: Deine Mami hat dir wohl keine anständigen Umgangsformen beigebracht.

Stichwort: Netiquette
https://de.wikipedia.org/wiki/Netiquette

Mit dir hatte ich auch nicht geredet.
Dein Problem wenn du dich angesprochen fühlst.

Offline

#11 13.01.2018 17:39:36

niemand
Mitglied

Re: [gelöst] Updateproblem von libx264

… und wenn du mir nun noch genau sagst, was dir an meinen Umgangsformen nicht gefällt, könnte ich sogar in Erwägung ziehen, diese anzupassen. Bis dahin jedoch bin ich mir keines Verstoßes gegen die Netiquette bewusst. Die Frage war jedenfalls exakt auf deine Aussage bezogen:
„Versteh ich nicht warum er 0.10 haben will.” → „Wer will das denn bei dir?“ (Bezüge kenntlich gemacht). Was genau ist das Problem damit?

Du hättest lieber die Frage beantworten sollen, was genau denn ffmpeg0.10 benötigt –  ansonsten kann’s nämlich einfach weg (wie du aus meinem Beitrag gelesen haben könntest, hätte deine Mami dir verstehendes Lesen beigebracht).

Online

#12 13.01.2018 20:01:34

Werner
Mitglied

Re: [gelöst] Updateproblem von libx264

OT: Apropos sprachliche Bezüge und Fettnäpfe …
Als kleiner Stöppke wurde ich vom Schuldirektor bei der Einschulung gefragt:
»Was ist denn dein Vater?« Die Antwort »Kartoffeln« hat er mir ziemlich übel genommen.
smile

Offline

#13 14.01.2018 00:06:02

SUSEDJAlex
Mitglied

Re: [gelöst] Updateproblem von libx264

Darf ich hier mal was aufzeigen:

Hier mal zum Vergleich:

sudo pacman -Qi libx264
Name                     : libx264
Version                  : 2:152.20171224-1
Beschreibung             : Library for encoding H264/AVC video streams (8bit depth)
Architektur              : x86_64
URL                      : https://www.videolan.org/developers/x264.html
Lizenzen                 : GPL
Gruppen                  : Nichts
Stellt bereit            : libx264-8bit  libx264.so=152-64
Hängt ab von             : glibc
Optionale Abhängigkeiten : Nichts
Benötigt von             : ffmpeg  ffmpeg2.8  gst-plugins-ugly  mplayer
Optional für             : Nichts
In Konflikt mit          : libx264
Ersetzt                  : Nichts
Installationsgröße       : 1090,00 KiB
Packer                   : Maxime Gauduin <alucryd@archlinux.org>
Erstellt am              : Do 28 Dez 2017 17:06:12 CET
Installiert am           : Sa 13 Jan 2018 21:01:28 CET
Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript     : Nein
Verifiziert durch        : Signatur

sudo pacman -Qi ffmpeg
Name                     : ffmpeg
Version                  : 1:3.4.1-3
Beschreibung             : Complete solution to record, convert and stream audio and video
Architektur              : x86_64
URL                      : http://ffmpeg.org/
Lizenzen                 : GPL3
Gruppen                  : Nichts
Stellt bereit            : libavcodec.so=57-64  libavdevice.so=57-64  libavfilter.so=6-64  libavformat.so=57-64
                           libavresample.so=3-64  libavutil.so=55-64  libpostproc.so=54-64  libswresample.so=2-64
                           libswscale.so=4-64
Hängt ab von             : alsa-lib  bzip2  fontconfig  fribidi  glibc  gmp  gnutls  gsm  jack  lame  libavc1394
                           libiec61883  libmodplug  libpulse  libraw1394  libsoxr  libssh  libtheora  libvdpau  libwebp
                           libx11  libxcb  libxml2  opencore-amr  openjpeg2  opus  sdl2  speex  v4l-utils  xz  zlib
                           libass.so=9-64  libbluray.so=2-64  libfreetype.so=6-64  libva-drm.so=2-64  libva.so=2-64
                           libva-x11.so=2-64  libvidstab.so=1.1-64  libvorbisenc.so=2-64  libvorbis.so=0-64
                           libvpx.so=4-64  libx264.so=152-64  libx265.so=146-64  libxvidcore.so=4-64
Optionale Abhängigkeiten : ladspa: LADSPA filters [Installiert]
Benötigt von             : chromaprint  firefox  gst-libav  java-openjfx  mplayer  thunderbird
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 29,56 MiB
Packer                   : Maxime Gauduin <alucryd@archlinux.org>
Erstellt am              : So 31 Dez 2017 00:48:18 CET
Installiert am           : Sa 13 Jan 2018 21:01:29 CET
Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript     : Nein
Verifiziert durch        : Signatur

sudo pacman -Qi ffmpeg2.8
Name                     : ffmpeg2.8
Version                  : 2.8.13-4
Beschreibung             : Complete solution to record, convert and stream audio and video
Architektur              : x86_64
URL                      : https://ffmpeg.org/
Lizenzen                 : GPL3
Gruppen                  : Nichts
Stellt bereit            : libavcodec.so=56-64  libavdevice.so=56-64  libavfilter.so=5-64  libavformat.so=56-64
                           libavresample.so=2-64  libavutil.so=54-64  libpostproc.so=53-64  libswresample.so=1-64
                           libswscale.so=3-64
Hängt ab von             : alsa-lib  bzip2  fontconfig  fribidi  glibc  gmp  gnutls  gsm  jack  lame  libmodplug  libpulse
                           libsoxr  libssh  libtheora  libvdpau  libwebp  libx11  libxcb  libxext  libxv  opencore-amr
                           openjpeg  opus  schroedinger  sdl  speex  v4l-utils  xz  zlib  libass.so=9-64
                           libbluray.so=2-64  libdcadec.so=0-64  libfreetype.so=6-64  libva.so=2-64  libvidstab.so=1.1-64
                           libvorbisenc.so=2-64  libvorbis.so=0-64  libvpx.so=4-64  libx264.so=152-64  libx265.so=146-64
                           libxvidcore.so=4-64
Optionale Abhängigkeiten : ladspa: LADSPA filters [Installiert]
Benötigt von             : vlc
Optional für             : Nichts
In Konflikt mit          : Nichts
Ersetzt                  : Nichts
Installationsgröße       : 17,74 MiB
Packer                   : Maxime Gauduin <alucryd@archlinux.org>
Erstellt am              : Do 28 Dez 2017 17:50:35 CET
Installiert am           : Sa 13 Jan 2018 21:01:29 CET
Installationsgrund       : Installiert als Abhängigkeit für ein anderes Paket
Installations-Skript     : Nein
Verifiziert durch        : Signatur

Woher du den ffmpeg-compat her hast, ist mir vollkommen schleierhaft, denn bei mir wird dies gar nicht aufgelistet.

LG SUSEDJAlex

Offline

#14 14.01.2018 14:46:04

Werner
Mitglied

Re: [gelöst] Updateproblem von libx264

Spotify wäre so ein Kandidat. Er Es kann anscheinend mit einer halbwegs aktuellen FFmpeg-Version keine lokalen Dateien abspielen.

Offline

#15 15.01.2018 23:30:01

stefanhusmann
Moderator

Re: [gelöst] Updateproblem von libx264

Hm, hier hat jemand ebenfalls ein Problem mit libx264.so. Ist hier auch archlinux32 im Spiel?

Offline

#16 15.01.2018 23:32:48

Schard-nologin
Gast

Re: [gelöst] Updateproblem von libx264

stefanhusmann schrieb:

Hm, hier hat jemand ebenfalls ein Problem mit libx264.so. Ist hier auch archlinux32 im Spiel?

Ich denke nicht

SUSEDJAlex schrieb:
Architektur              : x86_64

Wohl ein distributionsübergreifendes Problem.

#17 16.01.2018 14:48:42

sc44
Mitglied

Re: [gelöst] Updateproblem von libx264

Hallo,
ich verwende Arch noch nicht so lange, könnte mir aber vorstellen, das ffmpeg0.10 durch ffmpeg2.8 abgelöst wurde.
Die letzte ffmpeg0.10 wurde 2015 released, die erste ffmpeg2.8 auch 2015.

Offline

#18 18.01.2018 18:14:07

lemondreas
Mitglied

Re: [gelöst] Updateproblem von libx264

Hatte selbiges Problem:

# pacman -Rdd ffmpeg ffmpeg2.8 ffmpeg0.10 
# pacman -Syu 
# pacman -S ffmpeg ffmpeg2.8

und gut is

Beitrag geändert von lemondreas (18.01.2018 18:14:23)

Offline

#19 25.01.2018 19:00:44

Icecube63
Mitglied

Re: [gelöst] Updateproblem von libx264

Konnte nun endlich wieder an den betreffenden Rechner, nach dem löschen von ffmpeg0.10 läuft das Update durch.

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums