#1 12.11.2017 18:02:46

BitBabbler
Mitglied

Xfce Session schlägt fehl

Hallo zusammen

Dies ist mein erster Post im Forum. Bitte korrigiert meine allfälligen Fehler. Ich liefere fehlenden Infos gerne nach. Logs habe ich am Ende dieses Posts auf paste.archlinux.de verlinkt.

Bei mir hat sich Arch-Linux als sehr robust erwiesen und läuft seit ca. 2 Jahren stabil. Bisher sind keine Probleme aufgetreten, die ich nicht rasch selbst lösen konnte, und auch die waren meist hausgemacht. Ich betreibe Arch auf meinem Thinkpad W510, X230 und auf dem Heise Ryzen Eigenbau. Wirklich eine tolle Distribution mit einer Community die Fragen bisher immer beantworten konnte ohne das ich sie stellen musste. :-)
Mein aktuelles Problem mit XFCE scheint aber leider hartnäckiger zu sein. Sie betrifft mein x230.
Erste Probleme traten mit Thunar auf. Zuerst dauerte es sehr lange, bis ein Verzeichnis angezeigt wurde, danach baute sich das Fenster gar nicht mehr auf. Das betraf nur meinen Benutzer. Die Ursache konnte ich nicht ergründen. Sie hat auch kaum etwas mit dem aktuellen Problem zu tun.
Dieses trat auf nachdem ich einen Login-Manager installiert hatte. Bisher hatte ich XFCE immer via ~/.bash_profile direkt nach dem Konsolen Login starten lassen.
Nach der Installation (und Konfiguration) des XDM Login Managers stellte mir XFCE nur noch einen schwarzen Bildschirm dar. Das war auch nach der XDM Deinstallation der Fall. Direkter Start von startxfce4 ergibt dasselbe Fehlerbild. ~/.xinitrc und ~/.cache/sessions/ habe ich gelöscht und kontrolliert, ob alle Files in meinem $HOME auch zu meinem Account gehören. Das Problem scheint nicht an Xorg zu liegen, Fluxbox startet und funktioniert bestens. Auch das Problem mit Thunar ist weg (immerhin :-)). Die Problematik mit XFCE bleibt auch mit einem neuen Benutzer Account dieselbe.
Die Internet Recherche, nach den Fehlermeldungen die in den Logs ersichtlich sind, hat mich auch nicht weiter gebracht.
Bisher blieben alle meine Versuche, den Fehler zu beheben erfolglos. Ich hoffe jemand von euch kann mir helfen, ich möchte nur als allerletzter Ausweg Arch neu aufsetzen.

Vielen dank schon im Voraus.

Gruss
Michel

Xorg.0.log

dmesg.log

.xsession-errors

lightdm.log

Offline

#2 12.11.2017 21:21:31

Werner
Mitglied

Re: Xfce Session schlägt fehl

Liegt in deinem Homeverzeichnis evtl. noch eine ~/.xsession von XDM, die LightDM aus dem Tritt bringt?

Die von dir gelöschte ~/.xinitrc würde ich auf jeden Fall mit folgendem Inhalt wieder anlegen:

#!/bin/sh

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi

exec startxfce4

… und dann versuchen vom tty mit "startx" (nicht "startxfce4") zu starten. Auf dem Weg ist sichergestellt, dass beim Start von Xfce4 auch die Datei /etc/X11/xinit/xinitrc.d/50-systemd-user.sh ausgeführt wird. Ich habe jedenfalls den Verdacht, dass dies die Ursache sein könnte.

Edit: Vergessenes "exec startxfce4" hinzugefügt

Beitrag geändert von Werner (12.11.2017 22:21:51)

Offline

#3 13.11.2017 00:33:27

BitBabbler
Mitglied

Re: Xfce Session schlägt fehl

Hi Werner

Besten Dank für deine prompte Antwort.

Werner schrieb:

Liegt in deinem Homeverzeichnis evtl. noch eine ~/.xsession von XDM, die LightDM aus dem Tritt bringt?

Das war der Fall nachdem ich LightDM installiert hatte. Nachdem ich das File gelöscht hatte startete Fluxbox aber nicht Xfce.

Werner schrieb:

Die von dir gelöschte ~/.xinitrc würde ich auf jeden Fall mit folgendem Inhalt wieder anlegen:

Eine neue .xinitrc Datei anzulegen hatte ich schon, gemäss Wiki, versucht. Ohne Erfolg.
Ich habe es noch einmal, mit deinem Vorschlag umgesetzt.

Leider hat sich auch dadurch nichts am Fehlerbild geändert. Ich habe das .xinitrv File erstellt LightDM als Service deaktiviert und den Laptop neu gestartet. Danach den Befehl ‚startx | tee /tmp/xerror‘ auf tty1 eingegeben. Derselbe schwarze Screen mit dem Cursor ist erschienen.
Im xerror File steht:

/usr/bin/startxfce4: X server already running on display :0

Im Xorg.0.log steht:

[762.903] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)

Ich habe noch ein wenig mit den Ergebnissen einer Suche nach obiger Fehlermeldung rumgespielt. Aber auch 'unset DISPLAY' oder 'xinit /usr/bin/xterm' (ohne ein .xinitrc File) bringt kein brauchbares Ergebnis. Immerhin hatten noch andere mit dieser Fehlermeldung im Zusammenhang mit Xfce zu kämpfen. Das ist schon einmal ein Ansatzpunkt. Ich werde wohl erst Morgen Abend weiter forschen können.

Nochmal vielen Dank für deinen Input.
g n8
Gruss
Michel

Offline

#4 13.11.2017 01:43:47

Werner
Mitglied

Re: Xfce Session schlägt fehl

Vielleicht ist das xfce4-Profil beschädigt. Das hatte ich schon in der Vergangenheit – ebenfalls mit einem schwarzen Bildschirm als Folge. Um das zu prüfen, könntest du versuchen, xfce4 mit einem frischen Profil zu starten.

Grafische Sitzung beenden, dann:

rm -rf ~/.cache/sessions
mv ~/.config/xfce4 ~/.config/xfce4-ALT

Grafische Sitzung erneut starten.

Beitrag geändert von Werner (13.11.2017 01:45:55)

Offline

#5 14.11.2017 17:56:32

BitBabbler
Mitglied

Re: Xfce Session schlägt fehl

Hallo Werner

das war ein Versuch wert. Bisher hatte ich nur den Session Cache gelöscht.
Leider hat dein Vorschlag aber bei mir nichts geändert. Mir wird nach dem Start von XFCE immer noch schwarz vor Augen. :-)

Die üblichen Lösungs-Ansätze scheinen hier nicht zum Ziel zu führen. Ich werde mir wohl noch weiter Zeit nehmen. Inzwischen interessiert mich die Ursache zu sehr, als das ich einfach neu aufsetzen möchte.

Weitere Vorschläge sind sehr willkommen.

Besten Dank
Gruss
Michel

~/.local/share/xorg/Xorg.0.log

Offline

#6 14.11.2017 20:41:42

Photor
Mitglied

Re: Xfce Session schlägt fehl

Moin BitBabbler,

BitBabbler schrieb:

Im xerror File steht:

/usr/bin/startxfce4: X server already running on display :0

Das da oben bedeutet, dass da schon ein X-Server - damit kann startxfce4 den nicht mehr starten. Um genau zu sein: nicht mehr auf Display :0.

Du solltest rausfinden, wieso? Ich vermute mal, dass Du einen Display-Manager (XDM, GDM kommt mit Gnome, KDM enthalten in KDE, LightDM, ...) laufen hast.
Bei XDM und LightDM wird die nach dem Einloggen gestartete Session in irgendwelchen Files, die auch ein personalisierbaren Version im HOME-Verzeichnis liegen (z.B. .xsession); die musst Du dann anpassen (hängt u.U. von der Distri ab). Mir fällt gerade noch ein, dass ich auch schon mal ein Problem mit LightDM hatte(*).

Bei GDM (und sehr wahrscheinlich auch KDM) kann man direkt in dessen Oberfläche die zu startende Session festlegen: in dem entsprechenden Auswahlknopf sollte XFCE4 (neben Gnome z.B.) dann zur Auswahl angeboten werden und sich starten lassen. Der Eintrag in der Auswahl wird Wohl auch von der Distribution bzw. dem Paket und der Installation gesteuert.

Wenn Du aber auf eine Display-Manager verzichten willst, kannst Du Dich natürlich auch auf der Konsole einloggen und dann dort das startxfce4 aufrufen.

Ciao,
Photor

(*) ich setze im Moment Gnome und damit GDM ein, kann das also nicht mehr nachvollziehen. LightDM gab es mal auf meinem Uralt-Lappy (RIP); der startete dann auch XFCE4.

Offline

#7 15.11.2017 18:20:51

BitBabbler
Mitglied

Re: Xfce Session schlägt fehl

Hi Photor,

vielen Dank für deine Anregung. Ja mir ist diese Meldung im Log auch schon aufgefallen und ich bin ihr nachgegangen. Mein Login Manager ist deaktiviert (sudo systemctl disable lightdm.service) und ich starte X seither von der Konsole aus, sobald ich versuche Xfce zu starten.
Aufgrund deines Posts habe ich folgendes versucht.

  • Starten ohne X (init 3) dmesg.log

  • Login auf tty1 mit meinem debug Benutzer den ich nach auftreten des Fehlers angelegt habe.

  • Sicherstellen, dass das .xinitrc File der Empfehlung von Werner entspricht.

  • $ startx

Selber Effekt... ausser das ich jetzt auf tty1 einen schwarzen Schirm, ohne Cursor habe. Auf tty7 ist es schwarz mit blinkender Eingabe-Aufforderung "_".

ps.log
Xorg.0.log
.xsession-errors

Neue Fehlermeldungen altes Leid. :-(
Immerhin gibt mir folgende Zeile aus den XSession Errors eine neue Brotkrumenspur nach der ich suchen kann.

xterm: fatal IO error 11 (Resource temporarily unavailable) or KillClient on X server ":0.0"

Photor schrieb:

Bei GDM (und sehr wahrscheinlich auch KDM) kann man direkt in dessen Oberfläche die zu startende Session festlegen

Das kann ich auch bei LightDM. Ich starte den jeweils mit systemctl und brauche ihn um Fluxbox zu starten. So bleibt mein Laptop weiterhin brauchbar und ich kann diesen Thread einfach mit Logs füttern. Allerdings kann ich Xfce von hier auch auch nicht starten.

Ich danke euch allen, dass ihr mir bei der Ursachen-Forschung helft. Das motiviert mich den Grund dieses Problems verstehen zu wollen.

Eine tolle Distribution mit hilfsbereite Community und freundlichem Umgangston. Ich bin angekommen. ;-)
Ich halte euch auf dem laufenden, falls sich etwas ergibt.

Merci
Gruss
Michel

Offline

#8 15.11.2017 19:16:41

tuxnix
Mitglied

Re: Xfce Session schlägt fehl

Hi Michel.
Hattest du vor der Installation des Loginmanages ein System update durchgeführt?
Ich würde mal versuchen ob ein Downgrade der Pakete weiterhilft.
Zumindest hast du dann für die Fehlersuche auch von dieser Seite her eine Ausgangsbasis bei das alles noch funktionierte.

Bei der Intel HD 4000 Grafik für das Thinkpad X230 ist es zwar unwahrscheinlich, dass hier was im Grafikstrack kaputt gepached wurde, aber auch nicht gänzlich ausgeschlossen.
Laufen denn die beiden anderen Rechner unter der gleichen Konfiguration einwandfrei?

Beitrag geändert von tuxnix (15.11.2017 19:23:48)

Offline

#9 15.11.2017 20:56:02

BitBabbler
Mitglied

Re: Xfce Session schlägt fehl

Salü tuxnix,

tuxnix schrieb:

Hattest du vor der Installation des Loginmanages ein System update durchgeführt?

Vermutlich ja, ich mache das andauernd. Ich bin arbeitstechnisch auf einem HP Business Laptop und Win-10 festgenagelt und kann je nach Anforderung nicht jeden Tag auf meinen privaten Laptop ausweichen. Deshalb ist mein übliches Vorgehen erst mal die Linux News zu lesen und danach ein Update durchzuführen. Saugt dieses einen neuen Kernel starte ich neu.
Kennst du das Vorgehen um Xfce samt zugehöriger Konfiguration zu entfernen und danach neu zu installieren? Ich vermute, dass es Meldungen von Leidensgenossen gegeben hätte, falls wirklich ein Update meine (doch sehr übliche) Konfiguration zerschossen hätte. X0rg oder Intel Treiber sind es IMHO nicht, weil beides im Moment ja läuft. Leider nicht mit Xfce aber immerhin. :-)

tuxnix schrieb:

Ich würde mal versuchen ob ein Downgrade der Pakete weiterhilft.

Welche meinst du insbesondere? Xfce habe ich schon einmal (dümmlich und aus schierem Mangel an besseren Ideen) darüber installiert. An die Pakete der Grafik oder Xorg habe ich mich aus oben genannten Gründen noch nicht gewagt. Das Risiko eines Downgrade kann ich, aufgrund der mir unbekannten Abhängigkeiten, schlecht beurteilen. Möglich wäre sicher ein Snapshot mit Clonezilla um danach jedes Risiko tragen zu können. :-)

tuxnix schrieb:

Laufen denn die beiden anderen Rechner unter der gleichen Konfiguration einwandfrei?

Beide hier genannten Systeme haben einen Nvidia GPU. Sonst ja, mit denen habe ich keine (Xfce) Probleme. Das kann aber auch daran liegen, dass das W510 eine Test-Kiste ist auf der vor allem VMs laufen müssen und der Ryzen PC ist meine Spiele und Multimedia Kiste. Auf beiden ändere ich nur sehr wenig an der Host OS Konfig.
Auf diesem Laptop hier ändere hingegen öfters etwas. Vermutlich handelt es sich hier eher um ein Layer 8 Problem. :-\

Danke für deine Hilfe.

Gruss
Michel

Offline

#10 15.11.2017 21:43:07

Werner
Mitglied

Re: Xfce Session schlägt fehl

BitBabbler schrieb:

Im xerror File steht:

/usr/bin/startxfce4: X server already running on display :0

Im Xorg.0.log steht:

[762.903] (EE) parse_vt_settings: Cannot open /dev/tty0 (Permission denied)

Die erstgenannte Fehlermeldung wäre bei einem Startproblem mit Xfce4 nicht untypisch – hier auch im Zusammenhang mit XDM: Xfce4-Forum
Die Lösungsansätze sind soweit durchexerziert bis auf die automatische Sitzungsspeicherung. Die ist Default scharf geschaltet, auch bei einem frischen Profil. Da du nicht an‘s GUI kommst, könntest du sie versuchsweise von der Konsole aus abschalten:

xfconf-query -c xfce4-session -p /general/AutoSave -s false
xfconf-query -c xfce4-session -p /general/SaveOnExit -s false
xfconf-query -c xfce4-session -p /general/PromptOnLogout -s false

Was die zweitgenannte Fehlermeldung anbetrifft, die ist mir schleierhaft. Die gegoogelten Lösungsansätze laufen IMHO in zwei Richtungen:
Ein Workaround durch das Anlegen einer /etc/X11/Xwrapper.config [1] mit dem hier im Arch-Wiki beschriebenen Eintrag.
Oder aber das Warten auf ein Kernelupdate [2] oder evtl. ein vorübergehendes Downgrade.

Beitrag geändert von Werner (15.11.2017 21:44:27)

Offline

#11 26.11.2017 19:05:44

BitBabbler
Mitglied

Re: Xfce Session schlägt fehl

Hoi Werner,

Das war eine etwas herausfordernde Zeit im Geschäft. Ich war die ganze Zeit mit meinem Office Laptop unterwegs. Ich habe die Anregungen durchprobiert und Session Save auf die vorgeschlagene Art ausgeschaltet. Leider auch dieses Mal ohne Erfolg.
Um weiter, ohne viel zu tunen, arbeiten zu können, habe ich Gnome installiert. Das nimmt den Druck, rasch eine Lösung zu finden, etwas weg.

Werner schrieb:

Oder aber das Warten auf ein Kernelupdate [2] oder evtl. ein vorübergehendes Downgrade.

Ich schaue mal ob sich etwas selbst heilt, oder ob ich in ein paar Wochen motiviert bin, diese Lösungssuche weiter zu treiben.

Vielen Dank euch allen für eure Hilfe.

Gruss
Michel

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums