#1 12.10.2017 13:36:10

kama
Mitglied

[gelöst] Hatte Probleme mit Umlauten und Sonderzeichen in plasma (KDE)

Nur zur Information:

Seit einem Update vor einiger Zeit hatte ich Probleme mit der Anzeige von Umlauten unter KDE. Statt Sonderzeichen und Umlauten wurden Fragezeichen angezeigt.

Nach Versuchen mit Systemeinstellungen > Regionaleinstellungen wurde es noch schlechter! Die Ausgabe von locale unter KDE(!!!):

$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory                                                                                                              
locale: Cannot set LC_MESSAGES to default locale: No such file or directory                                                                                                           
locale: Cannot set LC_ALL to default locale: No such file or directory                                                                                                                
LANG=de_DE.US-ASCII
...

Natürlich habe ich mehrfach meine /etc/locale.conf, /etc/vconsole.conf, /etc/locale.gen und ~/.config/locale.conf (war nicht vorhanden) geprüft. Nichts!

Als Workaround sollte dann

cat ~/.xinitrc 
#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
...
setxkbmap de
export LC_ALL=de_DE.UTF-8
export MM_CHARSET=UTF-8
export LANG=de_DE.UTF-8
export LANGUAGE=de_DE.UTF-8
export BROWSER=firefox
...
exec dbus-launch --exit-with-session startkde

helfen, tat es aber nicht.

LÖSUNG: In der ~/.config/plasma-localerc und ~/.config/plasma-locale-settings.sh hatte  KDE tatsächlich de_DE.US-ASCII eingetragen. Seit dem Löschen dieser beiden Dateien ist alles wieder i.O.

Jedenfalls hat plasma bzw. KDE an dieser Stelle noch einen Bug. Vielleicht kann das ja jemand an der passenden Stelle melden.

Beitrag geändert von kama (12.10.2017 13:39:17)

Offline

#2 12.10.2017 14:39:27

Icecube63
Mitglied

Re: [gelöst] Hatte Probleme mit Umlauten und Sonderzeichen in plasma (KDE)

kama schrieb:

In der ~/.config/plasma-localerc und ~/.config/plasma-locale-settings.sh hatte  KDE tatsächlich de_DE.US-ASCII eingetragen. Seit dem Löschen dieser beiden Dateien ist alles wieder i.O.

Jedenfalls hat plasma bzw. KDE an dieser Stelle noch einen Bug. Vielleicht kann das ja jemand an der passenden Stelle melden.

Kein Bug, bei mir passt alless:

cat ~/.config/plasma-localerc
[Formats]
LANG=de_DE.UTF-8


cat ~/.config/plasma-locale-settings.sh
# Generated script, do not edit
# Exports language-format specific env vars from startkde.
# This script has been generated from kcmshell5 formats.
# It will automatically be overwritten from there.
export LANG=de_DE.UTF-8
export LANGUAGE=de

Offline

#3 12.10.2017 20:43:30

kama
Mitglied

Re: [gelöst] Hatte Probleme mit Umlauten und Sonderzeichen in plasma (KDE)

Nach dem Löschen wurde die Datei neu angelegt. Rate, was jetzt dort steht:

cat ~/.config/plasma-localerc
[Formats]
LANG=de_DE.UTF-8

Diese Datei habe ich nie editiert und schon gar nicht de_DE.US-ASCII eingetragen, eine offensichtlich nicht existierende Sprache. Dort sind nur Einträge sinnvoll, die auch in der /etc/locale.gen existieren.

Also definitiv ein Bug, wenn Systemeinstellungen > Regionaleinstellungen dort Müll einträgt.

Offline

#4 12.10.2017 22:41:07

Icecube63
Mitglied

Re: [gelöst] Hatte Probleme mit Umlauten und Sonderzeichen in plasma (KDE)

kama schrieb:

Also definitiv ein Bug, wenn Systemeinstellungen > Regionaleinstellungen dort Müll einträgt.

Da das wohl nur bei dir so ist: nein

Offline

#5 13.10.2017 01:32:00

k.osmo
Mitglied

Re: [gelöst] Hatte Probleme mit Umlauten und Sonderzeichen in plasma (KDE)

möglicherweise in Zusammenhang –> https://github.com/systemd/systemd/issues/6407
Mit meinem Setup hatte ich Probleme mit dem Zeichensatz in der Konsole, musste manuell jedesmal von Western ISO-8859 auf UTF-8 umstellen. Danke für den Tipp!

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums