#1 09.10.2017 09:23:35

ManfredB
Mitglied

[gelöst] WLAN zu Hause geht, im Urlaub nicht

Hallo zusammen,
ich nehme in meinen Urlaub mein Notebook mit. Gründe sind nebensächlich.

Im Ferienhaus gibt es keinen WLAN-Anschluss, den haben wir uns von Vodafone mit GigaCube geholt.

Die Smartphones verbinden sich automatisch mit dem WLAN. Und auf meinem Notebook habe ich neben
ArchLinux noch PCLinuxOS-KDE4. Letzteres verbindet sich von alleine mit dem WLAN, weil es im Frühjahr auf GigaCube eingerichtet wurde.

Doch wenn ich jetzt mit ArchLinux versuche, diese WLAN-Verbindung zu aktivieren, bekomme ich dauernd die Nachfrage nach dem Passwort, das ich eingebe, aber keine Verbindung kommt zustande.

Vor allem lautet die WLAN-Verbindung genauso wie zu Hause: wlp2s0.

Wie kann ich es hinbekommen, daß auch ArchLinux den Zugang herstellt.

Meine Versuche, das Problem zu lösen, sahen so aus:
1. systemctl disable wpa_supplicant
2. In der Datei /etc/wpa_supplicant habe ich den Zugang von zuhause deaktiviert mit # und den neuen eingetragen.
3. systemctl enable wpa_supplicant
4. systemctl start wpa_supplicant

Doch wenn ich in der Taskleiste das Symbol für WLAN anklicke, erscheint zwar der Name des neuen WLAN-Zugangs,
doch ich werde aufgefordert, das Paßwort einzugeben, was ich auch mache. Dann sehe ich um das Symbol in der Taskleiste herum einen hellen Kreis, der sich dreht, doch kurze Zeit später werde ich wieder aufgefordert, das Paßwort einzugeben,
das mache ich ununterbrochen, doch die Verbindung kommt nicht zustande.

Warum hat PCLinuxOS die Verbindung, ArchLinux aber bekommt sie nicht.

Problem ist nämlich, daß ich in PCLinuxOS keinerlei Konfiguration mehr vornehmen kann, das System ist noch KDE4,
bekommt keine Updates mehr und ist fast nicht mehr zu gebrauchen. Außer eben per WLAN ins Netz.

Darum will ich ArchLinux gerne als Basis-System einrichten, zuhause hat das ja alles geklappt.
Aber hier nicht.

Hat jemand einen Tipp oder sogar Hilfe anzubieten?

Danke im voraus.

Gruß
Manfred

Beitrag geändert von ManfredB (12.10.2017 15:51:00)

Offline

#2 09.10.2017 09:46:01

Schard-nologin
Gast

Re: [gelöst] WLAN zu Hause geht, im Urlaub nicht

1) Die Konfigurationen in /etc/wpa_supplicant sind bei Benutzung des NetworkManager irrelevant.
2) Gib bitte den Inhalt der entsprechenden Logfiles an.
3) Wenn nach dem Passwort gefragt wird hast du mit hoher Wahrscheinlichkeit ein falsche Passwort eingeben.
Das kann an einer falschen Tastatureinstellung liegen, oder daran, dass nebst dem Networkmanager eine Instanz von wpa_supplicant mit abweichender Konfiguration läuft.

#3 09.10.2017 10:45:01

ManfredB
Mitglied

Re: [gelöst] WLAN zu Hause geht, im Urlaub nicht

Welche logfiles?

In /var/log gibt es dazu keine logfiles.

Und wie startet man den Networkmanager?

Ich merke, daß ich noch nicht alles von ArchLinux weiß.

Gruß
Manfred

Offline

#4 09.10.2017 11:13:30

hcjl
Mitglied

Re: [gelöst] WLAN zu Hause geht, im Urlaub nicht

ManfredB schrieb:

Und wie startet man den Networkmanager?

Wie es im Wiki beschrieben ist.

Offline

#5 09.10.2017 11:24:44

Schard-nologin
Gast

Re: [gelöst] WLAN zu Hause geht, im Urlaub nicht

ManfredB schrieb:

Welche logfiles?

journalctl -b -au NetworkManager --no-pager
ManfredB schrieb:

In /var/log gibt es dazu keine logfiles.

Doch. Die Journale werden defaultmäßig in /var/log/journal im Binärformat gespeichert und können mittels journalctl wie oben ausgelesen werden.

ManfredB schrieb:

Und wie startet man den Networkmanager?

Ich bin aufgrund deiner Beschreibung deines Vorgehens, dich per GUI mit einem WLAN Netzwerk zu verbinden davon ausgegangen, dass du NetworkManager mit einem zugehörigen Applet benutzt.
Ob dies wirklich der Fall ist kannst nur du uns sagen.

#6 09.10.2017 13:46:42

ManfredB
Mitglied

Re: [gelöst] WLAN zu Hause geht, im Urlaub nicht

Zunächst einmal ein herzliches Dankeschön für deine Geduld.
Da ich immer wieder unterwegs bin, kann ich nicht so schnell reagieren.

Aber was ich jetzt gelesen habe, werde ich heute nachmittag überprüfen
und dann hier beschreiben bzw. liefern.

Bis dahin
Gruß
Manfred

Offline

#7 09.10.2017 15:14:58

ManfredB
Mitglied

Re: [gelöst] WLAN zu Hause geht, im Urlaub nicht

Hier nun die logfiles:

journalctl -b -au NetworkManager --no-pager
-- Logs begin at Sun 2017-09-10 17:36:21 CEST, end at Tue 2017-10-10 15:03:51 CEST. --
Okt 10 15:00:34 pustel systemd[1]: Starting Network Manager...
Okt 10 15:00:35 pustel NetworkManager[274]: <info>  [1507640435.9366] NetworkManager (version 1.8.4-1, Arch Linux) is starting... (for the first time)
Okt 10 15:00:35 pustel NetworkManager[274]: <info>  [1507640435.9368] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity.conf)
Okt 10 15:00:35 pustel NetworkManager[274]: <info>  [1507640435.9879] manager[0x55b62a1a10c0]: monitoring kernel firmware directory '/usr/lib/firmware'.
Okt 10 15:00:35 pustel NetworkManager[274]: <info>  [1507640435.9902] policy: hostname management mode: default
Okt 10 15:00:35 pustel NetworkManager[274]: <info>  [1507640435.9910] dns-mgr[0x55b62a1ae970]: init: dns=default, rc-manager=resolvconf
Okt 10 15:00:35 pustel NetworkManager[274]: <info>  [1507640435.9931] rfkill0: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1c.1/0000:02:00.0/ieee80211/phy0/rfkill0) (driver ath9k)
Okt 10 15:00:35 pustel NetworkManager[274]: <info>  [1507640435.9935] manager[0x55b62a1a10c0]: rfkill: WiFi hardware radio set enabled
Okt 10 15:00:35 pustel NetworkManager[274]: <info>  [1507640435.9936] manager[0x55b62a1a10c0]: rfkill: WWAN hardware radio set enabled
Okt 10 15:00:35 pustel systemd[1]: Started Network Manager.
Okt 10 15:00:36 pustel NetworkManager[274]: <error> [1507640436.3437] dispatcher: could not get dispatcher proxy! Fehler beim Aufruf von StartServiceByName für org.freedesktop.nm_dispatcher: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.freedesktop.nm-dispatcher.service not found.
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.3440] settings: loaded plugin keyfile: (c) 2007 - 2016 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.4211] settings: loaded plugin iBFT: (c) 2014 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list. (/usr/lib/NetworkManager/libnm-settings-plugin-ibft.so)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.4829] keyfile: new connection /etc/NetworkManager/system-connections/UPC366FD53 (32739abd-f5cb-43af-b7ef-7498eb0d60da,"UPC366FD53")
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.7516] settings: hostname: using hostnamed
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.7517] settings: hostname changed from (none) to "pustel"
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.7856] dhcp-init: default DHCP client 'dhclient' is not available
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.7858] dhcp-init: Using DHCP client 'internal'
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.7859] manager: rfkill: WiFi enabled by radio killswitch; enabled by state file
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.7860] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.7860] manager: Networking is enabled by state file
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8033] Loaded device plugin: NMBondDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8034] Loaded device plugin: NMBridgeDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8035] Loaded device plugin: NMDummyDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8035] Loaded device plugin: NMEthernetDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8036] Loaded device plugin: NMInfinibandDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8037] Loaded device plugin: NMIPTunnelDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8038] Loaded device plugin: NMMacsecDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8098] Loaded device plugin: NMMacvlanDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8100] Loaded device plugin: NMTunDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8101] Loaded device plugin: NMVethDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8102] Loaded device plugin: NMVlanDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8103] Loaded device plugin: NMVxlanDeviceFactory (internal)
Okt 10 15:00:36 pustel NetworkManager[274]: <info>  [1507640436.8652] Loaded device plugin: NMWifiFactory (/usr/lib/NetworkManager/libnm-device-plugin-wifi.so)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.0169] Loaded device plugin: NMBluezManager (/usr/lib/NetworkManager/libnm-device-plugin-bluetooth.so)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.0447] Loaded device plugin: NMAtmManager (/usr/lib/NetworkManager/libnm-device-plugin-adsl.so)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.0760] Loaded device plugin: NMWwanFactory (/usr/lib/NetworkManager/libnm-device-plugin-wwan.so)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1423] Loaded device plugin: NMTeamFactory (/usr/lib/NetworkManager/libnm-device-plugin-team.so)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1555] device (lo): link connected
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1576] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/Devices/1)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1592] device (enp0s20u2): link connected
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1618] manager: (enp0s20u2): new Ethernet device (/org/freedesktop/NetworkManager/Devices/2)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1644] keyfile: add connection in-memory (47471fb0-95ed-3788-8c19-f909cf00f26c,"Kabelgebundene Verbindung 1")
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1657] settings: (enp0s20u2): created default wired connection 'Kabelgebundene Verbindung 1'
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1675] device (enp0s20u2): state change: unmanaged -> unavailable (reason 'managed', internal state 'external')
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1703] manager: (enp3s0f2): new Ethernet device (/org/freedesktop/NetworkManager/Devices/3)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1715] keyfile: add connection in-memory (46d6eb49-811c-39b3-9b6f-3ef315b3485a,"Kabelgebundene Verbindung 2")
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1722] settings: (enp3s0f2): created default wired connection 'Kabelgebundene Verbindung 2'
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1735] device (enp3s0f2): state change: unmanaged -> unavailable (reason 'managed', internal state 'external')
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1983] wifi-nl80211: (wlp2s0): using nl80211 for WiFi device control
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.1988] device (wlp2s0): driver supports Access Point (AP) mode
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.2008] manager: (wlp2s0): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/4)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.2027] device (wlp2s0): state change: unmanaged -> unavailable (reason 'managed', internal state 'external')
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.2166] device (wlp2s0): set-hw-addr: set MAC address to C6:5D:84:5D:0F:CB (scanning)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.3400] device (enp0s20u2): state change: unavailable -> disconnected (reason 'none', internal state 'managed')
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.3416] policy: auto-activating connection 'Kabelgebundene Verbindung 1'
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.3426] supplicant: wpa_supplicant running
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.3427] device (wlp2s0): supplicant interface state: init -> starting
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.3435] device (enp0s20u2): Activation: starting connection 'Kabelgebundene Verbindung 1' (47471fb0-95ed-3788-8c19-f909cf00f26c)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.3439] device (enp0s20u2): state change: disconnected -> prepare (reason 'none', internal state 'managed')
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.3441] manager: NetworkManager state is now CONNECTING
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.3448] device (enp0s20u2): state change: prepare -> config (reason 'none', internal state 'managed')
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.3453] device (enp0s20u2): state change: config -> ip-config (reason 'none', internal state 'managed')
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.3458] dhcp4 (enp0s20u2): activation: beginning transaction (timeout in 45 seconds)
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.8834] sup-iface[0x55b62a250710,wlp2s0]: supports 4 scan SSIDs
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.8853] device (wlp2s0): supplicant interface state: starting -> ready
Okt 10 15:00:37 pustel NetworkManager[274]: <info>  [1507640437.8854] device (wlp2s0): state change: unavailable -> disconnected (reason 'supplicant-available', internal state 'managed')
Okt 10 15:00:38 pustel NetworkManager[274]: <info>  [1507640438.9842] device (wlp2s0): supplicant interface state: ready -> inactive
Okt 10 15:00:39 pustel NetworkManager[274]: <info>  [1507640439.6238] dhcp6 (enp0s20u2): activation: beginning transaction (timeout in 45 seconds)
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5220] dhcp6 (enp0s20u2):   nameserver fe80::b48d:fdff:fe51:6aec
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5221] dhcp6 (enp0s20u2): state changed unknown -> bound
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5762] dhcp4 (enp0s20u2):   address 192.168.42.122
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5763] dhcp4 (enp0s20u2):   plen 24
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5764] dhcp4 (enp0s20u2):   expires in 3600 seconds
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5764] dhcp4 (enp0s20u2):   nameserver '192.168.42.129'
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5765] dhcp4 (enp0s20u2):   hostname 'pustel'
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5765] dhcp4 (enp0s20u2):   gateway 192.168.42.129
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5769] dhcp4 (enp0s20u2): state changed unknown -> bound
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5795] device (enp0s20u2): state change: ip-config -> ip-check (reason 'none', internal state 'managed')
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5810] device (enp0s20u2): state change: ip-check -> secondaries (reason 'none', internal state 'managed')
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5820] device (enp0s20u2): state change: secondaries -> activated (reason 'none', internal state 'managed')
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5826] manager: NetworkManager state is now CONNECTED_LOCAL
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5983] manager: NetworkManager state is now CONNECTED_SITE
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5985] policy: set 'Kabelgebundene Verbindung 1' (enp0s20u2) as default for IPv4 routing and DNS
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5987] policy: set 'Kabelgebundene Verbindung 1' (enp0s20u2) as default for IPv6 routing and DNS
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.5988] dns-mgr: Writing DNS information to /usr/bin/resolvconf
Okt 10 15:00:40 pustel NetworkManager[274]: <info>  [1507640440.6935] device (enp0s20u2): Activation: successful, device activated.
Okt 10 15:00:41 pustel NetworkManager[274]: <info>  [1507640441.8795] manager: NetworkManager state is now CONNECTED_GLOBAL
Okt 10 15:00:42 pustel NetworkManager[274]: <info>  [1507640442.5805] manager: startup complete
Okt 09 15:06:43 pustel NetworkManager[274]: <info>  [1507554403.1023] device (wlp2s0): set-hw-addr: set MAC address to C2:F0:C6:6D:37:82 (scanning)
Okt 09 15:06:43 pustel NetworkManager[274]: <info>  [1507554403.1188] device (wlp2s0): supplicant interface state: inactive -> disabled
Okt 09 15:06:43 pustel NetworkManager[274]: <info>  [1507554403.1194] device (wlp2s0): supplicant interface state: disabled -> inactive

Anmerkung: ich habe - um das hier möglich zu machen - mein Smartphone als Hotspot eingerichtet.
Nur so kann ich das nur erledigen und liefern.
Ich hoffe, daraus geht schon einiges hervor, was auf Fehler meinerseits hinweist.

Gruß
Manfred

Offline

#8 09.10.2017 16:07:36

Schard-nologin
Gast

Re: [gelöst] WLAN zu Hause geht, im Urlaub nicht

Zeig bitte nochmal die Ausgabe von

for SERVICE in $(pacman -Ql wpa_supplicant | grep systemd.*\.service | cut -d "/" -f 6); do echo -ne "${SERVICE}\tis "; systemctl is-enabled ${SERVICE}; done

#9 09.10.2017 16:39:40

ManfredB
Mitglied

Re: [gelöst] WLAN zu Hause geht, im Urlaub nicht

wpa_supplicant-nl80211@.service is disabled
wpa_supplicant-wired@.service   is disabled
wpa_supplicant.service  is enabled
wpa_supplicant@.service is disabled

Offline

#10 09.10.2017 16:57:24

Schard-nologin
Gast

Re: [gelöst] WLAN zu Hause geht, im Urlaub nicht

Dann bitte

systemctl disable wpa_supplicant.service
reboot

#11 12.10.2017 15:50:22

ManfredB
Mitglied

Re: [gelöst] WLAN zu Hause geht, im Urlaub nicht

Nach langer Suche nach einer Lösung habe ich es heute geschafft.

Ich habe erst die GigaCube-Box mit Notebook per Kabel verbunden.
Dann die Einstellungsseite im Internet aufgesucht, mich eingeloggt und dann den Zugang noch einmal
konfiguriert.
Und was ich dann kaum glauben wollte: als ich "übernehmen" angeklickt habe,
und in der Taskleiste nach wlp2s0 und gigacube-E17D geschaut und "verbinden" angeklickt habe,
sah ich plötzlich, daß die Verbindung stand.

Sofort Kabel entfernt - und nun ist das WLAN-Symbol in der Taskleiste sichtbar.

Damit ist das Problem gelöst. Und ich weiß nun, daß ich es mit der AdminSeite der Box schaffen kann
auch bei anderen Distributionen.

Gruß
Manfred

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums