Du bist nicht angemeldet.

#1 07.10.2016 17:30:25

xunil
Mitglied

Aktualisierung geht nicht mehr

Hallo zusammen,

seit ein paar Tagen funktioniert bei mir die Aktualisierung nicht mehr. Ich bekomme folgende Fehlermeldung:

$ sudo pacman -Syu
Fehler: GPGME error: Keine Daten
:: Synchronisiere Paketdatenbanken...
 xorg116 ist aktuell
 core                                                                                                 120,4 KiB  2,06M/s 00:00 [#############################################################################] 100%
 extra                                                                                               1754,4 KiB  19,7M/s 00:00 [#############################################################################] 100%
 community                                                                                              3,6 MiB  33,0M/s 00:00 [#############################################################################] 100%
 multilib                                                                                             183,2 KiB  25,6M/s 00:00 [#############################################################################] 100%
 archlinuxfr ist aktuell
 catalyst-stable                                                                                        6,3 KiB  36,6K/s 00:00 [#############################################################################] 100%
 catalyst-stable.sig                                                                                    6,3 KiB  0,00B/s 00:00 [#############################################################################] 100%
Fehler: GPGME error: Keine Daten
Fehler: Konnte catalyst-stable nicht aktualisieren (Ungültige oder beschädigte Datenbank (PGP-Signatur))
Fehler: Datenbank 'catalyst-stable' ist nicht gültig (Ungültige oder beschädigte Datenbank (PGP-Signatur))

Ein Auszug aus meiner /etc/pacman.conf:

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/$arch

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

[catalyst-stable]
#Server=http://catalyst.wirephire.com/repo/catalyst/$arch
Server=http://mirror.hactar.bz/Vi0L0/catalyst/$arch

Kann mir da jemand weiterhelfen? Danke!

Offline

#2 07.10.2016 18:18:20

Icecube63
Mitglied

Re: Aktualisierung geht nicht mehr

xunil schrieb:

Kann mir da jemand weiterhelfen? Danke!

Mal im Forum geschaut/gesucht? Ähnliches gabs kürzlich erst, und das catalyst-Problem auch schon öfter

Offline

#3 07.10.2016 21:22:49

xunil
Mitglied

Re: Aktualisierung geht nicht mehr

Hab schon mehrere Sachen versucht, wie sie z.B.: auch hier empfohlen werden: --> https://bbs.archlinux.de/viewtopic.php?id=28677
Aber vielleicht hab ich auch einfach nicht den richtigen Thread gefunden.

Offline

#4 08.10.2016 15:54:06

Icecube63
Mitglied

Re: Aktualisierung geht nicht mehr

Hier war ein ähnliches Problem. Bei dir scheints aber an den catalyst-Repos zu liegen, also kommentiere die mal aus und mache dein Update erstmal ohne diese.

Du kannst dann ja mal den anderen Server ausprobieren. Im englischen Wiki stehen da aber andere Server, vllt liegts ja auch daran.

Offline

#5 08.10.2016 21:40:43

xunil
Mitglied

Re: Aktualisierung geht nicht mehr

Thanks, I tried it but now I get this error:

:: Synchronisiere Paketdatenbanken...
 xorg116 ist aktuell
 core                                                                                                 120,1 KiB  2,09M/s 00:00 [#############################################################################] 100%
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
 archlinuxfr ist aktuell
Fehler: Konnte catalyst-stable nicht aktualisieren (Es sind keine Server für dieses Repositorium definiert)
:: Starte vollständige Systemaktualisierung...
Warnung: catalyst-hook: Lokale Version (15.9-12) ist neuer als catalyst-stable (15.9-11)
:: kdegraphics-kolourpaint durch extra/kolourpaint ersetzen? [J/n] 
:: libgcrypt11 durch community/libgcrypt15 ersetzen? [J/n] 
Warnung: xf86-input-evdev: Lokale Version (2.9.2-1) ist neuer als xorg116 (2.9.1-1)
Warnung: xorg-server-common: Lokale Version (1.17.1-5) ist neuer als xorg116 (1.16.4-1)
Löse Abhängigkeiten auf...
:: Es stehen 2 Provider für phonon-qt5-backend zur Verfügung:
:: Repositorium extra
   1) phonon-qt5-gstreamer  2) phonon-qt5-vlc

Geben Sie eine Zahl ein (Voreinstellung=1): 1
Suche nach in Konflikt stehenden Paketen...
:: qt5-base und qtchooser stehen miteinander in Konflikt. qtchooser entfernen? [j/N] 
Fehler: Nicht auflösbare Paketkonflikte gefunden
Fehler: Konnte den Vorgang nicht vorbereiten (In Konflikt stehende Abhängigkeiten)
:: qt5-base und qtchooser stehen miteinander in Konflikt

Offline

#6 09.10.2016 09:24:13

stefanhusmann
Moderator

Re: Aktualisierung geht nicht mehr

Beim Auskommentieren des  catalyst-Repos muss etwas schief gegangen sein. Es wird weiterhin vesucht, das Repo einzubinden, dies schlägt aber fehl, da keine Server benannt sind. Vermutlich hast du nur den Eintrag

Server = ...

auskommentiert, nicht aber den davor stehenden Eintrag in eckigen Klammern.

Daher rührt

Fehler: Konnte catalyst-stable nicht aktualisieren (Es sind keine Server für dieses Repositorium definiert)

Des Weiteren ist da offenbar noc ein weiteres Repo xorg116 eingebunden, das nicht offiziell ist. Warum? Wenn dafür keie guten Gründe sprechen, raus damit aus der pacman.conf. Und im englischen Forum wird grundsätzlich von der Einbindung des archlinuxfr-Repos abgeraten.

:: Es stehen 2 Provider für phonon-qt5-backend zur Verfügung:
:: Repositorium extra
   1) phonon-qt5-gstreamer  2) phonon-qt5-vlc

Hier eine Alternative auswählen. Ich würde erstere wählen.

:: qt5-base und qtchooser stehen miteinander in Konflikt. qtchooser entfernen? [j/N] 

Ja sagen, da qtchooser aus den Repos entfernt wurde.

Offline

#7 13.10.2016 01:43:31

xunil
Mitglied

Re: Aktualisierung geht nicht mehr

Leider bekomme ich dann folgende Meldung:

:: Synchronisiere Paketdatenbanken...
 xorg116 ist aktuell
 core                                                                                                 120,6 KiB  2,10M/s 00:00 [#############################################################################] 100%
 extra                                                                                               1759,9 KiB  24,6M/s 00:00 [#############################################################################] 100%
 community                                                                                              3,6 MiB  68,6M/s 00:00 [#############################################################################] 100%
 multilib                                                                                             183,8 KiB  59,8M/s 00:00 [#############################################################################] 100%
 archlinuxfr                                                                                           14,2 KiB  1090K/s 00:00 [#############################################################################] 100%
:: Starte vollständige Systemaktualisierung...
:: kdegraphics-kolourpaint durch extra/kolourpaint ersetzen? [J/n] 
:: libgcrypt11 durch community/libgcrypt15 ersetzen? [J/n] 
Warnung: xf86-input-evdev: Lokale Version (2.9.2-1) ist neuer als xorg116 (2.9.1-1)
Warnung: xorg-server-common: Lokale Version (1.17.1-5) ist neuer als xorg116 (1.16.4-1)
Löse Abhängigkeiten auf...
:: Es stehen 2 Provider für phonon-qt5-backend zur Verfügung:
:: Repositorium extra
   1) phonon-qt5-gstreamer  2) phonon-qt5-vlc

Geben Sie eine Zahl ein (Voreinstellung=1): 1
Suche nach in Konflikt stehenden Paketen...
:: qt5-base und qtchooser stehen miteinander in Konflikt. qtchooser entfernen? [j/N] j
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: megasync: das Entfernen von qtchooser löscht ein benötigtes Packet von 'qtchooser'
:: spotify-stable: das Entfernen von libgcrypt11 löscht ein benötigtes Packet von 'libgcrypt11'

Offline

#8 13.10.2016 13:11:29

matthias
Moderator

Re: Aktualisierung geht nicht mehr

Wahrscheinlich stammen diese Pakete noch aus dem "bösen" Repo xorg116, das inzwischen nicht mehr existiert. http://catalyst.wirephire.com/repo/xorg116/$arch ergibt bei mir jedenfalls nur "404 Not Found" (Gott sei Dank - hat offenkundig eh' nix getaugt).

Zur Vorgeschichte sei nochmal auf diesen Thread desselben Nutzers verwiesen. Für xunil heisst dies zunächst mal: xorg116 rückstandsfrei aus /etc/pacman.conf löschen. Wenn überhaupt, hätte das dort auch niemals an erster Stelle stehen dürfen. Wir kommen hier auf das alte Grundproblem zurück, dass du offizielle Repos mit eher dubiosen Quellen vermischt hast (jetzt nutzt du schon wieder archlinux.fr - mein Gott, WOZU?).

Dann solltest du auch spotify-stable und megasync löschen. Wie niemand beschrieb, gibt's das nicht mehr. Wenn dich das Löschen dieser Pakete in Schwierigkeiten bringt, mach bitte dazu einen neuen Thread auf.

Was mich jetzt viel mehr interessiert: Wie verfährt Pacman mit nicht MEHR existierenden Repos. Bei einem nicht existierenden Repo käme die Meldung: Kenn ich nicht, gibt's nicht - klar. Stattdessen steht bei xunil: xorg116 ist aktuell. Die Datenbank des Repos liegt noch lokal auf xunils System, und daraus folgen Warnungen wie: XYZ ist neuer die Version in xorg116. Auch das ist logisch.

Aber Pacman sagt hier nicht. "xorg116 gibt's nicht", sondern "xorg116 ist aktuell". Ist aktuell bedeutet hier natürlich "keine neuen Pakete in der Datenbank", es gibt nichts zu aktualisieren, weil das Repo selbst schon ewig nicht aktualisiert wurde. Aber woher weiss Pacman das? Der kleine Scheisser kann ja echt viel, aber auch der sich nicht mit einem nicht existierenden Repo verbinden ...

Meinungen, Hintergründe?

PS: Das Blöde ist ja auch, das niemand dieses Problem reproduzieren kann, der nicht nicht zuerst xorg116 verwendet, dann deaktiviert, und dann wieder aktiviert hat. Wie soll man da 'ne Lösung finden?

Offline

#9 13.10.2016 18:29:46

drcux
Mitglied

Re: Aktualisierung geht nicht mehr

matthias schrieb:

Wahrscheinlich stammen diese Pakete noch aus dem "bösen" Repo xorg116, das inzwischen nicht mehr existiert. http://catalyst.wirephire.com/repo/xorg116/$arch ergibt bei mir jedenfalls nur "404 Not Found"


Dann ersetze $arch doch mal mit "x86_64" oder "i686".....

Offline

Schnellantwort auf dieses Thema

Schreibe deinen Beitrag und versende ihn
Deine Antwort

Fußzeile des Forums